aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-01-25 17:22:48 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-01-25 17:22:48 +0000
commit425d326baae5e13371f784481571914f4ccd1601 (patch)
treec0abe010524573851bf27d374d23d36fcbd70119
parentca63a16f5ced25bd5dc58383609ed8f6b5762e2a (diff)
downloadports-425d326baae5e13371f784481571914f4ccd1601.tar.gz
ports-425d326baae5e13371f784481571914f4ccd1601.zip
graphics/opencv: fix VSX detection
AT_HWCAP should be long.
-rw-r--r--graphics/opencv/Makefile1
-rw-r--r--graphics/opencv/files/patch-modules_core_src_system.cpp11
2 files changed, 12 insertions, 0 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 51e55a2c1e86..da23130c99cb 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -1,5 +1,6 @@
PORTNAME= opencv
DISTVERSION= 4.5.5
+PORTREVISION= 1
CATEGORIES= graphics
MAINTAINER= tcberner@FreeBSD.org
diff --git a/graphics/opencv/files/patch-modules_core_src_system.cpp b/graphics/opencv/files/patch-modules_core_src_system.cpp
new file mode 100644
index 000000000000..b4f88573d9cb
--- /dev/null
+++ b/graphics/opencv/files/patch-modules_core_src_system.cpp
@@ -0,0 +1,11 @@
+--- modules/core/src/system.cpp.orig 2022-01-25 17:17:25 UTC
++++ modules/core/src/system.cpp
+@@ -630,7 +630,7 @@ struct HWFeatures
+ }
+ }
+ #elif (defined __ppc64__ || defined __PPC64__) && defined __FreeBSD__
+- unsigned int hwcap = 0;
++ unsigned long hwcap = 0;
+ elf_aux_info(AT_HWCAP, &hwcap, sizeof(hwcap));
+ if (hwcap & PPC_FEATURE_HAS_VSX) {
+ elf_aux_info(AT_HWCAP2, &hwcap, sizeof(hwcap));