aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-06-04 00:50:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-06-04 00:54:01 +0000
commit429f3de9bdcd16057a17e0d678c4bf7350c59d47 (patch)
tree2fba64c98218a13e13739c8a33e53a3735f3c608
parent8efec5f24ae723f0051a63ae8f910efd16e18844 (diff)
downloadports-429f3de9bdcd16057a17e0d678c4bf7350c59d47.tar.gz
ports-429f3de9bdcd16057a17e0d678c4bf7350c59d47.zip
security/nettle: unbreak on aarch64 after c328d3ca8519
/usr/bin/cc -I. -isystem /usr/local/include -DHAVE_CONFIG_H -O2 -pipe -I/usr/include -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing -ggdb3 -Wall -W -Wno-sign-compare -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wpointer-arith -Wbad-function-cast -Wnested-externs -fpic -MT chacha-4core.o -MD -MP -MF chacha-4core.o.d -c chacha-4core.s chacha-4core.s:125:23: error: invalid operand for instruction add v24.4s, v24.4s, v160.4s ^ chacha-4core.s:126:7: error: invalid operand for instruction add v163.4s, v163.4s, v164.4s ^ chacha-4core.s:129:7: error: invalid operand for instruction eor v162.16b, v162.16b, v24.16b ^ chacha-4core.s:130:7: error: invalid operand for instruction eor v166.16b, v166.16b, v163.16b ^ chacha-4core.s:133:8: error: invalid operand for instruction rev32 v162.8h, v162.8h ^ chacha-4core.s:134:8: error: invalid operand for instruction rev32 v166.8h, v166.8h ^ chacha-4core.s:138:7: error: invalid operand for instruction add v161.4s, v161.4s, v162.4s ^ chacha-4core.s:139:7: error: invalid operand for instruction add v165.4s, v165.4s, v166.4s ^ chacha-4core.s:142:15: error: invalid operand for instruction eor v6.16b, v160.16b, v161.16b ^ chacha-4core.s:143:15: error: invalid operand for instruction eor v7.16b, v164.16b, v165.16b ^ chacha-4core.s:146:7: error: invalid operand for instruction ushr v160.4s, v6.4s, #20 ^ chacha-4core.s:147:7: error: invalid operand for instruction ushr v164.4s, v7.4s, #20 ^ chacha-4core.s:150:7: error: invalid operand for instruction sli v160.4s, v6.4s, #12 ^ chacha-4core.s:151:7: error: invalid operand for instruction sli v164.4s, v7.4s, #12 ^ chacha-4core.s:155:23: error: invalid operand for instruction add v24.4s, v24.4s, v160.4s ^ chacha-4core.s:156:7: error: invalid operand for instruction add v163.4s, v163.4s, v164.4s ^ chacha-4core.s:159:7: error: invalid operand for instruction eor v162.16b, v162.16b, v24.16b ^ chacha-4core.s:160:7: error: invalid operand for instruction eor v166.16b, v166.16b, v163.16b ^ chacha-4core.s:163:18: error: vector register expected tbl v162.16b, {v162.16b}, v8.16b ^ chacha-4core.s:163:26: error: unknown token in expression tbl v162.16b, {v162.16b}, v8.16b ^ chacha-4core.s:163:26: error: invalid operand tbl v162.16b, {v162.16b}, v8.16b ^ chacha-4core.s:164:18: error: vector register expected tbl v166.16b, {v166.16b}, v8.16b ^ chacha-4core.s:164:26: error: unknown token in expression tbl v166.16b, {v166.16b}, v8.16b ^ chacha-4core.s:164:26: error: invalid operand tbl v166.16b, {v166.16b}, v8.16b ^ chacha-4core.s:168:7: error: invalid operand for instruction add v161.4s, v161.4s, v162.4s ^ chacha-4core.s:169:7: error: invalid operand for instruction add v165.4s, v165.4s, v166.4s ^ chacha-4core.s:172:15: error: invalid operand for instruction eor v6.16b, v160.16b, v161.16b ^ chacha-4core.s:173:15: error: invalid operand for instruction eor v7.16b, v164.16b, v165.16b ^ chacha-4core.s:176:7: error: invalid operand for instruction ushr v160.4s, v6.4s, #25 ^ chacha-4core.s:177:7: error: invalid operand for instruction ushr v164.4s, v7.4s, #25 ^ chacha-4core.s:180:7: error: invalid operand for instruction sli v160.4s, v6.4s, #7 ^ chacha-4core.s:181:7: error: invalid operand for instruction sli v164.4s, v7.4s, #7 ^ chacha-4core.s:186:23: error: invalid operand for instruction add v24.4s, v24.4s, v160.4s ^ chacha-4core.s:187:7: error: invalid operand for instruction add v163.4s, v163.4s, v164.4s ^ chacha-4core.s:190:7: error: invalid operand for instruction eor v162.16b, v162.16b, v24.16b ^ chacha-4core.s:191:7: error: invalid operand for instruction eor v166.16b, v166.16b, v163.16b ^ chacha-4core.s:194:8: error: invalid operand for instruction rev32 v162.8h, v162.8h ^ chacha-4core.s:195:8: error: invalid operand for instruction rev32 v166.8h, v166.8h ^ chacha-4core.s:199:7: error: invalid operand for instruction add v161.4s, v161.4s, v162.4s ^ chacha-4core.s:200:7: error: invalid operand for instruction add v165.4s, v165.4s, v166.4s ^ chacha-4core.s:203:15: error: invalid operand for instruction eor v6.16b, v160.16b, v161.16b ^ chacha-4core.s:204:15: error: invalid operand for instruction eor v7.16b, v164.16b, v165.16b ^ chacha-4core.s:207:7: error: invalid operand for instruction ushr v160.4s, v6.4s, #20 ^ chacha-4core.s:208:7: error: invalid operand for instruction ushr v164.4s, v7.4s, #20 ^ chacha-4core.s:211:7: error: invalid operand for instruction sli v160.4s, v6.4s, #12 ^ chacha-4core.s:212:7: error: invalid operand for instruction sli v164.4s, v7.4s, #12 ^ chacha-4core.s:216:23: error: invalid operand for instruction add v24.4s, v24.4s, v160.4s ^ chacha-4core.s:217:7: error: invalid operand for instruction add v163.4s, v163.4s, v164.4s ^ chacha-4core.s:220:7: error: invalid operand for instruction eor v162.16b, v162.16b, v24.16b ^ chacha-4core.s:221:7: error: invalid operand for instruction eor v166.16b, v166.16b, v163.16b ^ chacha-4core.s:224:18: error: vector register expected tbl v162.16b, {v162.16b}, v8.16b ^ chacha-4core.s:224:26: error: unknown token in expression tbl v162.16b, {v162.16b}, v8.16b ^ chacha-4core.s:224:26: error: invalid operand tbl v162.16b, {v162.16b}, v8.16b ^ chacha-4core.s:225:18: error: vector register expected tbl v166.16b, {v166.16b}, v8.16b ^ chacha-4core.s:225:26: error: unknown token in expression tbl v166.16b, {v166.16b}, v8.16b ^ chacha-4core.s:225:26: error: invalid operand tbl v166.16b, {v166.16b}, v8.16b ^ chacha-4core.s:229:7: error: invalid operand for instruction add v161.4s, v161.4s, v162.4s ^ chacha-4core.s:230:7: error: invalid operand for instruction add v165.4s, v165.4s, v166.4s ^ chacha-4core.s:233:15: error: invalid operand for instruction eor v6.16b, v160.16b, v161.16b ^ chacha-4core.s:234:15: error: invalid operand for instruction eor v7.16b, v164.16b, v165.16b ^ chacha-4core.s:237:7: error: invalid operand for instruction ushr v160.4s, v6.4s, #25 ^ chacha-4core.s:238:7: error: invalid operand for instruction ushr v164.4s, v7.4s, #25 ^ chacha-4core.s:241:7: error: invalid operand for instruction sli v160.4s, v6.4s, #7 ^ chacha-4core.s:242:7: error: invalid operand for instruction sli v164.4s, v7.4s, #7 ^
-rw-r--r--security/nettle/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 2242322e6c36..c3196b222ad4 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -36,6 +36,10 @@ EXAMPLES_USES= ssl
.include <bsd.port.options.mk>
+.if ${ARCH} == "aarch64"
+CONFIGURE_ARGS+=--disable-assembler
+.endif
+
.if ${ARCH} == "sparc64"
CONFIGURE_ENV+= CCPIC=-fPIC
.endif