aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-23 13:43:52 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-23 13:43:52 +0000
commit433ab1934e9fc370e6c26324b7115b2ae69df4fd (patch)
tree1ee330b3813d4c246d3522de642135d91e032861
parent21e6d85ac3d857ac80809dbaac3f919e41afe1e7 (diff)
downloadports-433ab1934e9fc370e6c26324b7115b2ae69df4fd.tar.gz
ports-433ab1934e9fc370e6c26324b7115b2ae69df4fd.zip
Add py-statgrab 0.1, a set of Python bindings for libstatgrab.
PR: ports/64539 Submitted by: Tim Bishop <tim@bishnet.net>
Notes
Notes: svn path=/head/; revision=105044
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-statgrab/Makefile28
-rw-r--r--devel/py-statgrab/distinfo2
-rw-r--r--devel/py-statgrab/pkg-descr3
-rw-r--r--devel/py-statgrab/pkg-plist4
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 94adc48e7a79..3328596a6ac6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1025,6 +1025,7 @@
SUBDIR += py-simpleparse
SUBDIR += py-sip
SUBDIR += py-spark
+ SUBDIR += py-statgrab
SUBDIR += py-tables
SUBDIR += py-twisted
SUBDIR += py-ui
diff --git a/devel/py-statgrab/Makefile b/devel/py-statgrab/Makefile
new file mode 100644
index 000000000000..827f6a1f729a
--- /dev/null
+++ b/devel/py-statgrab/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: py-statgrab
+# Date created: 20 March 2004
+# Whom: Tim Bishop <tim@bishnet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= statgrab
+PORTVERSION= 0.1
+CATEGORIES= devel python
+MASTER_SITES= ftp://ftp.mirror.ac.uk/sites/ftp.i-scream.org/pub/i-scream/%SUBDIR%/ \
+ http://www.mirror.ac.uk/sites/ftp.i-scream.org/pub/i-scream/%SUBDIR%/ \
+ ftp://ftp.i-scream.org/pub/i-scream/%SUBDIR%/ \
+ http://www.i-scream.org/pub/i-scream/%SUBDIR%/
+MASTER_SITE_SUBDIR= py${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= tim@bishnet.net
+COMMENT= A set of Python bindings for libstatgrab
+
+LIB_DEPENDS= statgrab.4:${PORTSDIR}/devel/libstatgrab
+
+DIST_SUBDIR= i-scream
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-statgrab/distinfo b/devel/py-statgrab/distinfo
new file mode 100644
index 000000000000..9502e63d2e00
--- /dev/null
+++ b/devel/py-statgrab/distinfo
@@ -0,0 +1,2 @@
+MD5 (i-scream/pystatgrab-0.1.tar.gz) = 47a1711745111a49bd59ec03332e0ff8
+SIZE (i-scream/pystatgrab-0.1.tar.gz) = 20668
diff --git a/devel/py-statgrab/pkg-descr b/devel/py-statgrab/pkg-descr
new file mode 100644
index 000000000000..518b53eee8b2
--- /dev/null
+++ b/devel/py-statgrab/pkg-descr
@@ -0,0 +1,3 @@
+pystatgrab contains a set of python bindings for the libstatgrab library.
+
+WWW: http://www.i-scream.org/libstatgrab/
diff --git a/devel/py-statgrab/pkg-plist b/devel/py-statgrab/pkg-plist
new file mode 100644
index 000000000000..5c2e3a1c5b35
--- /dev/null
+++ b/devel/py-statgrab/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/_statgrab.so
+%%PYTHON_SITELIBDIR%%/statgrab.py
+%%PYTHON_SITELIBDIR%%/statgrab.pyc
+%%PYTHON_SITELIBDIR%%/statgrab.pyo