aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-12 11:50:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-12 11:50:40 +0000
commit433ac546cbc28293b5e0489ac891ee4c224ac800 (patch)
treef92c297eaf858b674ec0d03aec3be3f78bc41f56
parent8a5176cb1d453be3751db8a75661f973aa6a1228 (diff)
downloadports-433ac546cbc28293b5e0489ac891ee4c224ac800.tar.gz
ports-433ac546cbc28293b5e0489ac891ee4c224ac800.zip
Sud is a daemon to execute interactive and non-interactive processes with
special (and customizable) privileges in a nosuid environment. It is based on a client/server model and on the ability to pass file descriptors between processes. PR: ports/88354 Submitted by: Vaida Bogdan <vaidab@phenix.rootshell.be>
Notes
Notes: svn path=/head/; revision=148020
-rw-r--r--security/Makefile1
-rw-r--r--security/sud/Makefile41
-rw-r--r--security/sud/distinfo3
-rw-r--r--security/sud/pkg-descr9
-rw-r--r--security/sud/pkg-plist8
5 files changed, 62 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b45c10ff8103..7398a69ebdb2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -524,6 +524,7 @@
SUBDIR += strobe
SUBDIR += stunnel
SUBDIR += subweb
+ SUBDIR += sud
SUBDIR += sudo
SUBDIR += sudoscript
SUBDIR += sudosh
diff --git a/security/sud/Makefile b/security/sud/Makefile
new file mode 100644
index 000000000000..b4d0c5e97c67
--- /dev/null
+++ b/security/sud/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: sud
+# Date created: 20 Sep 2004
+# Whom: bugghy <bugghy@SAFe-mail.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sud
+PORTVERSION= 1.3
+CATEGORIES= security sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bugghy@SAFe-mail.net
+COMMENT= Execute processes with special privileges in a nosuid environment
+
+GNU_CONFIGURE= yes
+MAN1= sud.1 suz.1 ilogin.1
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' \
+ ${WRKSRC}/ilogin.1 ${WRKSRC}/sud.1 ${WRKSRC}/login/login.c ${WRKSRC}/sud/main.c
+ @${REINPLACE_CMD} -e 's|/usr/sbin/ilogin|${PREFIX}/ilogin| ; s|/usr/bin/ls|/bin/ls|' \
+ ${WRKSRC}/miscs/sud.conf.sample
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL_MAN} ${WRKSRC}/sud.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/suz.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/ilogin.1 ${MAN1PREFIX}/man/man1
+.endif
+
+.for i in issue.suz motd.suz sud.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/miscs/${i} ${PREFIX}/etc
+.endfor
+ @if [ ! -f ${PREFIX}/etc/sud.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/sud.conf.sample ${PREFIX}/etc/sud.conf ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/sud/distinfo b/security/sud/distinfo
new file mode 100644
index 000000000000..ffa2ffdbffb2
--- /dev/null
+++ b/security/sud/distinfo
@@ -0,0 +1,3 @@
+MD5 (sud-1.3.tar.gz) = f44ca2810ff72b84ad8a10cd62752098
+SHA256 (sud-1.3.tar.gz) = c4fdf9dfc7a58daf75cb37d2bc4d10d3767216e2b8e4861a87c2d274bac252a0
+SIZE (sud-1.3.tar.gz) = 117542
diff --git a/security/sud/pkg-descr b/security/sud/pkg-descr
new file mode 100644
index 000000000000..862e0e798ebe
--- /dev/null
+++ b/security/sud/pkg-descr
@@ -0,0 +1,9 @@
+Sud is a daemon to execute interactive and non-interactive
+processes with special (and customizable) privileges in a
+nosuid environment. It is based on a client/server model
+and on the ability to pass file descriptors between processes.
+
+WWW: http://sourceforge.net/projects/sud/
+
+- bugghy
+bugghy@SAFe-mail.net
diff --git a/security/sud/pkg-plist b/security/sud/pkg-plist
new file mode 100644
index 000000000000..6be92aac5ccf
--- /dev/null
+++ b/security/sud/pkg-plist
@@ -0,0 +1,8 @@
+bin/suz
+etc/issue.suz
+etc/motd.suz
+@unexec if cmp -s %D/etc/sud.conf.sample %D/etc/sud.conf; then rm -f %D/etc/sud.conf; fi
+etc/sud.conf.sample
+@exec if [ ! -f %D/etc/sud.conf ] ; then cp -p %D/%F %B/sud.conf; fi
+sbin/ilogin
+sbin/sud