aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarten <martenvdberg@hotmail.com>2023-04-13 08:10:55 +0000
committerChris Rees <crees@FreeBSD.org>2023-04-13 08:16:00 +0000
commit4353081bac0cb82f0590bf81800ac507f0cb75dd (patch)
tree6a0d70fbf330d45af260b92c0d38e80d5317fefe
parentee80e0dfbdbfb3cb294f6c853ef66f49d282f126 (diff)
downloadports-4353081bac0cb82f0590bf81800ac507f0cb75dd.tar.gz
ports-4353081bac0cb82f0590bf81800ac507f0cb75dd.zip
audio/oss: Save mixer before unloading module
After installing the oss package, a kernel panic occurs every time the computer is shut down. This is because the mixer RC script tries to save the mixer values after the OSS module is unloaded. We can avoid this by making OSS unload after this is done. [crees] While here, pet rclint. PR: ports/270709
-rw-r--r--audio/oss/Makefile2
-rw-r--r--audio/oss/files/oss.in12
2 files changed, 8 insertions, 6 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index da65d3e6b7da..5491461da85f 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -1,6 +1,6 @@
PORTNAME= oss
DISTVERSION= 4.2-build2019
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://www.opensound.com/developer/sources/stable/bsd/
DISTNAME= ${PORTNAME}-v${DISTVERSION}-src-bsd
diff --git a/audio/oss/files/oss.in b/audio/oss/files/oss.in
index 1ed49145aba2..413121acee0f 100644
--- a/audio/oss/files/oss.in
+++ b/audio/oss/files/oss.in
@@ -2,19 +2,21 @@
# PROVIDE: oss
# REQUIRE: DAEMON
+# BEFORE: mixer
# KEYWORD: nojail shutdown
. /etc/rc.subr
-name="oss"
+name=oss
rcvar=oss_enable
-
-stop_cmd="oss_stop"
-start_cmd="oss_start"
+desc="Load Open Sound System kernel modules"
load_rc_config $name
-: ${oss_enable=NO}
+: ${oss_enable:=NO}
+
+stop_cmd=oss_stop
+start_cmd=oss_start
oss_start()
{