aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 12:01:28 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 18:09:47 +0000
commit436f58ed00f575b04f793311477da4ae015edc94 (patch)
tree54543e2d386c7fada9235f23390285ef182febb7
parentde06f99a9c4fa7023cab2946cbcd5b0078d91073 (diff)
downloadports-436f58ed00f575b04f793311477da4ae015edc94.tar.gz
ports-436f58ed00f575b04f793311477da4ae015edc94.zip
java/jikes: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--java/jikes/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/java/jikes/Makefile b/java/jikes/Makefile
index 8d4db54cf8be..54e4adc31869 100644
--- a/java/jikes/Makefile
+++ b/java/jikes/Makefile
@@ -8,13 +8,18 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Java source to byte-code compiler made available by IBM
WWW= http://jikes.sf.net/
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+USES= autoreconf gmake iconv localbase tar:bzip2
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_search_iconv=${ICONV_LIB} \
ac_cv_search_libiconv_open=no
-USES= autoreconf iconv gmake tar:bzip2
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+PLIST_SUB= PORTVERSION=${PORTVERSION}
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CPPFLAGS+= -Dregister=
+.endif
.include <bsd.port.mk>