aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2024-04-05 09:34:46 +0000
committerNicola Vitale <nivit@FreeBSD.org>2024-04-05 09:34:46 +0000
commit43d3dde64f5ae9044d6279028d3fc5b25d82481f (patch)
tree1507d2e205f695e164099170ab1f0e08579db646
parent110a32afa6685567bb62148338d72d07a0624e1c (diff)
downloadports-43d3dde64f5ae9044d6279028d3fc5b25d82481f.tar.gz
ports-43d3dde64f5ae9044d6279028d3fc5b25d82481f.zip
devel/py-gptscript: Add new port
The GPTScript Python module is a library that provides a simple interface to create and run gptscripts within Python applications, and Jupyter notebooks. It allows you to define tools, execute them, and process the responses. https://github.com/gptscript-ai/py-gptscript
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-gptscript/Makefile33
-rw-r--r--devel/py-gptscript/distinfo3
-rw-r--r--devel/py-gptscript/pkg-descr3
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6fe17bf06f03..198365e2e022 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4789,6 +4789,7 @@
SUBDIR += py-google-pasta
SUBDIR += py-google-re2
SUBDIR += py-googleapis-common-protos
+ SUBDIR += py-gptscript
SUBDIR += py-gpxpy
SUBDIR += py-grab
SUBDIR += py-graphene
diff --git a/devel/py-gptscript/Makefile b/devel/py-gptscript/Makefile
new file mode 100644
index 000000000000..d7f34cbb3018
--- /dev/null
+++ b/devel/py-gptscript/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= gptscript
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Python module for running GPTScript
+WWW= https://github.com/gptscript-ai/py-gptscript/
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=40.9.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.43.0:devel/py-wheel@${PY_FLAVOR}
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}certifi>=2024.2.2:security/py-certifi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}charset-normalizer>=3.3.2:textproc/py-charset-normalizer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}idna>=3.6:dns/py-idna@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.31.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=4.66.2:misc/py-tqdm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=2.2.1:net/py-urllib3@${PY_FLAVOR} \
+ gptscript:lang/gptscript
+
+USES= python
+USE_GITHUB= yes
+
+GH_ACCOUNT= gptscript-ai
+GH_PROJECT= py-gptscript
+USE_PYTHON= autoplist pep517
+
+.include <bsd.port.mk>
diff --git a/devel/py-gptscript/distinfo b/devel/py-gptscript/distinfo
new file mode 100644
index 000000000000..55b252d1b040
--- /dev/null
+++ b/devel/py-gptscript/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1712308094
+SHA256 (gptscript-ai-py-gptscript-v0.4.1_GH0.tar.gz) = 01efa3cd5899aa8d4bdcd1ac1c49837b85d2074a1a1c5061a12d93f049056d66
+SIZE (gptscript-ai-py-gptscript-v0.4.1_GH0.tar.gz) = 12759
diff --git a/devel/py-gptscript/pkg-descr b/devel/py-gptscript/pkg-descr
new file mode 100644
index 000000000000..e3f998773d0c
--- /dev/null
+++ b/devel/py-gptscript/pkg-descr
@@ -0,0 +1,3 @@
+The GPTScript Python module is a library that provides a simple interface to
+create and run gptscripts within Python applications, and Jupyter notebooks. It
+allows you to define tools, execute them, and process the responses.