aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2023-08-01 14:20:22 +0000
committerWen Heping <wen@FreeBSD.org>2023-08-01 14:21:35 +0000
commit4409f4891a8fe2f7c547961ca57c00b2fb578c59 (patch)
treea9c1d0f8e92fc545a4d73d4e1782a9a1fb9ccdf7
parent80a1a60bbead12b52e4284965f3037ffd85e2770 (diff)
downloadports-4409f4891a8fe2f7c547961ca57c00b2fb578c59.tar.gz
ports-4409f4891a8fe2f7c547961ca57c00b2fb578c59.zip
math/givaro: Update to 4.2.0
PR: 272641 Reported by: wen@ Approved by: maintainer
-rw-r--r--math/givaro/Makefile5
-rw-r--r--math/givaro/distinfo6
-rw-r--r--math/givaro/files/patch-configure.ac17
-rw-r--r--math/givaro/pkg-plist7
4 files changed, 18 insertions, 17 deletions
diff --git a/math/givaro/Makefile b/math/givaro/Makefile
index e510c9dfab1f..ba924c8758a8 100644
--- a/math/givaro/Makefile
+++ b/math/givaro/Makefile
@@ -1,7 +1,6 @@
PORTNAME= givaro
-PORTVERSION= 4.1.1
+PORTVERSION= 4.2.0
DISTVERSIONPREFIX=v
-PORTREVISION= 3
CATEGORIES= math
MAINTAINER= pi@FreeBSD.org
@@ -15,7 +14,7 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libgmp.so:math/gmp
-USES= autoreconf compiler:c++11-lang gmake libtool pathfix pkgconfig
+USES= autoreconf compiler:c++11-lang gmake libtool localbase pathfix pkgconfig
USE_CXXSTD= c++11
USE_GITHUB= yes
GH_ACCOUNT= linbox-team
diff --git a/math/givaro/distinfo b/math/givaro/distinfo
index 1736bd31d7ea..6a5502692cc6 100644
--- a/math/givaro/distinfo
+++ b/math/givaro/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583962842
-SHA256 (linbox-team-givaro-v4.1.1_GH0.tar.gz) = d0cde67e7b29c5d6a0ba0afb52410a91bd0f7f2c2b14def1fe4f98b22b7494d7
-SIZE (linbox-team-givaro-v4.1.1_GH0.tar.gz) = 645424
+TIMESTAMP = 1690897251
+SHA256 (linbox-team-givaro-v4.2.0_GH0.tar.gz) = dca23a928e4704f045848fce884fe49ce09a8de7ebf750b87c807ca4e0facedd
+SIZE (linbox-team-givaro-v4.2.0_GH0.tar.gz) = 637479
diff --git a/math/givaro/files/patch-configure.ac b/math/givaro/files/patch-configure.ac
index 8e403236e6e0..467b392f1a1a 100644
--- a/math/givaro/files/patch-configure.ac
+++ b/math/givaro/files/patch-configure.ac
@@ -1,15 +1,14 @@
---- configure.ac.orig 2019-06-07 13:23:45 UTC
+--- configure.ac.orig 2023-07-20 23:09:18 UTC
+++ configure.ac
-@@ -49,11 +49,7 @@ AC_COMPILER_NAME
+@@ -48,10 +48,7 @@ AC_COMPILER_NAME
# We need a C++11 compiler now - AB 2014-12-12
# clang-3.8 does not support __float128 without explicitly passing it -std=c++11
--if test "x${CCNAM}" = "xclang38" ; then
-- AX_CXX_COMPILE_STDCXX_11([noext],[mandatory])
--else
-- AX_CXX_COMPILE_STDCXX_11([ext],[mandatory])
--fi
+-AS_IF([test "x${CCNAM}" = "xclang38"],
+- [AX_CXX_COMPILE_STDCXX_11([noext],[mandatory])],
+- [AX_CXX_COMPILE_STDCXX_11([ext],[mandatory])]
+- )
+AX_CXX_COMPILE_STDCXX_11([noext],[mandatory])
- REQUIRED_FLAGS="$CXX11FLAGS"
+ REQUIRED_FLAGS="${CXX11FLAGS}"
# Add the c++11 flags for the configure compilations as clang needs it to work properly with a glibc++ compiled with gcc
- BACKUP_CXXFLAGS="${CXXFLAGS}"
+ CXXFLAGS="${CXX11FLAGS} ${CXXFLAGS}"
diff --git a/math/givaro/pkg-plist b/math/givaro/pkg-plist
index 896131553393..9439e4d032ea 100644
--- a/math/givaro/pkg-plist
+++ b/math/givaro/pkg-plist
@@ -1,6 +1,5 @@
%%PORTDOCS%%%%DOCSDIR%%/givaro.html
bin/givaro-config
-bin/givaro-makefile
include/givaro-config.h
include/givaro/StaticElement.h
include/givaro/chineseremainder.h
@@ -113,9 +112,11 @@ include/givaro/givtablelimits.h
include/givaro/givtimer.h
include/givaro/givtruncdomain.h
include/givaro/givtruncdomain.inl
+include/givaro/givtypestring.h
include/givaro/givvectdenseops.inl
include/givaro/givvectdensespe.inl
include/givaro/givvector.h
+include/givaro/givvectordense.h
include/givaro/givvectordense.inl
include/givaro/givvectorsparse.h
include/givaro/givvectorsparse.inl
@@ -153,6 +154,7 @@ include/givaro/montgomery-int32.inl
include/givaro/montgomery-ruint.h
include/givaro/montgomery-ruint.inl
include/givaro/montgomery.h
+include/givaro/qfield.h
include/givaro/random-integer.h
include/givaro/ring-interface.h
include/givaro/udl.h
@@ -224,5 +226,6 @@ include/recint/rutools.h
lib/libgivaro.a
lib/libgivaro.so
lib/libgivaro.so.9
-lib/libgivaro.so.9.1.1
+lib/libgivaro.so.9.2.0
libdata/pkgconfig/givaro.pc
+%%DATADIR%%/givaro-makefile