aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:46:00 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:21:10 +0000
commit4444a6e8a0545ec0b3d08716b4d63a698418acae (patch)
tree11ab3765245112a5141227823d4204dc4cc4b039
parentb64df17bd4442b72827d13207ce9f3fa58c2af0a (diff)
downloadports-4444a6e8a0545ec0b3d08716b4d63a698418acae.tar.gz
ports-4444a6e8a0545ec0b3d08716b4d63a698418acae.zip
math/py-affine: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--math/py-affine/Makefile8
-rw-r--r--math/py-affine/files/setup.py26
2 files changed, 4 insertions, 30 deletions
diff --git a/math/py-affine/Makefile b/math/py-affine/Makefile
index 77a1f754a20e..3519304d6da4 100644
--- a/math/py-affine/Makefile
+++ b/math/py-affine/Makefile
@@ -1,5 +1,6 @@
PORTNAME= affine
PORTVERSION= 2.4.0
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +12,11 @@ WWW= https://github.com/sgillies/affine
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.2<4:devel/py-flit-core@${PY_FLAVOR}
+
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
-
.include <bsd.port.mk>
diff --git a/math/py-affine/files/setup.py b/math/py-affine/files/setup.py
deleted file mode 100644
index cf8c5386760c..000000000000
--- a/math/py-affine/files/setup.py
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/usr/bin/env python
-# setup.py generated by flit for tools that don't yet use PEP 517
-
-from distutils.core import setup
-
-packages = \
-['affine', 'affine.tests']
-
-package_data = \
-{'': ['*']}
-
-extras_require = \
-{'dev': ['pydocstyle', 'flake8', 'coveralls'],
- 'test': ['pytest >=4.6', 'pytest-cov']}
-
-setup(name='affine',
- version='%%PORTVERSION%%',
- description='Matrices describing affine transformation of the plane',
- author=None,
- author_email='Sean Gillies <sean.gillies@gmail.com>',
- url=None,
- packages=packages,
- package_data=package_data,
- extras_require=extras_require,
- python_requires='>=3.7',
- )