aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2016-01-30 20:24:18 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2016-01-30 20:24:18 +0000
commit446cdc5a70b185538801e2e9a91248d4b96206a6 (patch)
tree8eeb6e156e5f7b996e9b5678b1c4d70c29a546cd
parentedfa1cfc4fc665a44018e578f64d05d6b49e4cf5 (diff)
downloadports-446cdc5a70b185538801e2e9a91248d4b96206a6.tar.gz
ports-446cdc5a70b185538801e2e9a91248d4b96206a6.zip
Remove unnecessary empty directories from Erlang's plists.
Notes
Notes: svn path=/head/; revision=407551
-rw-r--r--lang/erlang-runtime15/Makefile6
-rw-r--r--lang/erlang-runtime16/Makefile6
-rw-r--r--lang/erlang-runtime17/Makefile6
-rw-r--r--lang/erlang-runtime18/Makefile6
-rw-r--r--lang/erlang/Makefile6
5 files changed, 5 insertions, 25 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index 604835799531..13b9334700c3 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -204,11 +204,7 @@ post-install:
.if ! ${PORT_OPTIONS:MWX}
${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/wx-*
.endif
-
- @cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type d -empty \
- | ${SORT} \
- | ${SED} -e 's#^#@dir #g' \
- > ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/* -type d -empty -delete
@cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type f -o -type l \
| ${SORT} \
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index 985233943a93..b9d190350e76 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -204,11 +204,7 @@ post-install:
.if ! ${PORT_OPTIONS:MWX}
${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/wx-*
.endif
-
- @cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type d -empty \
- | ${SORT} \
- | ${SED} -e 's#^#@dir #g' \
- > ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/* -type d -empty -delete
@cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type f -o -type l \
| ${SORT} \
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 02f07657cce3..b7b201fec9ac 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -264,11 +264,7 @@ post-install:
.if ! ${PORT_OPTIONS:MWX}
${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/wx-*
.endif
-
- @cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type d -empty \
- | ${SORT} \
- | ${SED} -e 's#^#@dir #g' \
- > ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/* -type d -empty -delete
@cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type f -o -type l \
| ${SORT} \
diff --git a/lang/erlang-runtime18/Makefile b/lang/erlang-runtime18/Makefile
index b2d1c9b97e39..10fad616ea3d 100644
--- a/lang/erlang-runtime18/Makefile
+++ b/lang/erlang-runtime18/Makefile
@@ -224,11 +224,7 @@ post-install:
.if ! ${PORT_OPTIONS:MWX}
${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/wx-*
.endif
-
- @cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type d -empty \
- | ${SORT} \
- | ${SED} -e 's#^#@dir #g' \
- > ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/* -type d -empty -delete
@cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type f -o -type l \
| ${SORT} \
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index cc6e6c12d472..ef456be66dfe 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -250,14 +250,10 @@ post-install:
.if ! ${PORT_OPTIONS:MWX}
${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/wx-*
.endif
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/* -type d -empty -delete
${LN} -s ../lib/erlang/lib/snmp-${SNMP_VSN}/bin/snmpc ${STAGEDIR}${PREFIX}/bin/snmpc
- @cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type d -empty \
- | ${SORT} \
- | ${SED} -e 's#^#@dir #g' \
- >> ${TMPPLIST}
-
@cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type f -o -type l \
| ${SORT} \
>> ${TMPPLIST}