aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2022-08-22 14:33:50 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-08-22 14:44:50 +0000
commit447fcc79d4fcc25dd5e9c3ac72636cacd75851b6 (patch)
treef55649a385a23ccb021739d4ef265910d60a0d43
parentf395272de6886f236bfe99081bfb8df6cd18b772 (diff)
downloadports-447fcc79d4fcc25dd5e9c3ac72636cacd75851b6.tar.gz
ports-447fcc79d4fcc25dd5e9c3ac72636cacd75851b6.zip
www/qt6-serialport: new port
This adds the missing Qt 6 serialport module to the tree. As with the rest of the Qt 6 ports, we first need to figure out what is actually required by other ports before we can finalize them.
-rw-r--r--Mk/Uses/qt.mk2
-rw-r--r--comms/Makefile1
-rw-r--r--comms/qt6-serialport/Makefile15
-rw-r--r--comms/qt6-serialport/distinfo3
-rw-r--r--comms/qt6-serialport/pkg-descr11
-rw-r--r--comms/qt6-serialport/pkg-plist34
6 files changed, 65 insertions, 1 deletions
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index 721e115306b1..05908e86d575 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -151,7 +151,7 @@ _USE_QT5_ONLY= 3d buildtools charts concurrent connectivity \
sql-sqlite3 svg testlib webkit xml xmlpatterns
_USE_QT6_ONLY= 3d 5compat base declarative doc imageformats quick3d \
- quickcontrols2 quicktimeline networkauth shadertools \
+ quickcontrols2 quicktimeline networkauth serialport shadertools \
svg tools translations wayland webchannel websockets
# Dependency tuples: _LIB should be preferred if possible.
diff --git a/comms/Makefile b/comms/Makefile
index 841716e29433..b07001b4232c 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -148,6 +148,7 @@
SUBDIR += qt5-sensors
SUBDIR += qt5-serialbus
SUBDIR += qt5-serialport
+ SUBDIR += qt6-serialport
SUBDIR += qtel
SUBDIR += redsea
SUBDIR += remserial
diff --git a/comms/qt6-serialport/Makefile b/comms/qt6-serialport/Makefile
new file mode 100644
index 000000000000..1876416045b7
--- /dev/null
+++ b/comms/qt6-serialport/Makefile
@@ -0,0 +1,15 @@
+PORTNAME= serialport
+PORTVERSION= ${QT6_VERSION}
+CATEGORIES= comms
+PKGNAMEPREFIX= qt6-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt functions to access serial ports
+
+BUILD_DEPENDS= vulkan-headers>0:graphics/vulkan-headers
+LIB_DEPENDS= libudev.so:devel/libudev-devd
+
+USES= cmake compiler:c++11-lib pkgconfig qt-dist:6
+USE_QT= base
+
+.include <bsd.port.mk>
diff --git a/comms/qt6-serialport/distinfo b/comms/qt6-serialport/distinfo
new file mode 100644
index 000000000000..26b60daecdd5
--- /dev/null
+++ b/comms/qt6-serialport/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1661178330
+SHA256 (KDE/Qt/6.3.1/qtserialport-everywhere-src-6.3.1.tar.xz) = 4eb6d80e65799dd2e0318df4dfba14173c1929e861718cda9bedca24253b616e
+SIZE (KDE/Qt/6.3.1/qtserialport-everywhere-src-6.3.1.tar.xz) = 319404
diff --git a/comms/qt6-serialport/pkg-descr b/comms/qt6-serialport/pkg-descr
new file mode 100644
index 000000000000..d8dc40011399
--- /dev/null
+++ b/comms/qt6-serialport/pkg-descr
@@ -0,0 +1,11 @@
+Qt Serial Port provides the basic functionality, which includes configuring,
+I/O operations, getting and setting the control signals of the RS-232 pinouts.
+
+The following items are not supported by this module:
+
+ * Terminal features, such as echo, control CR/LF, and so on.
+ * Text mode.
+ * Configuring timeouts and delays while reading or writing.
+ * Pinout signal change notification.
+
+WWW: https://qt.io
diff --git a/comms/qt6-serialport/pkg-plist b/comms/qt6-serialport/pkg-plist
new file mode 100644
index 000000000000..ce3180b07079
--- /dev/null
+++ b/comms/qt6-serialport/pkg-plist
@@ -0,0 +1,34 @@
+%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qserialport_p.h
+%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qserialportinfo_p.h
+%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qtserialport-config_p.h
+%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qtudev_p.h
+%%QT_INCDIR%%/QtSerialPort/%%FULLVER%%/QtSerialPort/private/qwinoverlappedionotifier_p.h
+%%QT_INCDIR%%/QtSerialPort/QSerialPort
+%%QT_INCDIR%%/QtSerialPort/QSerialPortInfo
+%%QT_INCDIR%%/QtSerialPort/QtSerialPort
+%%QT_INCDIR%%/QtSerialPort/QtSerialPortDepends
+%%QT_INCDIR%%/QtSerialPort/QtSerialPortVersion
+%%QT_INCDIR%%/QtSerialPort/qserialport.h
+%%QT_INCDIR%%/QtSerialPort/qserialportglobal.h
+%%QT_INCDIR%%/QtSerialPort/qserialportinfo.h
+%%QT_INCDIR%%/QtSerialPort/qtserialport-config.h
+%%QT_INCDIR%%/QtSerialPort/qtserialportexports.h
+%%QT_INCDIR%%/QtSerialPort/qtserialportversion.h
+lib/cmake/Qt6BuildInternals/StandaloneTests/QtSerialPortTestsConfig.cmake
+lib/cmake/Qt6SerialPort/Qt6SerialPortAdditionalTargetInfo.cmake
+lib/cmake/Qt6SerialPort/Qt6SerialPortConfig.cmake
+lib/cmake/Qt6SerialPort/Qt6SerialPortConfigVersion.cmake
+lib/cmake/Qt6SerialPort/Qt6SerialPortConfigVersionImpl.cmake
+lib/cmake/Qt6SerialPort/Qt6SerialPortDependencies.cmake
+lib/cmake/Qt6SerialPort/Qt6SerialPortTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Qt6SerialPort/Qt6SerialPortTargets.cmake
+lib/cmake/Qt6SerialPort/Qt6SerialPortVersionlessTargets.cmake
+%%QT_LIBDIR%%/libQt6SerialPort.prl
+%%QT_LIBDIR%%/libQt6SerialPort.so
+%%QT_LIBDIR%%/libQt6SerialPort.so.6
+%%QT_LIBDIR%%/libQt6SerialPort.so.%%FULLVER%%
+%%QT_LIBDIR%%/metatypes/qt6serialport_%%CMAKE_BUILD_TYPE%%_metatypes.json
+%%QT_MKSPECDIR%%/modules/qt_lib_serialport.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_serialport_private.pri
+libdata/pkgconfig/Qt6SerialPort.pc
+%%QT_DATADIR%%/modules/SerialPort.json