aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-04-10 08:33:55 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-04-10 08:33:58 +0000
commit4491ea0aa2e175148003772e1d7c916f7d6cd567 (patch)
treea8973ce5d5c68331d7e66ef1a517c006efcf5f19
parent284339db15d25aae9c32a820bd5a6295686373ed (diff)
downloadports-4491ea0aa2e175148003772e1d7c916f7d6cd567.tar.gz
ports-4491ea0aa2e175148003772e1d7c916f7d6cd567.zip
shells/yash: Add mirror and use framework helper
Add GitHub mirror as backup Use USE_CSTD helper instead of CFLAGS variable Reference: https://yash.osdn.jp/index.html.en PR: 270724 Reviewed by: naddy (maintainer)
-rw-r--r--shells/yash/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/shells/yash/Makefile b/shells/yash/Makefile
index 5e53f1140a45..89ec40537e5c 100644
--- a/shells/yash/Makefile
+++ b/shells/yash/Makefile
@@ -1,7 +1,8 @@
PORTNAME= yash
DISTVERSION= 2.54
CATEGORIES= shells
-MASTER_SITES= OSDN/yash
+MASTER_SITES= OSDN/yash \
+ https://github.com/magicant/${PORTNAME}/releases/download/${DISTVERSION}/
MAINTAINER= naddy@FreeBSD.org
COMMENT= POSIX-compliant command line shell
@@ -11,10 +12,10 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= tar:xz
+USE_CSTD= c99
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
-CPPFLAGS+= -std=c99
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes