aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2022-10-28 18:36:09 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2022-10-28 18:36:09 +0000
commit44ad650ffecc4a7b638f2a9f56f17bbed940249c (patch)
tree21f72def6340aaa93d534f1c002921b4b38e662a
parentae33c30fb0de4184a0987616465273db11eabe5e (diff)
downloadports-44ad650ffecc4a7b638f2a9f56f17bbed940249c.tar.gz
ports-44ad650ffecc4a7b638f2a9f56f17bbed940249c.zip
math/octave-forge-cfitsio: new port.
Octave forge port: I/O routines to read and write FITS (Flexible Image Transport System) files.
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-cfitsio/Makefile34
-rw-r--r--math/octave-forge-cfitsio/distinfo3
-rw-r--r--math/octave-forge-cfitsio/pkg-descr8
4 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 710586b5faca..ebadaf71742c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -532,6 +532,7 @@
SUBDIR += octave-forge-bioinfo
SUBDIR += octave-forge-biosig
SUBDIR += octave-forge-bsltl
+ SUBDIR += octave-forge-cfitsio
SUBDIR += octave-forge-cgi
SUBDIR += octave-forge-civil-engineering
SUBDIR += octave-forge-communications
diff --git a/math/octave-forge-cfitsio/Makefile b/math/octave-forge-cfitsio/Makefile
new file mode 100644
index 000000000000..bd648d9fe85e
--- /dev/null
+++ b/math/octave-forge-cfitsio/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= octave-forge-cfitsio
+PORTVERSION= 0.0.4
+CATEGORIES= math
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=octave-cfitsio/v${PORTVERSION}
+DISTNAME= octave-${OCTAVE_PKGNAME}-${PORTVERSION}
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+WWW= http://octave.sourceforge.net/
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+LIB_DEPENDS+= libcfitsio.so:astro/cfitsio
+
+USES= autoreconf
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+
+OCTSRC= ${DISTNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+
+GNU_CONFIGURE= yes
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-cfitsio/distinfo b/math/octave-forge-cfitsio/distinfo
new file mode 100644
index 000000000000..17a9712c69e6
--- /dev/null
+++ b/math/octave-forge-cfitsio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1666981649
+SHA256 (octave-forge/octave-cfitsio-0.0.4.tar.gz) = cc76307f99a3b7755a4ea72d1c4d40758329f20807e48d5df59da74e6bfee88e
+SIZE (octave-forge/octave-cfitsio-0.0.4.tar.gz) = 626713
diff --git a/math/octave-forge-cfitsio/pkg-descr b/math/octave-forge-cfitsio/pkg-descr
new file mode 100644
index 000000000000..a3a1f3369976
--- /dev/null
+++ b/math/octave-forge-cfitsio/pkg-descr
@@ -0,0 +1,8 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is cfitsio.
+
+ I/O routines to read and write FITS (Flexible Image Transport System) files.