aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-08-10 08:18:51 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-08-10 08:18:51 +0000
commit44ddc3426e2f6f576dd0931fd2d2e78c7335f7bd (patch)
tree4c30952faed9171dec6732ab20b44a4fe895a099
parent40e2e9a9f87c1a720f777a907f72abdd0b79c4dd (diff)
downloadports-44ddc3426e2f6f576dd0931fd2d2e78c7335f7bd.tar.gz
ports-44ddc3426e2f6f576dd0931fd2d2e78c7335f7bd.zip
devel/py-jellyfish: Prepare for py-maturin >= 1.x
* Relax version requirements and add the additional directive "modulename" to point newer versions of py-maturin to the symbols of the binary module. Otherwise it emits following warning and leads to runtime errors: [...] Warning: Couldn't find the symbol `PyInit_jellyfish` in the native library. Python will fail to import this module. If you're using pyo3, check that `#[pymodule]` uses `jellyfish` as module name [...] * No PORTREVISION bump as the package doesn't change. PR: 272570 Approved by: portmgr (buildfix blanket)
-rw-r--r--devel/py-jellyfish/Makefile2
-rw-r--r--devel/py-jellyfish/files/patch-pyproject.toml7
2 files changed, 7 insertions, 2 deletions
diff --git a/devel/py-jellyfish/Makefile b/devel/py-jellyfish/Makefile
index bd4909e2809d..8669afa443a0 100644
--- a/devel/py-jellyfish/Makefile
+++ b/devel/py-jellyfish/Makefile
@@ -13,7 +13,7 @@ WWW= https://github.com/jamesturk/jellyfish
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}maturin>=0.13<0.15:devel/py-maturin@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}maturin>=0.13<2:devel/py-maturin@${PY_FLAVOR}
USES= cargo python
USE_PYTHON= autoplist concurrent pep517
diff --git a/devel/py-jellyfish/files/patch-pyproject.toml b/devel/py-jellyfish/files/patch-pyproject.toml
index 56e799e9595d..545bef7a4035 100644
--- a/devel/py-jellyfish/files/patch-pyproject.toml
+++ b/devel/py-jellyfish/files/patch-pyproject.toml
@@ -3,7 +3,12 @@
@@ -1,5 +1,5 @@
[build-system]
-requires = ["maturin>=0.14,<0.15"]
-+requires = ["maturin>=0.13,<0.15"]
++requires = ["maturin>=0.13,<2"]
build-backend = "maturin"
[project]
+@@ -24,3 +24,4 @@ python-source = "python"
+ [tool.maturin]
+ features = ["pyo3/extension-module", "python"]
+ python-source = "python"
++module-name = "jellyfish._rustyfish"