aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 17:46:44 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-03-07 18:10:51 +0000
commit45fee563f96cbe7d03f20bea8e5aa3a9ada1048a (patch)
tree1fd2f83dd7f8d270c8bc68f340531c8323ed24bf
parentfd0ac53ca4a55253b71ef4a5ce9d6eb2379d8608 (diff)
downloadports-45fee563f96cbe7d03f20bea8e5aa3a9ada1048a.tar.gz
ports-45fee563f96cbe7d03f20bea8e5aa3a9ada1048a.zip
graphics/py-momepy: Add py-momepy 0.5.2
Momepy is a library for quantitative analysis of urban form - urban morphometrics. It is part of PySAL (Python Spatial Analysis Library) and is built on top of GeoPandas, other PySAL modules and networkX. WWW: https://github.com/pysal/momepy
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-momepy/Makefile26
-rw-r--r--graphics/py-momepy/distinfo3
-rw-r--r--graphics/py-momepy/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 784286527464..f46e54a25746 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -871,6 +871,7 @@
SUBDIR += py-mcomix
SUBDIR += py-mgwr
SUBDIR += py-ming
+ SUBDIR += py-momepy
SUBDIR += py-mpl-interactions
SUBDIR += py-mpl-scatter-density
SUBDIR += py-nwdiag
diff --git a/graphics/py-momepy/Makefile b/graphics/py-momepy/Makefile
new file mode 100644
index 000000000000..c517beb14f24
--- /dev/null
+++ b/graphics/py-momepy/Makefile
@@ -0,0 +1,26 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= momepy
+PORTVERSION= 0.5.2
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Urban Morphology Measuring Toolkit
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}geopandas>=0.8.0:graphics/py-geopandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libpysal>=4.2.0:science/py-libpysal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}networkx>=2.3:math/py-networkx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygeos>=0:graphics/py-pygeos@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=4.27.0:misc/py-tqdm@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-momepy/distinfo b/graphics/py-momepy/distinfo
new file mode 100644
index 000000000000..ebebbccc326e
--- /dev/null
+++ b/graphics/py-momepy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1646057852
+SHA256 (momepy-0.5.2.tar.gz) = 44a67b00ca7cd61895162eb017470058494b98eb0ebff8970146790ed6ff0fcc
+SIZE (momepy-0.5.2.tar.gz) = 256225
diff --git a/graphics/py-momepy/pkg-descr b/graphics/py-momepy/pkg-descr
new file mode 100644
index 000000000000..9e17cff98c3b
--- /dev/null
+++ b/graphics/py-momepy/pkg-descr
@@ -0,0 +1,5 @@
+Momepy is a library for quantitative analysis of urban form - urban
+morphometrics. It is part of PySAL (Python Spatial Analysis Library) and is
+built on top of GeoPandas, other PySAL modules and networkX.
+
+WWW: https://github.com/pysal/momepy