aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksii Samorukov <samm@FreeBSD.org>2023-06-05 18:43:11 +0000
committerOleksii Samorukov <samm@FreeBSD.org>2023-06-05 18:45:37 +0000
commit463b5fbc591b49446e1f8c07567a3d1372194d5b (patch)
treeb3bb5e48c926db21137af70d50c2ce7710430549
parent3fdf44501099b4dc5d945b7262fc5e05022d80cf (diff)
downloadports-463b5fbc591b49446e1f8c07567a3d1372194d5b.tar.gz
ports-463b5fbc591b49446e1f8c07567a3d1372194d5b.zip
sysutils/fusefs-exfat: update to 1.4.0
-rw-r--r--sysutils/fusefs-exfat/Makefile3
-rw-r--r--sysutils/fusefs-exfat/distinfo6
-rw-r--r--sysutils/fusefs-exfat/files/patch-fuse_main.c25
-rw-r--r--sysutils/fusefs-exfat/files/patch-libexfat_exfat.h10
-rw-r--r--sysutils/fusefs-exfat/files/patch-libexfat_mount.c42
-rw-r--r--sysutils/fusefs-exfat/files/patch-libexfat_utils.c18
6 files changed, 4 insertions, 100 deletions
diff --git a/sysutils/fusefs-exfat/Makefile b/sysutils/fusefs-exfat/Makefile
index ce63b317f659..10e39dafb8ae 100644
--- a/sysutils/fusefs-exfat/Makefile
+++ b/sysutils/fusefs-exfat/Makefile
@@ -1,7 +1,6 @@
PORTNAME= exfat
DISTVERSIONPREFIX= v
-DISTVERSION= 1.3.0
-PORTREVISION= 1
+DISTVERSION= 1.4.0
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-
diff --git a/sysutils/fusefs-exfat/distinfo b/sysutils/fusefs-exfat/distinfo
index 9cca7d02e16b..3d2567e5d62d 100644
--- a/sysutils/fusefs-exfat/distinfo
+++ b/sysutils/fusefs-exfat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1566155165
-SHA256 (relan-exfat-v1.3.0_GH0.tar.gz) = 689bcb4a639acd2d45e6fa0ff455f7f18edb2421d4f4f42909943775adc0e375
-SIZE (relan-exfat-v1.3.0_GH0.tar.gz) = 57846
+TIMESTAMP = 1685988699
+SHA256 (relan-exfat-v1.4.0_GH0.tar.gz) = af560659f55dca0270f94809530f359d6bdad5d313133c68b458fb0a8eeab1c8
+SIZE (relan-exfat-v1.4.0_GH0.tar.gz) = 62390
diff --git a/sysutils/fusefs-exfat/files/patch-fuse_main.c b/sysutils/fusefs-exfat/files/patch-fuse_main.c
deleted file mode 100644
index aa2e853d16dd..000000000000
--- a/sysutils/fusefs-exfat/files/patch-fuse_main.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- fuse/main.c.orig 2021-11-24 20:45:02 UTC
-+++ fuse/main.c
-@@ -451,7 +451,7 @@ static char* add_ro_option(char* options, bool ro)
- return ro ? add_option(options, "ro", NULL) : options;
- }
-
--#if defined(__linux__) || defined(__FreeBSD__)
-+#if defined(__linux__)
- static char* add_user_option(char* options)
- {
- struct passwd* pw;
-@@ -492,12 +492,10 @@ static char* add_fuse_options(char* options, const cha
- options = add_ro_option(options, ro);
- if (options == NULL)
- return NULL;
--#if defined(__linux__) || defined(__FreeBSD__)
-+#if defined(__linux__)
- options = add_user_option(options);
- if (options == NULL)
- return NULL;
--#endif
--#if defined(__linux__)
- options = add_blksize_option(options, CLUSTER_SIZE(*ef.sb));
- if (options == NULL)
- return NULL;
diff --git a/sysutils/fusefs-exfat/files/patch-libexfat_exfat.h b/sysutils/fusefs-exfat/files/patch-libexfat_exfat.h
deleted file mode 100644
index 2b5d7cf8473e..000000000000
--- a/sysutils/fusefs-exfat/files/patch-libexfat_exfat.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- libexfat/exfat.h.orig 2018-09-15 05:03:24 UTC
-+++ libexfat/exfat.h
-@@ -201,6 +201,7 @@ le16_t exfat_calc_name_hash(const struct exfat* ef, co
- void exfat_humanize_bytes(uint64_t value, struct exfat_human_bytes* hb);
- void exfat_print_info(const struct exfat_super_block* sb,
- uint32_t free_clusters);
-+bool exfat_match_option(const char* options, const char* option_name);
-
- int utf16_to_utf8(char* output, const le16_t* input, size_t outsize,
- size_t insize);
diff --git a/sysutils/fusefs-exfat/files/patch-libexfat_mount.c b/sysutils/fusefs-exfat/files/patch-libexfat_mount.c
deleted file mode 100644
index 66d6096e3131..000000000000
--- a/sysutils/fusefs-exfat/files/patch-libexfat_mount.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- libexfat/mount.c.orig 2018-09-15 05:03:24 UTC
-+++ libexfat/mount.c
-@@ -79,18 +79,6 @@ static int get_int_option(const char* options, const c
- return strtol(p, NULL, base);
- }
-
--static bool match_option(const char* options, const char* option_name)
--{
-- const char* p;
-- size_t length = strlen(option_name);
--
-- for (p = strstr(options, option_name); p; p = strstr(p + 1, option_name))
-- if ((p == options || p[-1] == ',') &&
-- (p[length] == ',' || p[length] == '\0'))
-- return true;
-- return false;
--}
--
- static void parse_options(struct exfat* ef, const char* options)
- {
- int opt_umask;
-@@ -102,7 +90,7 @@ static void parse_options(struct exfat* ef, const char
- ef->uid = get_int_option(options, "uid", 10, geteuid());
- ef->gid = get_int_option(options, "gid", 10, getegid());
-
-- ef->noatime = match_option(options, "noatime");
-+ ef->noatime = exfat_match_option(options, "noatime");
-
- switch (get_int_option(options, "repair", 10, 0))
- {
-@@ -205,9 +193,9 @@ int exfat_mount(struct exfat* ef, const char* spec, co
-
- parse_options(ef, options);
-
-- if (match_option(options, "ro"))
-+ if (exfat_match_option(options, "ro"))
- mode = EXFAT_MODE_RO;
-- else if (match_option(options, "ro_fallback"))
-+ else if (exfat_match_option(options, "ro_fallback"))
- mode = EXFAT_MODE_ANY;
- else
- mode = EXFAT_MODE_RW;
diff --git a/sysutils/fusefs-exfat/files/patch-libexfat_utils.c b/sysutils/fusefs-exfat/files/patch-libexfat_utils.c
deleted file mode 100644
index 0bb23430d4a9..000000000000
--- a/sysutils/fusefs-exfat/files/patch-libexfat_utils.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- libexfat/utils.c.orig 2018-09-15 05:03:24 UTC
-+++ libexfat/utils.c
-@@ -178,3 +178,15 @@ void exfat_print_info(const struct exfat_super_block*
- exfat_humanize_bytes(avail_space, &hb);
- printf("Available space %10"PRIu64" %s\n", hb.value, hb.unit);
- }
-+
-+bool exfat_match_option(const char* options, const char* option_name)
-+{
-+ const char* p;
-+ size_t length = strlen(option_name);
-+
-+ for (p = strstr(options, option_name); p; p = strstr(p + 1, option_name))
-+ if ((p == options || p[-1] == ',') &&
-+ (p[length] == ',' || p[length] == '\0'))
-+ return true;
-+ return false;
-+}