aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2022-07-27 21:52:01 +0000
committerLarry Rosenman <ler@FreeBSD.org>2022-07-27 21:54:04 +0000
commit4668af6562433fc42f29d30f2dd02317f49ee6ad (patch)
tree3604e1808b6a53b6f595a3a51a166be5435059ad
parentfaf2a8ddb038494cfd55b33a0c5d53249f8ba613 (diff)
downloadports-4668af6562433fc42f29d30f2dd02317f49ee6ad.tar.gz
ports-4668af6562433fc42f29d30f2dd02317f49ee6ad.zip
net/boinc-client: upgrade to 7.20.2
notified by: portscout
-rw-r--r--net/boinc-client/Makefile5
-rw-r--r--net/boinc-client/distinfo6
-rw-r--r--net/boinc-client/files/patch-client_hostinfo__unix.cpp14
-rw-r--r--net/boinc-client/files/patch-client_mac__address.cpp46
-rw-r--r--net/boinc-client/pkg-plist9
5 files changed, 18 insertions, 62 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index 8b344a04c837..e777f1b64968 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -1,7 +1,6 @@
PORTNAME= boinc-client
-PORTVERSION= 7.8.6
-DISTVERSIONPREFIX= client_release/7.8/
-PORTREVISION= 10
+PORTVERSION= 7.20.2
+DISTVERSIONPREFIX= client_release/7.20/
CATEGORIES= net
MAINTAINER= ler@FreeBSD.org
diff --git a/net/boinc-client/distinfo b/net/boinc-client/distinfo
index f15265ea3965..b2440de35137 100644
--- a/net/boinc-client/distinfo
+++ b/net/boinc-client/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516015415
-SHA256 (BOINC-boinc-client_release-7.8-7.8.6_GH0.tar.gz) = ed5f3dcdc8d1cc5277529afb701377e77d1ff89711368a7456553bf249940bad
-SIZE (BOINC-boinc-client_release-7.8-7.8.6_GH0.tar.gz) = 52037690
+TIMESTAMP = 1658954348
+SHA256 (BOINC-boinc-client_release-7.20-7.20.2_GH0.tar.gz) = e577072b06f590d3230c25c94b221dba528b0938681e645bbd870778f8958077
+SIZE (BOINC-boinc-client_release-7.20-7.20.2_GH0.tar.gz) = 46555666
diff --git a/net/boinc-client/files/patch-client_hostinfo__unix.cpp b/net/boinc-client/files/patch-client_hostinfo__unix.cpp
index f9ef1cf4f67b..4f2165ae8798 100644
--- a/net/boinc-client/files/patch-client_hostinfo__unix.cpp
+++ b/net/boinc-client/files/patch-client_hostinfo__unix.cpp
@@ -1,13 +1,11 @@
---- client/hostinfo_unix.cpp.orig 2018-01-14 10:07:52 UTC
+--- client/hostinfo_unix.cpp.orig 2022-07-27 21:28:09 UTC
+++ client/hostinfo_unix.cpp
-@@ -164,7 +164,9 @@ extern "C" {
+@@ -177,7 +177,7 @@ extern "C" {
// The following is intended to be true both on Linux
// and Debian GNU/kFreeBSD (see trac #521)
//
--#define LINUX_LIKE_SYSTEM (defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)) && !defined(__HAIKU__)
-+#if (defined(__linux__) || defined(__GNU__) || defined(__GLIBC__) || defined (__freebsd__)) && !defined(__HAIKU__)
-+#define LINUX_LIKE_SYSTEM 1
-+#endif
+-#if (defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)) && !defined(__HAIKU__)
++#if (defined(__linux__) || defined(__GNU__) || defined(__GLIBC__) || defined(__freebsd__)) && !defined(__HAIKU__)
+ #define LINUX_LIKE_SYSTEM 1
+ #endif
- // Returns the offset between LOCAL STANDARD TIME and UTC.
- // LOCAL_STANDARD_TIME = UTC_TIME + get_timezone().
diff --git a/net/boinc-client/files/patch-client_mac__address.cpp b/net/boinc-client/files/patch-client_mac__address.cpp
deleted file mode 100644
index d87206a48bb5..000000000000
--- a/net/boinc-client/files/patch-client_mac__address.cpp
+++ /dev/null
@@ -1,46 +0,0 @@
---- client/mac_address.cpp.orig 2018-01-14 10:07:52 UTC
-+++ client/mac_address.cpp
-@@ -67,6 +67,10 @@
- #ifdef HAVE_NETINET_ETHER_H
- #include <netinet/ether.h>
- #endif
-+#if defined(__FreeBSD__)
-+#include <ifaddrs.h>
-+#include <net/if_dl.h>
-+#endif
-
- #include "mac_address.h"
-
-@@ -262,10 +266,32 @@ int get_mac_address(char* address) {
- return -1;
- }
- hw_addr = (struct ether_addr *)&(item->lifr_lifru.lifru_enaddr);
-+#elif defined(__FreeBSD__)
-+ struct ifaddrs *ifap, *ifaptr;
-+ unsigned char *ptr;
-+
-+ if (getifaddrs(&ifap) == 0) {
-+ for(ifaptr = ifap; ifaptr != NULL; ifaptr = (ifaptr)->ifa_next) {
-+ if (!strcmp((ifaptr)->ifa_name, item->ifr_name) && (((ifaptr)->ifa_addr)->sa_family == AF_LINK)) {
-+ ptr = (unsigned char *)LLADDR((struct sockaddr_dl *)(ifaptr)->ifa_addr);
-+ hw_addr = (struct ether_addr *)ptr;
-+ break;
-+ }
-+ }
-+ } else {
-+ return -1;
-+ }
-+#else
-+ return -1;
- #endif
- strcpy(address, ether_ntoa(hw_addr));
-+#if defined(__FreeBSD__)
-+ freeifaddrs(ifap);
-+#endif
- #ifdef HAVE_STRUCT_LIFCONF
- if (strstr(item->lifr_name, "eth")) break;
-+#elif defined(__FreeBSD__)
-+ break;
- #else
- if (strstr(item->ifr_name, "eth")) break;
- #endif
diff --git a/net/boinc-client/pkg-plist b/net/boinc-client/pkg-plist
index 450d5d90c067..30fbe6677d21 100644
--- a/net/boinc-client/pkg-plist
+++ b/net/boinc-client/pkg-plist
@@ -36,6 +36,7 @@ include/boinc/notice.h
include/boinc/opencl_boinc.h
include/boinc/parse.h
include/boinc/prefs.h
+include/boinc/proc_control.h
include/boinc/procinfo.h
include/boinc/project_specific_defines.h
include/boinc/proxy_info.h
@@ -58,12 +59,16 @@ lib/libboinc.a
lib/libboinc_api.a
lib/libboinc_api.so
lib/libboinc_api.so.7
-lib/libboinc_api.so.7.8.6
+lib/libboinc_api.so.7.20.2
lib/libboinc_crypt.a
lib/libboinc_opencl.a
lib/libboinc_opencl.so
lib/libboinc_opencl.so.7
-lib/libboinc_opencl.so.7.8.6
+lib/libboinc_opencl.so.7.20.2
+libdata/pkgconfig/libboinc.pc
+libdata/pkgconfig/libboinc_api.pc
+libdata/pkgconfig/libboinc_crypt.pc
+libdata/pkgconfig/libboinc_opencl.pc
%%X11%%lib/libboinc_graphics2.a
%%X11%%lib/libboinc_graphics2.so
%%X11%%lib/libboinc_graphics2.so.7