aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 19:09:32 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-05 19:34:42 +0000
commit46f341bb935225b15ae3aea20293019eb5a22f68 (patch)
treea9918d5651e471b69f775fe3dc10f01f90192f2e
parentaa4f1208414fb437ce549623d093e6c7221c6691 (diff)
downloadports-46f341bb935225b15ae3aea20293019eb5a22f68.tar.gz
ports-46f341bb935225b15ae3aea20293019eb5a22f68.zip
astro/openuniverse: Fix build with llvm16
- Utilize USES=localbase - Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--astro/openuniverse/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index 7fad1608d9d0..c4876144fe54 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -8,15 +8,17 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL Solar System simulator for X Window System
WWW= http://openuniverse.sourceforge.net/
-USES= gl gmake jpeg xorg
+USES= gl gmake jpeg localbase xorg
+USE_CXXSTD= c++14
USE_GL= glut
USE_XORG= sm ice xmu xi xext x11
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib" \
-CPPFLAGS+= -I${LOCALBASE}/include/GL -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib -lm -lcompat
+CPPFLAGS+= -I${LOCALBASE}/include/GL
+LIBS+= -lm -lcompat
.include <bsd.port.mk>