aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-02 09:44:14 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-02 09:44:14 +0000
commit46f9eb7bdb72a12f98990747860f7e9bd8fc9c2d (patch)
tree9f505daf050a83a37a7110d6acec24fb41a83610
parent4f0f40cb05fcf0dafeb29921258f35833e960b6d (diff)
downloadports-46f9eb7bdb72a12f98990747860f7e9bd8fc9c2d.tar.gz
ports-46f9eb7bdb72a12f98990747860f7e9bd8fc9c2d.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Notes
Notes: svn path=/head/; revision=325960
-rw-r--r--finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile3
-rw-r--r--finance/p5-Business-PayPal-IPN/Makefile3
-rw-r--r--finance/p5-Business-Stripe/Makefile3
-rw-r--r--finance/p5-PayflowPro/Makefile3
-rw-r--r--www/asql/Makefile2
-rw-r--r--www/p5-AnyEvent-HTTP-LWP-UserAgent/Makefile3
-rw-r--r--www/p5-AnyEvent-Mojo/Makefile3
-rw-r--r--www/p5-Catalyst-Controller-ActionRole/Makefile3
-rw-r--r--www/p5-Catalyst-Model-Tarantool/Makefile3
-rw-r--r--www/p5-FCGI-ProcManager/Makefile3
-rw-r--r--www/p5-File-Mork/Makefile3
-rw-r--r--www/p5-HTML-Parser/Makefile3
-rw-r--r--www/p5-HTTP-WebTest/Makefile3
-rw-r--r--www/p5-Mozilla-CA/Makefile3
-rw-r--r--www/p5-Nginx-Simple/Makefile3
-rw-r--r--www/p5-POE-Component-Server-HTTPServer/Makefile3
-rw-r--r--www/p5-POE-Component-Server-PSGI/Makefile3
-rw-r--r--www/p5-Plack-Middleware-ConsoleLogger/Makefile3
-rw-r--r--www/p5-Plack-Middleware-Header/Makefile3
-rw-r--r--www/p5-Template-Plugin-VMethods/Makefile3
-rw-r--r--www/p5-Template-Toolkit-Simple/Makefile3
-rw-r--r--www/p5-URI-Escape-JavaScript/Makefile3
-rw-r--r--www/p5-WWW-IMDb/Makefile3
-rw-r--r--www/p5-WWW-TV/Makefile3
24 files changed, 47 insertions, 24 deletions
diff --git a/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile b/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile
index 8761138e7196..4442f1dac98c 100644
--- a/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile
+++ b/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww \
p5-Crypt-SSLeay>0.0:${PORTSDIR}/security/p5-Crypt-SSLeay
BUILD_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::MaxMind::CreditCardFraudDetection.3 \
Business::MaxMind::HTTPBase.3 \
diff --git a/finance/p5-Business-PayPal-IPN/Makefile b/finance/p5-Business-PayPal-IPN/Makefile
index 8628af259048..27d070e4da33 100644
--- a/finance/p5-Business-PayPal-IPN/Makefile
+++ b/finance/p5-Business-PayPal-IPN/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Crypt-SSLeay>=0.56:${PORTSDIR}/security/p5-Crypt-SSLeay \
RUN_DEPENDS= p5-Crypt-SSLeay>=0.56:${PORTSDIR}/security/p5-Crypt-SSLeay \
p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::PayPal::IPN.3
diff --git a/finance/p5-Business-Stripe/Makefile b/finance/p5-Business-Stripe/Makefile
index 803d5752de43..81dddeb5d503 100644
--- a/finance/p5-Business-Stripe/Makefile
+++ b/finance/p5-Business-Stripe/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= p5-HTTP-Message>=0.0:${PORTSDIR}/www/p5-HTTP-Message \
WRKSRC= ${WRKDIR}/aquaron-Business-Stripe-c067843
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Business::Stripe.3 Business::README.3
diff --git a/finance/p5-PayflowPro/Makefile b/finance/p5-PayflowPro/Makefile
index 541a5444e682..4de255632ba6 100644
--- a/finance/p5-PayflowPro/Makefile
+++ b/finance/p5-PayflowPro/Makefile
@@ -18,7 +18,8 @@ COMMENT= Pure Perl PayflowPro payment gateway interface
RUN_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
post-install:
${INSTALL_DATA} ${WRKSRC}/ca-bundle.crt ${LOCALBASE}/etc
diff --git a/www/asql/Makefile b/www/asql/Makefile
index d5353f10c84d..f55bdb7ca3a2 100644
--- a/www/asql/Makefile
+++ b/www/asql/Makefile
@@ -20,6 +20,6 @@ RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
NO_BUILD= yes
PLIST_FILES= bin/asql
-USE_PERL5= yes
+USES= perl5
.include <bsd.port.mk>
diff --git a/www/p5-AnyEvent-HTTP-LWP-UserAgent/Makefile b/www/p5-AnyEvent-HTTP-LWP-UserAgent/Makefile
index 23cd878ea9bc..0f2f54a70222 100644
--- a/www/p5-AnyEvent-HTTP-LWP-UserAgent/Makefile
+++ b/www/p5-AnyEvent-HTTP-LWP-UserAgent/Makefile
@@ -17,7 +17,8 @@ RUN_DEPENDS= \
p5-libwww>=5.815:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::HTTP::LWP::UserAgent.3
diff --git a/www/p5-AnyEvent-Mojo/Makefile b/www/p5-AnyEvent-Mojo/Makefile
index a43e37f0a946..1d1ca0d6f981 100644
--- a/www/p5-AnyEvent-Mojo/Makefile
+++ b/www/p5-AnyEvent-Mojo/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= \
# p5-Test-Exception>0:${PORTSDIR}/devel/p5-Test-Exception
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= AnyEvent::Mojo.3 \
AnyEvent::Mojo::Server.3 \
diff --git a/www/p5-Catalyst-Controller-ActionRole/Makefile b/www/p5-Catalyst-Controller-ActionRole/Makefile
index 5fd72aab4757..cab4bc81e3ef 100644
--- a/www/p5-Catalyst-Controller-ActionRole/Makefile
+++ b/www/p5-Catalyst-Controller-ActionRole/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.71001:${PORTSDIR}/www/p5-Catalyst-Runtime
p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Controller::ActionRole.3
diff --git a/www/p5-Catalyst-Model-Tarantool/Makefile b/www/p5-Catalyst-Model-Tarantool/Makefile
index 6ad360d754fb..54ae64c739b7 100644
--- a/www/p5-Catalyst-Model-Tarantool/Makefile
+++ b/www/p5-Catalyst-Model-Tarantool/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Catalyst-Runtime>=5.90001:${PORTSDIR}/www/p5-Catalyst-Runtime
p5-MR-Tarantool>=0.0.24:${PORTSDIR}/databases/p5-MR-Tarantool
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN3= Catalyst::Model::Tarantool.3
diff --git a/www/p5-FCGI-ProcManager/Makefile b/www/p5-FCGI-ProcManager/Makefile
index 944d8c20170d..1af0b91f2cb0 100644
--- a/www/p5-FCGI-ProcManager/Makefile
+++ b/www/p5-FCGI-ProcManager/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= peter@vereshagin.org
COMMENT= Functions for managing FastCGI applications
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= FCGI::ProcManager.3 \
FCGI::ProcManager::Constrained.3
diff --git a/www/p5-File-Mork/Makefile b/www/p5-File-Mork/Makefile
index d66d9b93c4a0..846097c4f536 100644
--- a/www/p5-File-Mork/Makefile
+++ b/www/p5-File-Mork/Makefile
@@ -18,7 +18,8 @@ COMMENT= A module to read Mozilla URL history files
BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= mork.1
MAN3= File::Mork.3
diff --git a/www/p5-HTML-Parser/Makefile b/www/p5-HTML-Parser/Makefile
index 701c580cf441..192beddd2228 100644
--- a/www/p5-HTML-Parser/Makefile
+++ b/www/p5-HTML-Parser/Makefile
@@ -13,7 +13,8 @@ COMMENT= Perl5 module for parsing HTML documents
RUN_DEPENDS= p5-HTML-Tagset>=3:${PORTSDIR}/www/p5-HTML-Tagset
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Entities.3 \
HTML::Filter.3 \
diff --git a/www/p5-HTTP-WebTest/Makefile b/www/p5-HTTP-WebTest/Makefile
index 3d3021eafeca..d03850f3559f 100644
--- a/www/p5-HTTP-WebTest/Makefile
+++ b/www/p5-HTTP-WebTest/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject \
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
INSTALL_TARGET= pure_install
MAN1= wt.1
diff --git a/www/p5-Mozilla-CA/Makefile b/www/p5-Mozilla-CA/Makefile
index 38b2a7420acf..44c5e65bddce 100644
--- a/www/p5-Mozilla-CA/Makefile
+++ b/www/p5-Mozilla-CA/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl extension for Mozilla CA cert bundle in PEM format
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mozilla::CA.3
diff --git a/www/p5-Nginx-Simple/Makefile b/www/p5-Nginx-Simple/Makefile
index d20a72c753cf..dba5fe18f9d2 100644
--- a/www/p5-Nginx-Simple/Makefile
+++ b/www/p5-Nginx-Simple/Makefile
@@ -10,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= simond@irrelevant.org
COMMENT= Perl 5 module for easy to use interface for Nginx Perl Module
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Nginx::Simple::Dispatch.3 Nginx::Simple::Cookie.3 \
Nginx::Simple::Ajax.3 Nginx::Simple.3 \
diff --git a/www/p5-POE-Component-Server-HTTPServer/Makefile b/www/p5-POE-Component-Server-HTTPServer/Makefile
index 9b32eda376c5..916310bcd6dd 100644
--- a/www/p5-POE-Component-Server-HTTPServer/Makefile
+++ b/www/p5-POE-Component-Server-HTTPServer/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
p5-MIME-Types>=0:${PORTSDIR}/mail/p5-MIME-Types
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Server::HTTPServer.3 \
POE::Component::Server::HTTPServer::BasicAuthenHandler.3 \
diff --git a/www/p5-POE-Component-Server-PSGI/Makefile b/www/p5-POE-Component-Server-PSGI/Makefile
index 0527d6d3038b..3000a68aa176 100644
--- a/www/p5-POE-Component-Server-PSGI/Makefile
+++ b/www/p5-POE-Component-Server-PSGI/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl extension to PSGI Server implementation for POE
RUN_DEPENDS= p5-POEx-Role-PSGIServer>0:${PORTSDIR}/www/p5-POEx-Role-PSGIServer
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= POE::Component::Server::PSGI.3 \
Plack::Server::POE.3
diff --git a/www/p5-Plack-Middleware-ConsoleLogger/Makefile b/www/p5-Plack-Middleware-ConsoleLogger/Makefile
index b47ccef9c4ff..ab33d064f106 100644
--- a/www/p5-Plack-Middleware-ConsoleLogger/Makefile
+++ b/www/p5-Plack-Middleware-ConsoleLogger/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-JavaScript-Value-Escape>0:${PORTSDIR}/lang/p5-JavaScript-Value-Escape
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::ConsoleLogger.3
diff --git a/www/p5-Plack-Middleware-Header/Makefile b/www/p5-Plack-Middleware-Header/Makefile
index 2ca769b52d06..5f448111f96c 100644
--- a/www/p5-Plack-Middleware-Header/Makefile
+++ b/www/p5-Plack-Middleware-Header/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= \
p5-Plack>0:${PORTSDIR}/www/p5-Plack
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::Header.3
diff --git a/www/p5-Template-Plugin-VMethods/Makefile b/www/p5-Template-Plugin-VMethods/Makefile
index c29fbb6c8b4f..cefc52810e3f 100644
--- a/www/p5-Template-Plugin-VMethods/Makefile
+++ b/www/p5-Template-Plugin-VMethods/Makefile
@@ -17,7 +17,8 @@ COMMENT= Install vmethods for Template-Toolkit
BUILD_DEPENDS:= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Template-Toolkit>0:${PORTSDIR}/www/p5-Template-Toolkit
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Plugin::VMethods.3
diff --git a/www/p5-Template-Toolkit-Simple/Makefile b/www/p5-Template-Toolkit-Simple/Makefile
index bf5de5c3140c..a0b4bab58b48 100644
--- a/www/p5-Template-Toolkit-Simple/Makefile
+++ b/www/p5-Template-Toolkit-Simple/Makefile
@@ -17,7 +17,8 @@ COMMENT= A Simple Interface to Template Toolkit
BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Toolkit::Simple.3
diff --git a/www/p5-URI-Escape-JavaScript/Makefile b/www/p5-URI-Escape-JavaScript/Makefile
index 7f1a6243d0e3..2905b85b8e3b 100644
--- a/www/p5-URI-Escape-JavaScript/Makefile
+++ b/www/p5-URI-Escape-JavaScript/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kostjnspb@yandex.ru
COMMENT= Perl implementation of JavaScript's escape()/unescape() functions
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= URI::Escape::JavaScript.3
diff --git a/www/p5-WWW-IMDb/Makefile b/www/p5-WWW-IMDb/Makefile
index 22798083ea74..c75d2c87e367 100644
--- a/www/p5-WWW-IMDb/Makefile
+++ b/www/p5-WWW-IMDb/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IMDb.3 IMDb::People.3 IMDb::Title.3
diff --git a/www/p5-WWW-TV/Makefile b/www/p5-WWW-TV/Makefile
index 0c973230bcd5..35ad385d1b18 100644
--- a/www/p5-WWW-TV/Makefile
+++ b/www/p5-WWW-TV/Makefile
@@ -16,7 +16,8 @@ COMMENT= Perl interface to the database of series/episodes at TV.com
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::TV.3 WWW::TV::Episode.3 WWW::TV::Series.3