aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-02-28 14:16:52 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-02-28 14:16:52 +0000
commit47095dc46a1110ae3aa8f44e640a783c4d654bf6 (patch)
treecc0620b9da2ca5836124af49745e4f8fba66d7d7
parent794b20db5951ece3ea052bb7ca965a406e28f9a2 (diff)
downloadports-47095dc46a1110ae3aa8f44e640a783c4d654bf6.tar.gz
ports-47095dc46a1110ae3aa8f44e640a783c4d654bf6.zip
- Remove USE_IMAKE
- Add WWW: line PR: 25426 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=38892
-rw-r--r--emulators/spim/Makefile23
-rw-r--r--emulators/spim/files/patch-0126
-rw-r--r--emulators/spim/files/patch-aa81
-rw-r--r--emulators/spim/pkg-descr2
-rw-r--r--emulators/spim/pkg-plist4
5 files changed, 92 insertions, 44 deletions
diff --git a/emulators/spim/Makefile b/emulators/spim/Makefile
index 376b746af2ae..f319d16ae154 100644
--- a/emulators/spim/Makefile
+++ b/emulators/spim/Makefile
@@ -8,35 +8,26 @@
PORTNAME= spim
PORTVERSION= 6.3
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.cs.wisc.edu/pub/spim/
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-PREFIX?= ${LOCALBASE}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_XLIB= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
-USE_IMAKE= yes
-ALL_TARGET= y.tab.c spim xspim
+MAKEFILE= Makefile.std
+ALL_TARGET= spim xspim
MAN1= spim.1 xspim.1
-pre-build:
- @${RM} -f ${WRKSRC}/y.tab.*
-
-pre-install:
- @${MKDIR} ${PREFIX}/share/spim && ${CHMOD} a+rx,u+w ${PREFIX}/share/spim
-
post-install:
.if !defined(NOPORTDOCS)
- @${ECHO_MSG} "Installing spim/xspim documentation"
- @${MKDIR} ${PREFIX}/share/doc/spim \
- && ${CHMOD} a+rx,u+w ${PREFIX}/share/doc/spim
- ${INSTALL_DATA} ${WRKSRC}/Documentation/spim.ps \
- ${PREFIX}/share/doc/spim
- ${INSTALL_DATA} ${WRKSRC}/Documentation/cycle.ps \
- ${PREFIX}/share/doc/spim
+ @${MKDIR} ${PREFIX}/share/doc/spim
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/*.ps ${PREFIX}/share/doc/spim
${GZIP_CMD} ${PREFIX}/share/doc/spim/*.ps
.endif
diff --git a/emulators/spim/files/patch-01 b/emulators/spim/files/patch-01
deleted file mode 100644
index e1df4551ca36..000000000000
--- a/emulators/spim/files/patch-01
+++ /dev/null
@@ -1,26 +0,0 @@
---- Imakefile.orig Sun Jan 14 20:55:15 2001
-+++ Imakefile Sun Feb 11 23:49:11 2001
-@@ -44,13 +44,13 @@
- #
-
- # Full path for directory that will hold the trap handler file:
--TRAP_DIR = .
-+TRAP_DIR = $(PREFIX)/share/spim
-
- # Full path for the directory that will hold the executable files:
--BIN_DIR = /usr/unsup/bin
-+BIN_DIR = $(PREFIX)/bin
-
- # Full path for the directory that will hold the man files:
--MAN_DIR = /var/unsup/man
-+MAN_DIR = $(PREFIX)/man/man1
-
-
- # If you have flex, use it instead of lex. If you use flex, define this
-@@ -255,7 +255,7 @@
- mv -f lex.yy.c.xx lex.yy.c
-
- depend::
-- makedepend -w10 *.c
-+ makedepend -w10 -I$(X11BASE)/include *.c
-
diff --git a/emulators/spim/files/patch-aa b/emulators/spim/files/patch-aa
new file mode 100644
index 000000000000..addb52150e1b
--- /dev/null
+++ b/emulators/spim/files/patch-aa
@@ -0,0 +1,81 @@
+--- Makefile.std.orig Mon Jan 15 05:55:16 2001
++++ Makefile.std Tue Feb 27 21:16:12 2001
+@@ -46,21 +46,21 @@
+
+
+ # Full path for directory containing X11 include files:
+-X_INCLUDE_DIR=/usr/X11/include
++X_INCLUDE_DIR=${X11BASE}/include
+
+
+ # Location of X11 root directory.
+-TOPDIR = /usr/X11
++TOPDIR = ${X11BASE}
+
+
+ # Full path for directory that will hold the trap handler file:
+-TRAP_DIR = .
++TRAP_DIR = ${PREFIX}/share/spim
+
+ # Full path for the directory that will hold the executable files:
+-BIN_DIR = /usr/unsup/bin
++BIN_DIR = ${PREFIX}/bin
+
+ # Full path for the directory that will hold the man files:
+-MAN_DIR = /usr/unsup/man
++MAN_DIR = ${PREFIX}/man/man1
+
+
+ # Full path for the trap handler file:
+@@ -93,8 +93,8 @@
+
+ DEFINES = $(ENDIAN) $(MEM_SIZES) -DDEFAULT_TRAP_HANDLER=$(TRAP_PATH) -DSPIM_VERSION="\"`cat VERSION`\""
+
+-CC = cc
+-CFLAGS = $(DEFINES)
++CC ?= cc
++CFLAGS += $(DEFINES) $(IFLAGS)
+ IFLAGS = -I$(X_INCLUDE_DIR)
+ YFLAGS = -d
+ YCFLAGS =
+@@ -120,18 +120,18 @@
+
+ spim: force
+ @touch .spim-made
+- make -f Makefile.std spim2
++ $(MAKE) -f Makefile.std spim2
+
+ spim2: $(OBJS) spim.o
+- $(CC) -g $(OBJS) spim.o $(LDFLAGS) -o spim -lm
++ $(CC) $(OBJS) spim.o $(LDFLAGS) -o spim -lm
+
+
+ xspim: force
+ @touch .spim-made
+- make -f Makefile.std xspim2
++ $(MAKE) -f Makefile.std xspim2
+
+ xspim2: $(OBJS) $(XOBJS) xspim.o
+- $(CC) -g $(OBJS) $(XOBJS) xspim.o $(LDFLAGS) $(XLDFLAGS) -o xspim -lm
++ $(CC) $(OBJS) $(XOBJS) xspim.o $(LDFLAGS) $(XLDFLAGS) -o xspim -lm
+
+ force: configuration
+
+@@ -200,11 +200,12 @@
+ spim.tar.* spim.aux spim.log spim.dvi spim.shar*
+
+ install: spim xspim
+- install -c -s spim $(BIN_DIR)
+- install -c -s xspim $(BIN_DIR)
+- install -c -m 0444 trap.handler $(TRAP_DIR)
+- install -c -m 0444 spim.man $(MAN_DIR)
+- install -c -m 0444 xspim.man $(MAN_DIR)
++ -mkdir -p $(BIN_DIR) $(TRAP_DIR) $(MAN_DIR)
++ ${BSD_INSTALL_PROGRAM} spim $(BIN_DIR)
++ ${BSD_INSTALL_PROGRAM} xspim $(BIN_DIR)
++ ${BSD_INSTALL_DATA} trap.handler $(TRAP_DIR)
++ ${BSD_INSTALL_MAN} spim.man $(MAN_DIR)/spim.1
++ ${BSD_INSTALL_MAN} xspim.man $(MAN_DIR)/xspim.1
+
+ very-clean: clean
+ rm -f y.tab.h y.tab.c lex.yy.c spim.tar* Documentation/spim.ps
diff --git a/emulators/spim/pkg-descr b/emulators/spim/pkg-descr
index 7119312777bc..666022e72e53 100644
--- a/emulators/spim/pkg-descr
+++ b/emulators/spim/pkg-descr
@@ -12,4 +12,6 @@ This simulator is useful in CS and EE classes, including providing a
target machine for compilers courses, lower division assembly language
programming, microprocessor design courses, etc...
+WWW: http://www.cs.wisc.edu/~larus/SPIM/
+
-- David O'Brien (obrien@cs.ucdavis.edu)
diff --git a/emulators/spim/pkg-plist b/emulators/spim/pkg-plist
index bd1fe2f424db..361c35233e3f 100644
--- a/emulators/spim/pkg-plist
+++ b/emulators/spim/pkg-plist
@@ -1,7 +1,7 @@
bin/spim
bin/xspim
-share/spim/trap.handler
%%PORTDOCS%%share/doc/spim/spim.ps.gz
%%PORTDOCS%%share/doc/spim/cycle.ps.gz
-%%PORTDOCS%%@dirrm share/doc/spim
+share/spim/trap.handler
@dirrm share/spim
+%%PORTDOCS%%@dirrm share/doc/spim