aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-02-05 20:30:25 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-02-05 20:42:36 +0000
commit471747153a83621deb72470fa0b10c23205b2d62 (patch)
tree56c759329c65a25af35896338af9888e4c965608
parentad243caa7fb4460a75f16457c90a9c0ddc7b166b (diff)
downloadports-471747153a83621deb72470fa0b10c23205b2d62.tar.gz
ports-471747153a83621deb72470fa0b10c23205b2d62.zip
devel/py-importlib-metadata: add explicit setuptools BUILD_DEPENDS
Per PEP-518 [0], for projects using setuptools as the build backend, both setuptools and wheel are to be specified, as wheel is a plugin for setuptools to support the format at all. Additionally, wheel itself will soon [1] not depend on setuptools, but rather the dependency tree will reverse. With hat: python Approved by: mentors (implicit), swills (maintainer, implicit) References: https://peps.python.org/pep-0518/#build-system-table [0] https://github.com/pypa/wheel/pull/501 [1]
-rw-r--r--devel/py-importlib-metadata/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/py-importlib-metadata/Makefile b/devel/py-importlib-metadata/Makefile
index 51dd799a6911..461323b77c3d 100644
--- a/devel/py-importlib-metadata/Makefile
+++ b/devel/py-importlib-metadata/Makefile
@@ -12,7 +12,8 @@ WWW= https://github.com/python/importlib_metadata
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zipp>=0.5:devel/py-zipp@${PY_FLAVOR}