aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2021-09-01 18:45:12 +0000
committerKai Knoblich <kai@FreeBSD.org>2021-09-01 18:45:12 +0000
commit4766669c83688f55de321201b070d5bc5c829931 (patch)
treef7f6dbd40330b0af07fcef3aac4b8d5d09adcda6
parent2dbca492ee282dc054a31cdc2efb6f904932ec97 (diff)
downloadports-4766669c83688f55de321201b070d5bc5c829931.tar.gz
ports-4766669c83688f55de321201b070d5bc5c829931.zip
www/qt5-webkit: Fix fetch of glib 2.68 workaround
The filesize of the glib 2.68 workaround changes for some reason intermittently from 841 bytes to 839 bytes when it's fetched: $ diff 5b698ba3faff_841_bytes.patch 5b698ba3faff_839_bytes.patch 14c14 < index 06133d82cb35d..d9a1d2f145f50 100644 --- > index 06133d82cb35..d9a1d2f145f5 100644 Therefore convert the patch into a local patch to remedy the issue. Reported by: tcberner, yuri MFH: No (not required, devel/glib20 is at 2.66.8 in 2021Q3)
-rw-r--r--www/qt5-webkit/Makefile6
-rw-r--r--www/qt5-webkit/distinfo2
-rw-r--r--www/qt5-webkit/files/patch-Source_WTF_wtf_glib_GRefPtr.h24
3 files changed, 26 insertions, 6 deletions
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index ab828bf60666..b2831a472319 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -6,10 +6,8 @@ MASTER_SITES= https://github.com/qt${PORTNAME}/qt${PORTNAME}/releases/download/
PKGNAMEPREFIX= qt5-
DISTNAME= qt${PORTNAME}-${DISTVERSION}
-PATCH_SITES= https://github.com/qt${PORTNAME}/qt${PORTNAME}/commit/ \
- https://github.com/qtwebkit/qtwebkit/pull/1058/commits/:glib268
-PATCHFILES+= 78360c01c796b6260bf828bc9c8a0ef73c5132fd.patch:-p1 \
- 5b698ba3faffd4e198a45be9fe74f53307395e4b.patch:-p1:glib268
+PATCH_SITES= https://github.com/qt${PORTNAME}/qt${PORTNAME}/commit/
+PATCHFILES+= 78360c01c796b6260bf828bc9c8a0ef73c5132fd.patch:-p1
MAINTAINER= kde@FreeBSD.org
COMMENT= QtWebKit with a more modern WebKit code base
diff --git a/www/qt5-webkit/distinfo b/www/qt5-webkit/distinfo
index 0a2cde9210e0..705582e44c58 100644
--- a/www/qt5-webkit/distinfo
+++ b/www/qt5-webkit/distinfo
@@ -3,5 +3,3 @@ SHA256 (qtwebkit-5.212.0-alpha4.tar.xz) = 9ca126da9273664dd23a3ccd0c9bebceb7bb53
SIZE (qtwebkit-5.212.0-alpha4.tar.xz) = 12528508
SHA256 (78360c01c796b6260bf828bc9c8a0ef73c5132fd.patch) = 9db5480dfbd3c440489e8e4131e3555b2af61fa4b6c19f35227588c5996be128
SIZE (78360c01c796b6260bf828bc9c8a0ef73c5132fd.patch) = 1100
-SHA256 (5b698ba3faffd4e198a45be9fe74f53307395e4b.patch) = aee2faef4e77809051cef163195b9be4fc4ec1302d4ceca4c6027d3f5d8d2a25
-SIZE (5b698ba3faffd4e198a45be9fe74f53307395e4b.patch) = 841
diff --git a/www/qt5-webkit/files/patch-Source_WTF_wtf_glib_GRefPtr.h b/www/qt5-webkit/files/patch-Source_WTF_wtf_glib_GRefPtr.h
new file mode 100644
index 000000000000..cdb0307225ec
--- /dev/null
+++ b/www/qt5-webkit/files/patch-Source_WTF_wtf_glib_GRefPtr.h
@@ -0,0 +1,24 @@
+From: Fabian Vogt <fvogt@suse.de>
+Date: Wed, 7 Apr 2021 13:38:09 +0200
+Subject: [PATCH] Remove invalid g_object declarations to fix build with glib
+ >= 2.68
+
+ g_object_ref_sink is defined as a macro meanwhile and so the build fails.
+ Just remove the declarations, glib.h is included anyway.
+
+Obtained from:
+
+https://github.com/qtwebkit/qtwebkit/commit/5b698ba3faffd4e198a45be9fe74f53307395e4b.patch
+
+--- Source/WTF/wtf/glib/GRefPtr.h.orig 2020-03-04 17:16:37 UTC
++++ Source/WTF/wtf/glib/GRefPtr.h
+@@ -29,9 +29,6 @@
+ #include <wtf/RefPtr.h>
+ #include <algorithm>
+
+-extern "C" void g_object_unref(gpointer);
+-extern "C" gpointer g_object_ref_sink(gpointer);
+-
+ namespace WTF {
+
+ enum GRefPtrAdoptType { GRefPtrAdopt };