aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-10 13:30:00 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-01-10 13:30:00 +0000
commit47721a7247d2d9ad1e6cb47a518090305254016f (patch)
tree0818295115af801f37030c4a0fec35c323b2a552
parent39e1835244cbdb461de7af510a26a3004408f3f0 (diff)
downloadports-47721a7247d2d9ad1e6cb47a518090305254016f.tar.gz
ports-47721a7247d2d9ad1e6cb47a518090305254016f.zip
Mark ports to IGNORE with new php81
Approved by: portmgr (infrastructure blanket) Sponsored by: Bounce Experts
-rw-r--r--archivers/pecl-rar/Makefile1
-rw-r--r--chinese/php-opencc/Makefile2
-rw-r--r--databases/pecl-cassandra/Makefile2
-rw-r--r--databases/pecl-couchbase/Makefile2
-rw-r--r--databases/php-xapian/Makefile2
-rw-r--r--deskutils/moregroupware/Makefile25
-rw-r--r--devel/arcanist-lib/Makefile1
-rw-r--r--devel/ioncube/Makefile2
-rw-r--r--devel/pecl-APCu_bc/Makefile2
-rw-r--r--devel/pecl-ds/Makefile1
-rw-r--r--devel/pecl-eio/Makefile2
-rw-r--r--devel/pecl-hrtime/Makefile2
-rw-r--r--devel/pecl-jsmin/Makefile2
-rw-r--r--devel/pecl-jsond/Makefile2
-rw-r--r--devel/pecl-propro2/Makefile5
-rw-r--r--devel/pecl-runkit7/Makefile1
-rw-r--r--devel/pecl-sync/Makefile2
-rw-r--r--devel/pecl-uv/Makefile1
-rw-r--r--devel/php-ice37/Makefile2
-rw-r--r--ftp/php-fastdfs/Makefile2
-rw-r--r--math/pecl-stats2/Makefile3
-rw-r--r--net-im/pecl-stomp2/Makefile2
-rw-r--r--net/pecl-amqp/Makefile2
-rw-r--r--net/pecl-mosquitto/Makefile2
-rw-r--r--net/pecl-rdkafka/Makefile2
-rw-r--r--net/pecl-xmlrpc/Makefile3
-rw-r--r--net/pecl-zmq/Makefile3
-rw-r--r--print/pecl-pdflib/Makefile3
-rw-r--r--security/pecl-crypto/Makefile2
-rw-r--r--security/pecl-pkcs11/Makefile2
-rw-r--r--sysutils/pecl-proctitle/Makefile2
-rw-r--r--textproc/php-mecab/Makefile2
-rw-r--r--www/pecl-http/Makefile16
-rw-r--r--www/pecl-yaf/Makefile2
-rw-r--r--www/phalcon/Makefile2
-rw-r--r--www/phalcon4/Makefile2
-rw-r--r--www/phpgroupware/Makefile1
-rw-r--r--www/zend-framework1/Makefile22
38 files changed, 67 insertions, 67 deletions
diff --git a/archivers/pecl-rar/Makefile b/archivers/pecl-rar/Makefile
index 15aa0c26f13e..8e3eb421360e 100644
--- a/archivers/pecl-rar/Makefile
+++ b/archivers/pecl-rar/Makefile
@@ -11,6 +11,7 @@ LICENSE= PHP301
USES= compiler:c11 php:pecl
USE_PHP= spl:build
+IGNORE_WITH_PHP= 81
CONFIGURE_ARGS= --enable-rar
diff --git a/chinese/php-opencc/Makefile b/chinese/php-opencc/Makefile
index a57e7af554bc..108f38498833 100644
--- a/chinese/php-opencc/Makefile
+++ b/chinese/php-opencc/Makefile
@@ -18,6 +18,6 @@ GH_PROJECT= opencc4php
GH_TAGNAME= 8007639
USES= php:ext
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/databases/pecl-cassandra/Makefile b/databases/pecl-cassandra/Makefile
index 80f9d6061bb1..7c2df6e634a3 100644
--- a/databases/pecl-cassandra/Makefile
+++ b/databases/pecl-cassandra/Makefile
@@ -20,7 +20,7 @@ GH_ACCOUNT= datastax
GH_PROJECT= php-driver
GH_TAGNAME= 61faee0
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
PHP_MODNAME= cassandra
WRKSRC_SUBDIR= ext
diff --git a/databases/pecl-couchbase/Makefile b/databases/pecl-couchbase/Makefile
index 2a4d50f0375a..7c23133a12f5 100644
--- a/databases/pecl-couchbase/Makefile
+++ b/databases/pecl-couchbase/Makefile
@@ -16,6 +16,6 @@ LIB_DEPENDS= libcouchbase.so:databases/libcouchbase
USES= php:pecl
USE_PHP= json:build
-IGNORE_WITH_PHP=80
+IGNORE_WITH_PHP=80 81
.include <bsd.port.mk>
diff --git a/databases/php-xapian/Makefile b/databases/php-xapian/Makefile
index 7fcf46ccde51..e0825e73886f 100644
--- a/databases/php-xapian/Makefile
+++ b/databases/php-xapian/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= xapian-core>=${PORTVERSION}:databases/xapian-core
LIB_DEPENDS= libxapian.so:databases/xapian-core
USES= compiler:c++11-lang libtool php:build,flavors tar:xz
+IGNORE_WITH_PHP=80 81
CONFIGURE_ARGS= --datarootdir=${DATADIR} \
--docdir=${DOCSDIR} \
@@ -35,7 +36,6 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} \
--without-tcl
CONFIGURE_ENV= PHP_CONFIG=${LOCALBASE}/bin/php-config
GNU_CONFIGURE= yes
-IGNORE_WITH_PHP=80
INSTALL_TARGET= install-strip
USE_CXXSTD= c++11
diff --git a/deskutils/moregroupware/Makefile b/deskutils/moregroupware/Makefile
index de9ae15ee2a8..93aad40e686a 100644
--- a/deskutils/moregroupware/Makefile
+++ b/deskutils/moregroupware/Makefile
@@ -10,33 +10,34 @@ DISTNAME= ${PORTNAME}-core-${PORTVERSION}
MAINTAINER= eksffa@freebsdbrasil.com.br
COMMENT= Web based GroupWare system
+USES= gettext php:mod
+WANT_PGSQL= server
# php extensions
USE_PHP= curl \
gd \
pcre \
session \
xml
+IGNORE_WITH_PHP= 81
-USES= gettext php:mod
+SHAREOWN= ${WWWOWN}
+SHAREGRP= ${WWWGRP}
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= ADDONS NLS
+OPTIONS_DEFAULT= MYSQL
OPTIONS_SINGLE= DB
OPTIONS_SINGLE_DB= PGSQL MYSQL
-OPTIONS_DEFAULT= MYSQL
-ADDONS_DESC= install additional workgroup features (addons)
OPTIONS_SUB= yes
-NLS_USES= gettext
-PGSQL_USES= pgsql
-WANT_PGSQL= server
-MYSQL_USES= mysql:server
+ADDONS_DESC= install additional workgroup features (addons)
ADDONS_DISTFILES= ${PORTNAME}-addons-${PORTVERSION}${EXTRACT_SUFX}
-NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-SHAREOWN= ${WWWOWN}
-SHAREGRP= ${WWWGRP}
+MYSQL_USES= mysql:server
+NLS_USES= gettext
+PGSQL_USES= pgsql
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
diff --git a/devel/arcanist-lib/Makefile b/devel/arcanist-lib/Makefile
index 7344c35a2d3d..a69b558a731c 100644
--- a/devel/arcanist-lib/Makefile
+++ b/devel/arcanist-lib/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PHP_DESTDIR= lib/php/arcanist
USES= php:cli,flavors python:env shebangfix
+IGNORE_WITH_PHP= 81
SHEBANG_FILES= bin/arc \
bin/phage \
scripts/*.php \
diff --git a/devel/ioncube/Makefile b/devel/ioncube/Makefile
index 869a403102c0..22da7235e72e 100644
--- a/devel/ioncube/Makefile
+++ b/devel/ioncube/Makefile
@@ -22,7 +22,7 @@ IGNORE_DragonFly= is unsupported on DragonFly
ONLY_FOR_ARCHS= amd64 i386
NO_BUILD= yes
USES= php:flavors
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
SUB_FILES= pkg-message
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/pecl-APCu_bc/Makefile b/devel/pecl-APCu_bc/Makefile
index 99b55d132c5d..c5237115dcbe 100644
--- a/devel/pecl-APCu_bc/Makefile
+++ b/devel/pecl-APCu_bc/Makefile
@@ -13,7 +13,7 @@ BUILD_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu@${PHP_F
USES= localbase php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
PHP_MODNAME= apc
PHP_MOD_PRIO=30
diff --git a/devel/pecl-ds/Makefile b/devel/pecl-ds/Makefile
index 04dc5df62c59..4ab48fe55caa 100644
--- a/devel/pecl-ds/Makefile
+++ b/devel/pecl-ds/Makefile
@@ -12,5 +12,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= localbase php:pecl
USE_PHP= json:build
+IGNORE_WITH_PHP= 81
.include <bsd.port.mk>
diff --git a/devel/pecl-eio/Makefile b/devel/pecl-eio/Makefile
index ecd32b10613b..b114c9405eec 100644
--- a/devel/pecl-eio/Makefile
+++ b/devel/pecl-eio/Makefile
@@ -10,7 +10,7 @@ COMMENT= Provides interface to the libeio library
LICENSE= PHP301
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
CONFIGURE_ARGS= --enable-eio
diff --git a/devel/pecl-hrtime/Makefile b/devel/pecl-hrtime/Makefile
index defdc18e4fca..f469265b15d9 100644
--- a/devel/pecl-hrtime/Makefile
+++ b/devel/pecl-hrtime/Makefile
@@ -10,6 +10,6 @@ COMMENT= High resolution timing for PHP
LICENSE= BSD2CLAUSE
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/devel/pecl-jsmin/Makefile b/devel/pecl-jsmin/Makefile
index 36f1217ceb6e..0308aef0322f 100644
--- a/devel/pecl-jsmin/Makefile
+++ b/devel/pecl-jsmin/Makefile
@@ -10,6 +10,6 @@ COMMENT= PHP extension for minifying JavaScript
LICENSE= PHP301
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/devel/pecl-jsond/Makefile b/devel/pecl-jsond/Makefile
index 4c33f885a462..0ad5b97eb6b9 100644
--- a/devel/pecl-jsond/Makefile
+++ b/devel/pecl-jsond/Makefile
@@ -10,6 +10,6 @@ COMMENT= JavaScript Object Notation in PHP
LICENSE= PHP301
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/devel/pecl-propro2/Makefile b/devel/pecl-propro2/Makefile
index 03e9adf98417..0656635a75d9 100644
--- a/devel/pecl-propro2/Makefile
+++ b/devel/pecl-propro2/Makefile
@@ -10,10 +10,7 @@ COMMENT= Facility to manage extension object properties
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-PORTSCOUT= limit:^2.*
-
USES= gmake php:pecl
-IGNORE_WITH_PHP= 80
-CONFLICTS= pecl-propro-1*
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/devel/pecl-runkit7/Makefile b/devel/pecl-runkit7/Makefile
index b8b2f9b5988c..54d8592b3a55 100644
--- a/devel/pecl-runkit7/Makefile
+++ b/devel/pecl-runkit7/Makefile
@@ -8,5 +8,6 @@ COMMENT= Extension to replace, rename, and remove user functions and classes
LICENSE= PHP301
USES= compiler:c11 php:pecl
+IGNORE_WITH_PHP= 81
.include <bsd.port.mk>
diff --git a/devel/pecl-sync/Makefile b/devel/pecl-sync/Makefile
index 8a08fb868df1..bfcad76cb14a 100644
--- a/devel/pecl-sync/Makefile
+++ b/devel/pecl-sync/Makefile
@@ -11,6 +11,6 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/devel/pecl-uv/Makefile b/devel/pecl-uv/Makefile
index 64fd8ad405ab..0cceeecdc971 100644
--- a/devel/pecl-uv/Makefile
+++ b/devel/pecl-uv/Makefile
@@ -14,5 +14,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libuv.so:devel/libuv
USES= php:pecl
+IGNORE_WITH_PHP= 81
.include <bsd.port.mk>
diff --git a/devel/php-ice37/Makefile b/devel/php-ice37/Makefile
index 414cda4d4a0c..9117ddad8d86 100644
--- a/devel/php-ice37/Makefile
+++ b/devel/php-ice37/Makefile
@@ -21,7 +21,7 @@ PLIST= ${.CURDIR}/pkg-plist
MAKE_ARGS+= PHP_EXT_DIR=${PHP_EXT_DIR} ICE_HOME=${LOCALBASE} \
PHP_HOME=${LOCALBASE} OPTIMIZE=yes
USES+= php:build,flavors
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
BUILD_WRKSRC= ${WRKSRC}/php
INSTALL_WRKSRC= ${WRKSRC}/php
diff --git a/ftp/php-fastdfs/Makefile b/ftp/php-fastdfs/Makefile
index 337c9379bf2c..bfb8446d4825 100644
--- a/ftp/php-fastdfs/Makefile
+++ b/ftp/php-fastdfs/Makefile
@@ -12,12 +12,12 @@ LIB_DEPENDS= libfastcommon.so:devel/libfastcommon \
libfdfsclient.so:ftp/fastdfs
USES= php:ext
-IGNORE_WITH_PHP= 80
USE_GITHUB= yes
GH_ACCOUNT= happyfish100
GH_PROJECT= fastdfs
GH_TAGNAME= V6.06
+IGNORE_WITH_PHP= 80 81
WRKSRC_SUBDIR= php_client
CONFIGURE_ENV= ROOT=${LOCALBASE}
diff --git a/math/pecl-stats2/Makefile b/math/pecl-stats2/Makefile
index af2b5f18d5b7..2e9568924a11 100644
--- a/math/pecl-stats2/Makefile
+++ b/math/pecl-stats2/Makefile
@@ -9,8 +9,7 @@ LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
-IGNORE_WITH_PHP= 80
-CONFLICTS= pecl-stats-1*
+IGNORE_WITH_PHP= 80 81
PORTSCOUT= limit:^2.*
diff --git a/net-im/pecl-stomp2/Makefile b/net-im/pecl-stomp2/Makefile
index 32c016b141b7..f6131bd31538 100644
--- a/net-im/pecl-stomp2/Makefile
+++ b/net-im/pecl-stomp2/Makefile
@@ -9,7 +9,7 @@ LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
CONFLICTS= pecl-stomp-1*
PORTSCOUT= limit:^2.*
diff --git a/net/pecl-amqp/Makefile b/net/pecl-amqp/Makefile
index f73855a494a9..636eecd240cb 100644
--- a/net/pecl-amqp/Makefile
+++ b/net/pecl-amqp/Makefile
@@ -13,6 +13,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= librabbitmq.so:net/rabbitmq-c-devel
USES= php:pecl localbase
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/net/pecl-mosquitto/Makefile b/net/pecl-mosquitto/Makefile
index dbd23bc974a0..eb20d369b498 100644
--- a/net/pecl-mosquitto/Makefile
+++ b/net/pecl-mosquitto/Makefile
@@ -13,6 +13,6 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= mosquitto>=0:net/mosquitto
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/net/pecl-rdkafka/Makefile b/net/pecl-rdkafka/Makefile
index d1e414321a9d..a8f94b02fea6 100644
--- a/net/pecl-rdkafka/Makefile
+++ b/net/pecl-rdkafka/Makefile
@@ -11,6 +11,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= librdkafka.so:net/librdkafka
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/net/pecl-xmlrpc/Makefile b/net/pecl-xmlrpc/Makefile
index cef94960cef5..e622ffc18226 100644
--- a/net/pecl-xmlrpc/Makefile
+++ b/net/pecl-xmlrpc/Makefile
@@ -11,11 +11,10 @@ COMMENT= PHP extension for XML-RPC servers and clients
LICENSE= PHP301
LICENSE_FILE= ${WRKSRC}/LICENSE
-IGNORE_WITH_PHP= 73 74
-
USES= iconv:translit gnome php:pecl pkgconfig
USE_PHP= xml:build
USE_GNOME= libxml2
+IGNORE_WITH_PHP= 73 74 81
CONFIGURE_ARGS+= --with-iconv-dir=${LOCALBASE}
diff --git a/net/pecl-zmq/Makefile b/net/pecl-zmq/Makefile
index bd7281317f1e..000a3bbb17fa 100644
--- a/net/pecl-zmq/Makefile
+++ b/net/pecl-zmq/Makefile
@@ -8,10 +8,9 @@ COMMENT= PHP bindings for ZeroMQ
LICENSE= BSD3CLAUSE
-IGNORE_WITH_PHP= 80
-
LIB_DEPENDS= libzmq.so:net/libzmq4
USES= php:pecl pkgconfig
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/print/pecl-pdflib/Makefile b/print/pecl-pdflib/Makefile
index b1ebfe5a7878..9ecf16c17d4e 100644
--- a/print/pecl-pdflib/Makefile
+++ b/print/pecl-pdflib/Makefile
@@ -13,13 +13,12 @@ LICENSE_NAME= PDFlib GmbH General License
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= none
-IGNORE_WITH_PHP=80
-
LIB_DEPENDS= libpdf.so:print/pdflib
USES= php:pecl
USE_PHP= gd:build
+IGNORE_WITH_PHP=80 81
PHP_MODNAME= pdf
CONFIGURE_ARGS= --with-pdflib=${LOCALBASE}
diff --git a/security/pecl-crypto/Makefile b/security/pecl-crypto/Makefile
index 31b90f4fcd5b..f6941375d1c2 100644
--- a/security/pecl-crypto/Makefile
+++ b/security/pecl-crypto/Makefile
@@ -11,9 +11,9 @@ COMMENT= Objective wrapper for OpenSSL Crypto Library
LICENSE= PHP301
USES= compiler:c++11-lang php:pecl
+IGNORE_WITH_PHP= 80 81
CONFIGURE_ARGS= --with-crypto
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-IGNORE_WITH_PHP= 80
.include <bsd.port.mk>
diff --git a/security/pecl-pkcs11/Makefile b/security/pecl-pkcs11/Makefile
index 50fea54ca3b0..2e9f3dda8d8d 100644
--- a/security/pecl-pkcs11/Makefile
+++ b/security/pecl-pkcs11/Makefile
@@ -12,6 +12,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= localbase php:pecl
-IGNORE_WITH_PHP=73
+IGNORE_WITH_PHP=73 81
.include <bsd.port.mk>
diff --git a/sysutils/pecl-proctitle/Makefile b/sysutils/pecl-proctitle/Makefile
index 3c41f89b21cf..79f986698d6e 100644
--- a/sysutils/pecl-proctitle/Makefile
+++ b/sysutils/pecl-proctitle/Makefile
@@ -9,6 +9,6 @@ MAINTAINER= flo@FreeBSD.org
COMMENT= PECL extension that allows changing the current process' name
USES= php:pecl
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/textproc/php-mecab/Makefile b/textproc/php-mecab/Makefile
index 8c3ef5e2bbe5..f623563d71ac 100644
--- a/textproc/php-mecab/Makefile
+++ b/textproc/php-mecab/Makefile
@@ -14,11 +14,11 @@ LICENSE= MIT
LIB_DEPENDS= libmecab.so:japanese/mecab
-IGNORE_WITH_PHP= 80
USES= php:ext
USE_GITHUB= yes
GH_ACCOUNT= rsky
GH_PROJECT= php-${PORTNAME}
+IGNORE_WITH_PHP= 80 81
WRKSRC_SUBDIR= mecab
CONFIGURE_ARGS= --with-mecab=${LOCALBASE}/bin/mecab-config
diff --git a/www/pecl-http/Makefile b/www/pecl-http/Makefile
index 80167755c922..afd5771b2b65 100644
--- a/www/pecl-http/Makefile
+++ b/www/pecl-http/Makefile
@@ -12,22 +12,20 @@ COMMENT= Extended HTTP Support
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_mips= fails to compile: pecl_http-3.1.0/src/php_http_etag.c:63:20: \#if with no expression
-BROKEN_mips64= fails to compile: pecl_http-3.1.0/src/php_http_etag.c:63:20: \#if with no expression
+BROKEN_mips= fails to compile: pecl_http-3.1.0/src/php_http_etag.c:63:20: \#if with no expression
+BROKEN_mips64= fails to compile: pecl_http-3.1.0/src/php_http_etag.c:63:20: \#if with no expression
-BUILD_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf2@${PHP_FLAVOR} \
- ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/propro.so:devel/pecl-propro2@${PHP_FLAVOR} \
+BUILD_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/propro.so:devel/pecl-propro2@${PHP_FLAVOR} \
+ ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf2@${PHP_FLAVOR} \
re2c:devel/re2c
-RUN_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf2@${PHP_FLAVOR} \
- ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/propro.so:devel/pecl-propro2@${PHP_FLAVOR}
LIB_DEPENDS= libcurl.so:ftp/curl \
libevent.so:devel/libevent \
libicudata.so:devel/icu
+RUN_DEPENDS= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/propro.so:devel/pecl-propro2@${PHP_FLAVOR} \
+ ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/raphf.so:devel/pecl-raphf2@${PHP_FLAVOR}
USES= php:pecl
USE_PHP= zlib:build
-IGNORE_WITH_PHP= 80
-
-CONFLICTS= pecl-http[12]*
+IGNORE_WITH_PHP= 80 81
.include <bsd.port.mk>
diff --git a/www/pecl-yaf/Makefile b/www/pecl-yaf/Makefile
index 7386296cfdd1..d2a54149392a 100644
--- a/www/pecl-yaf/Makefile
+++ b/www/pecl-yaf/Makefile
@@ -14,4 +14,6 @@ LIB_DEPENDS= libpcre.so:devel/pcre
USES= localbase php:pecl
+IGNORE_WITH_PHP= 81
+
.include <bsd.port.mk>
diff --git a/www/phalcon/Makefile b/www/phalcon/Makefile
index f14296b23236..cb245552ff37 100644
--- a/www/phalcon/Makefile
+++ b/www/phalcon/Makefile
@@ -15,7 +15,7 @@ ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386 powerpc powerpc64 powerpc64le
USES= localbase php:ext
USE_PHP= hash:build json:build pdo:build
-IGNORE_WITH_PHP=74 80
+IGNORE_WITH_PHP=74 80 81
USE_GITHUB= yes
GH_PROJECT= c${PORTNAME}
diff --git a/www/phalcon4/Makefile b/www/phalcon4/Makefile
index 7b2c24773c71..d2b240f29bb5 100644
--- a/www/phalcon4/Makefile
+++ b/www/phalcon4/Makefile
@@ -19,7 +19,7 @@ USE_GITHUB= yes
GH_PROJECT= c${PORTNAME}
USE_PHP= hash:build json:build mbstring pdo:build session
-IGNORE_WITH_PHP= 80
+IGNORE_WITH_PHP= 80 81
PHP_MOD_PRIO= 30
CONFIGURE_ARGS= --enable-phalcon
diff --git a/www/phpgroupware/Makefile b/www/phpgroupware/Makefile
index 78415f1029eb..f7ce450b1d1f 100644
--- a/www/phpgroupware/Makefile
+++ b/www/phpgroupware/Makefile
@@ -7,6 +7,7 @@ MAINTAINER= olgeni@FreeBSD.org
COMMENT= Web based GroupWare system
USES= php:mod tar:bzip2
+IGNORE_WITH_PHP= 81
NO_BUILD= yes
NO_ARCH= yes
diff --git a/www/zend-framework1/Makefile b/www/zend-framework1/Makefile
index c4d317474974..121e358c00f4 100644
--- a/www/zend-framework1/Makefile
+++ b/www/zend-framework1/Makefile
@@ -13,29 +13,29 @@ COMMENT= Framework for developing PHP web applications
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-IGNORE_WITH_PHP= 74
-
-NO_ARCH= yes
-NO_BUILD= yes
-USE_PHP= spl
USES= gettext php:web
+USE_PHP= spl
+IGNORE_WITH_PHP= 74 81
CONFLICTS= ZendFramework-2.*
-PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
+NO_ARCH= yes
+NO_BUILD= yes
SUB_FILES= pkg-message
+PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
+
OPTIONS_DEFINE= DOCS EXAMPLES MYSQL MYSQLI DBLIB PGSQL ODBC SQLITE REQPHP OPTPHP
OPTIONS_DEFAULT=REQPHP
-MYSQL_DESC= Enable MySQL PDO support
-MYSQLI_DESC= Enable MySQLi support
DBLIB_DESC= Enable DBLIB PDO support
-PGSQL_DESC= Enable PostgreSQL PDO support
+MYSQLI_DESC= Enable MySQLi support
+MYSQL_DESC= Enable MySQL PDO support
ODBC_DESC= Enable ODBC PDO support
-SQLITE_DESC= Enable SQLite v3 PDO support
-REQPHP_DESC= Install required PHP dependencies
OPTPHP_DESC= Install optional PHP dependencies
+PGSQL_DESC= Enable PostgreSQL PDO support
+REQPHP_DESC= Install required PHP dependencies
+SQLITE_DESC= Enable SQLite v3 PDO support
.include <bsd.port.pre.mk>