aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2021-10-20 22:52:51 +0000
committerThomas Zander <riggs@FreeBSD.org>2021-10-20 22:54:08 +0000
commit479c5b288a6ee070b38e311316fa5cd63b4519bd (patch)
tree55a6ed0744046e83ccad6821f44352f3f1495187
parent0c631e628d84f25227219074966ca524209d9eb2 (diff)
downloadports-479c5b288a6ee070b38e311316fa5cd63b4519bd.tar.gz
ports-479c5b288a6ee070b38e311316fa5cd63b4519bd.zip
audio/musicpd: Update to upstream release 0.23.1
-rw-r--r--audio/musicpd/Makefile4
-rw-r--r--audio/musicpd/distinfo6
-rw-r--r--audio/musicpd/files/patch-src_neighbor_plugins_SmbclientNeighborPlugin.cxx50
-rw-r--r--audio/musicpd/files/patch-src_storage_plugins_SmbclientStorage.cxx21
4 files changed, 5 insertions, 76 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 1132de5e333c..fa91161d61ec 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -1,7 +1,7 @@
PORTNAME= musicpd
-PORTVERSION= 0.23
+PORTVERSION= 0.23.1
CATEGORIES= audio
-MASTER_SITES= https://www.musicpd.org/download/mpd/${PORTVERSION}/
+MASTER_SITES= https://www.musicpd.org/download/mpd/${PORTVERSION:R}/
DISTNAME= mpd-${PORTVERSION}
MAINTAINER= riggs@FreeBSD.org
diff --git a/audio/musicpd/distinfo b/audio/musicpd/distinfo
index 6ba2ffde1abe..6a25b5bce89b 100644
--- a/audio/musicpd/distinfo
+++ b/audio/musicpd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1634384255
-SHA256 (mpd-0.23.tar.xz) = 73562c7e6d5815e84de9485c9947c98fa5b9c2d761c3fb23df7004b9b8beb85a
-SIZE (mpd-0.23.tar.xz) = 764184
+TIMESTAMP = 1634768410
+SHA256 (mpd-0.23.1.tar.xz) = 93990f026886cee3b8707b38cef575b1904f4a6e5fc6d92b2a82ba2a3a6302bd
+SIZE (mpd-0.23.1.tar.xz) = 764920
diff --git a/audio/musicpd/files/patch-src_neighbor_plugins_SmbclientNeighborPlugin.cxx b/audio/musicpd/files/patch-src_neighbor_plugins_SmbclientNeighborPlugin.cxx
deleted file mode 100644
index c8c90a1d62b7..000000000000
--- a/audio/musicpd/files/patch-src_neighbor_plugins_SmbclientNeighborPlugin.cxx
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/neighbor/plugins/SmbclientNeighborPlugin.cxx.orig 2021-10-14 13:25:21 UTC
-+++ src/neighbor/plugins/SmbclientNeighborPlugin.cxx
-@@ -33,6 +33,8 @@
-
- #include <libsmbclient.h>
-
-+#include <cerrno>
-+#include <cstring>
- #include <utility>
-
- class SmbclientNeighborExplorer final : public NeighborExplorer {
-@@ -45,12 +47,12 @@ class SmbclientNeighborExplorer final : public Neighbo
-
- Server(const Server &) = delete;
-
-- gcc_pure
-+ [[gnu::pure]]
- bool operator==(const Server &other) const noexcept {
- return name == other.name;
- }
-
-- [[nodiscard]] gcc_pure
-+ [[nodiscard]] [[gnu::pure]]
- NeighborInfo Export() const noexcept {
- return { "smb://" + name + "/", comment };
- }
-@@ -165,11 +167,11 @@ ReadServers(SmbclientContext &ctx, const char *uri,
- ReadServers(ctx, handle, list);
- ctx.CloseDirectory(handle);
- } else
-- FormatErrno(smbclient_domain, "smbc_opendir('%s') failed",
-- uri);
-+ FmtError(smbclient_domain, "smbc_opendir('{}') failed: {}",
-+ uri, strerror(errno));
- }
-
--gcc_pure
-+[[gnu::pure]]
- static NeighborExplorer::List
- DetectServers(SmbclientContext &ctx) noexcept
- {
-@@ -178,7 +180,7 @@ DetectServers(SmbclientContext &ctx) noexcept
- return list;
- }
-
--gcc_pure
-+[[gnu::pure]]
- static NeighborExplorer::List::iterator
- FindBeforeServerByURI(NeighborExplorer::List::iterator prev,
- NeighborExplorer::List::iterator end,
diff --git a/audio/musicpd/files/patch-src_storage_plugins_SmbclientStorage.cxx b/audio/musicpd/files/patch-src_storage_plugins_SmbclientStorage.cxx
deleted file mode 100644
index acb8680d62e1..000000000000
--- a/audio/musicpd/files/patch-src_storage_plugins_SmbclientStorage.cxx
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/storage/plugins/SmbclientStorage.cxx.orig 2021-10-14 13:25:21 UTC
-+++ src/storage/plugins/SmbclientStorage.cxx
-@@ -186,15 +186,15 @@ SmbclientDirectoryReader::GetInfo([[maybe_unused]] boo
- static std::unique_ptr<Storage>
- CreateSmbclientStorageURI([[maybe_unused]] EventLoop &event_loop, const char *base)
- {
-- if (!StringStartsWithCaseASCII(base, "smb://"))
-- return nullptr;
--
- SmbclientInit();
-
- return std::make_unique<SmbclientStorage>(base);
- }
-
-+static constexpr const char *smbclient_prefixes[] = { "smb://", nullptr };
-+
- const StoragePlugin smbclient_storage_plugin = {
- "smbclient",
-+ smbclient_prefixes,
- CreateSmbclientStorageURI,
- };