aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-20 22:02:36 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-20 22:03:00 +0000
commit47fb20c30c51fec8aec96ce9bcd6d2e94493f49d (patch)
tree538d57ea4fd62edc59aaea4ceab38ac67572e937
parent8b4b845a5189060785ac47d3e95a913d896e7641 (diff)
downloadports-47fb20c30c51fec8aec96ce9bcd6d2e94493f49d.tar.gz
ports-47fb20c30c51fec8aec96ce9bcd6d2e94493f49d.zip
math/moab: Fix MPI option
-rw-r--r--math/moab/Makefile10
-rw-r--r--math/moab/files/patch-CMakeLists.txt3
-rw-r--r--math/moab/pkg-plist5
3 files changed, 11 insertions, 7 deletions
diff --git a/math/moab/Makefile b/math/moab/Makefile
index bce64266e692..29d81648abeb 100644
--- a/math/moab/Makefile
+++ b/math/moab/Makefile
@@ -1,5 +1,6 @@
PORTNAME= moab
DISTVERSION= 5.3.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
@@ -13,7 +14,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libnetcdf.so:science/netcdf \
libopenblas.so:math/openblas
-USES= cmake compiler:c++11-lang eigen:3 fortran
+USES= cmake eigen:3 fortran
USE_LDCONFIG= yes
CMAKE_ARGS= -DBLAS_LIBRARIES:STRING=${LOCALBASE}/lib/libopenblas.so \
@@ -27,12 +28,15 @@ BB_COMMIT= 65880ffe833d
WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
OPTIONS_DEFINE= MPI
-OPTIONS_DEFAULT= #MPI
+OPTIONS_DEFAULT= MPI
OPTIONS_SUB= yes
MPI_CMAKE_BOOL= ENABLE_MPI
MPI_LIB_DEPENDS= libmpi.so:net/openmpi
-MPI_BROKEN= Build fails, see https://bitbucket.org/fathomteam/moab/issues/158/531-fails-to-build-with-openmpi-undefined
+MPI_LDFLAGS= -L${LOCALBASE}/mpi/openmpi/lib
+MPI_VARS= CXX=${LOCALBASE}/mpi/openmpi/bin/mpic++ CC=${LOCALBASE}/mpi/openmpi/bin/mpicc
+OPENMPI_VARS= CONFLICTS_BUILD=mpich # otherwise bin/hexmodops gets linked with libmpi.so:net/mpich
+OPENMPI_VARS_OFF= USES=compiler:c++11-lang
post-install:
# docs are just readmes
diff --git a/math/moab/files/patch-CMakeLists.txt b/math/moab/files/patch-CMakeLists.txt
index 32dc03a0a7bc..0c92f1b054cc 100644
--- a/math/moab/files/patch-CMakeLists.txt
+++ b/math/moab/files/patch-CMakeLists.txt
@@ -11,14 +11,13 @@
if ( MOAB_HAVE_FBIGEOM )
CONFIGURE_FILE(itaps/fbigeom/FBiGeom-Defs.inc.in "${PROJECT_BINARY_DIR}/lib/FBiGeom-Defs.inc" @ONLY)
install(
-@@ -636,23 +636,24 @@ if ( MOAB_HAVE_IMESH )
+@@ -636,23 +636,23 @@ if ( MOAB_HAVE_IMESH )
endif ( MOAB_HAVE_IMESH )
INSTALL(
FILES "${PROJECT_BINARY_DIR}/lib/moab.make"
- DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ DESTINATION lib
)
-+message(STATUS "YURI DESTDIR=${FREEBSD_STAGEDIR}")
INSTALL(
CODE
- "file(APPEND ${CMAKE_INSTALL_FULL_LIBDIR}/moab.make MOAB_LIBDIR=${CMAKE_INSTALL_FULL_LIBDIR}\\n )"
diff --git a/math/moab/pkg-plist b/math/moab/pkg-plist
index 820d40b77a4d..8b3bb286b66d 100644
--- a/math/moab/pkg-plist
+++ b/math/moab/pkg-plist
@@ -13,8 +13,6 @@ bin/mbsurfplot
bin/mbtagprop
bin/mbumr
bin/spheredecomp
-%%MPI%%include/Coupler.hpp
-%%MPI%%include/ElemUtil.hpp
include/MBCN.h
include/MBCN_protos.h
include/MBEntityType.h
@@ -30,6 +28,8 @@ include/iMesh.h
include/iMesh_extensions.h
include/iMesh_f.h
include/iMesh_protos.h
+%%MPI%%include/mbcoupler/Coupler.hpp
+%%MPI%%include/mbcoupler/ElemUtil.hpp
include/moab/AdaptiveKDTree.hpp
include/moab/BSPTree.hpp
include/moab/BSPTreePoly.hpp
@@ -80,6 +80,7 @@ include/moab/NestedRefine.hpp
include/moab/NestedRefineTemplates.hpp
include/moab/OrientedBox.hpp
include/moab/OrientedBoxTreeTool.hpp
+%%MPI%%include/moab/ParCommGraph.hpp
%%MPI%%include/moab/ParallelComm.hpp
%%MPI%%include/moab/ParallelData.hpp
%%MPI%%include/moab/ParallelMergeMesh.hpp