aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-31 16:32:25 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-31 16:40:13 +0000
commit4996408feee5d569b8bbbba2b6d289e9057ef1c5 (patch)
tree04fe7b76b8f3fea562358868d69beed8a9405a59
parentdfc0cf9973c46dde9aa0b393c8b759f692bbc1ff (diff)
downloadports-4996408feee5d569b8bbbba2b6d289e9057ef1c5.tar.gz
ports-4996408feee5d569b8bbbba2b6d289e9057ef1c5.zip
security/py-oauthlib: Convert to USE_PYTHON=pytest
-rw-r--r--security/py-oauthlib/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/security/py-oauthlib/Makefile b/security/py-oauthlib/Makefile
index 519a510871f4..e132e3abf688 100644
--- a/security/py-oauthlib/Makefile
+++ b/security/py-oauthlib/Makefile
@@ -11,11 +11,10 @@ WWW= https://github.com/oauthlib/oauthlib
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.0:devel/py-pytest@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytest-cov>=2.6:devel/py-pytest-cov@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-cov>=2.6:devel/py-pytest-cov@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
@@ -27,10 +26,7 @@ SIGNEDTOKEN_DESC= Signed token support
RSA_USES= pycryptography:run
SIGNALS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blinker>=1.4.0:devel/py-blinker@${PY_FLAVOR}
-SIGNEDTOKEN_USES= pycryptography:run
SIGNEDTOKEN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyjwt>=2.0.0<3:www/py-pyjwt@${PY_FLAVOR}
-
-do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
+SIGNEDTOKEN_USES= pycryptography:run
.include <bsd.port.mk>