aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2012-07-26 02:41:58 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2012-07-26 02:41:58 +0000
commit49ac3accb4fc378c681317849f4ae94655a61423 (patch)
tree538c537fb78f65a4ac2f356f6d118555bbd126f2
parent9030102ea4136c0e1629200706a4573c45806a80 (diff)
downloadports-49ac3accb4fc378c681317849f4ae94655a61423.tar.gz
ports-49ac3accb4fc378c681317849f4ae94655a61423.zip
fixed mozc-el build fail
PR: 170131 Submitted by: Seiji Ariga <freebsd@khaotic.net>
Notes
Notes: svn path=/head/; revision=301538
-rw-r--r--japanese/mozc-el/Makefile2
-rw-r--r--japanese/mozc-server/Makefile18
2 files changed, 10 insertions, 10 deletions
diff --git a/japanese/mozc-el/Makefile b/japanese/mozc-el/Makefile
index d99257c4b0f9..215da94fab5f 100644
--- a/japanese/mozc-el/Makefile
+++ b/japanese/mozc-el/Makefile
@@ -11,7 +11,7 @@ COMMENT= Mozc for GNU Emacs
MASTERDIR= ${.CURDIR}/../../japanese/mozc-server
PKGMESSAGE= ${.CURDIR}/pkg-message
-BUILD_MOZC_LIST= mozc-el
+BUILD_MOZC_LIST= mozc_el
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 6894f2c961d6..290e85645298 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozc
PORTVERSION= 1.5.1090.102
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX?= ja-
@@ -37,7 +37,7 @@ USE_QT4+= gui dbus qmake_build moc_build uic_build rcc_build
USE_GNOME+= pygtk2
.elif ${BUILD_MOZC_LIST:Mfcitx_mozc} == "fcitx_mozc"
USE_GNOME+= glib20 gtk20
-.elif ${BUILD_MOZC_LIST:Mmozc-el} == "mozc-el"
+.elif ${BUILD_MOZC_LIST:Mmozc_el} == "mozc_el"
USE_EMACS= yes
.endif
@@ -73,9 +73,9 @@ SSL_REINPLACE_STR=
SSL_REINPLACE_STR+= -e "s,%%${V}%%,${${V}},"
.endfor
-.if ${BUILD_MOZC_LIST:Mmozc_server} == "mozc_server"
-GYP_DEFINES="use_libprotobuf=1 enable_gtk_renderer=0"
-.elif ${BUILD_MOZC_LIST:Mmozc_tool} == "mozc_tool"
+.if ${BUILD_MOZC_LIST:Mmozc_server} == "mozc_server" || \
+ ${BUILD_MOZC_LIST:Mmozc_tool} == "mozc_tool" || \
+ ${BUILD_MOZC_LIST:Mmozc_el} == "mozc_el"
GYP_DEFINES="use_libprotobuf=1 enable_gtk_renderer=0"
.else
GYP_DEFINES="use_libprotobuf=1"
@@ -306,8 +306,8 @@ do-install-fcitx_mozc:
.endfor
.endif
-# mozc-el
-.if ${BUILD_MOZC_LIST:Mmozc-el} == "mozc-el"
+# mozc_el
+.if ${BUILD_MOZC_LIST:Mmozc_el} == "mozc_el"
CATEGORIES+= editors elisp
RUN_DEPENDS+= mozc_server:${PORTSDIR}/japanese/mozc-server \
mozc_server_start:${PORTSDIR}/japanese/mozc-additions
@@ -316,14 +316,14 @@ PLIST_FILES+= bin/mozc_emacs_helper \
${EMACS_VERSION_SITE_LISPDIR}/mozc.el \
${EMACS_VERSION_SITE_LISPDIR}/mozc.elc
-do-build-mozc-el:
+do-build-mozc_el:
${BUILD_MOZC_CMD} build -c ${BUILD_MODE} \
unix/emacs/emacs.gyp:mozc_emacs_helper
@cd ${WRKSRC}/unix/emacs && \
${EMACS_CMD} -batch -q -no-site-file -no-init-file \
-f batch-byte-compile mozc.el
-do-install-mozc-el:
+do-install-mozc_el:
@${INSTALL_PROGRAM} \
${WRKSRC}/out_linux/${BUILD_MODE}/mozc_emacs_helper \
${PREFIX}/bin/