aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-16 06:48:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-16 06:48:02 +0000
commit4a225cc8bd291d2bcb11c9b6b842e2d8d4117ddc (patch)
tree66a444215f601490418cd9773dc9d2a55d56c64d
parent97376e06fcb88368cdc3ea2b7cb6738219a9508e (diff)
downloadports-4a225cc8bd291d2bcb11c9b6b842e2d8d4117ddc.tar.gz
ports-4a225cc8bd291d2bcb11c9b6b842e2d8d4117ddc.zip
Stagify.
Notes
Notes: svn path=/head/; revision=357948
-rw-r--r--graphics/cuttlefish/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/cuttlefish/Makefile b/graphics/cuttlefish/Makefile
index 5048f73f97dc..21c3a5956de2 100644
--- a/graphics/cuttlefish/Makefile
+++ b/graphics/cuttlefish/Makefile
@@ -14,9 +14,10 @@ RUN_DEPENDS+= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
convert:${PORTSDIR}/graphics/ImageMagick \
gifsicle:${PORTSDIR}/graphics/gifsicle
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
NO_BUILD= yes
+SHEBANG_FILES= bin/cuttlefish.pl
IMAGES= caida_logo.gif caida_logo_gray.gif \
japan-water-okinawa.jpg japan-water.jpg \
@@ -26,7 +27,6 @@ EXAMPLES= japan-traces-small.config japan-traces.config \
nyxem-hosts-both.config \
witty-combined-small.config witty-combined.config
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|../lib|../lib/cuttlefish|" \
${WRKSRC}/bin/cuttlefish.pl
@@ -36,18 +36,18 @@ post-patch:
.endfor
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/bin/cuttlefish.pl ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/lib/cuttlefish
- @${MKDIR} ${DATADIR}
- @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/cuttlefish.pl ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/cuttlefish
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in Canvas.pm Control.pm Histogram.pm Image.pm Legend.pm Map.pm Util.pm
- @${INSTALL_DATA} ${WRKSRC}/lib/${f} ${PREFIX}/lib/cuttlefish/${f}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${f} ${STAGEDIR}${PREFIX}/lib/cuttlefish/${f}
.endfor
.for f in ${EXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/configs/${f} ${EXAMPLESDIR}/${f}
+ @${INSTALL_DATA} ${WRKSRC}/configs/${f} ${STAGEDIR}${EXAMPLESDIR}/${f}
.endfor
.for f in ${IMAGES}
- @${INSTALL_DATA} ${WRKSRC}/images/${f} ${DATADIR}/${f}
+ @${INSTALL_DATA} ${WRKSRC}/images/${f} ${STAGEDIR}${DATADIR}/${f}
.endfor
.include <bsd.port.mk>