aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2022-05-14 19:42:58 +0000
committerBernard Spil <brnrd@FreeBSD.org>2022-05-14 19:42:58 +0000
commit4a2a9ddf364f06274f8c82e86a0ad3611c8c53a5 (patch)
treebdbdd7a9d26b866391753f297ce4154094024b3a
parent21b89b758b1c5c57b4ccbb02301da48ba5099753 (diff)
downloadports-4a2a9ddf364f06274f8c82e86a0ad3611c8c53a5.tar.gz
ports-4a2a9ddf364f06274f8c82e86a0ad3611c8c53a5.zip
databases/mariadb106-server: Fix build with LibreSSL 3.5
* Improve poudriere build reliability
-rw-r--r--databases/mariadb106-server/Makefile2
-rw-r--r--databases/mariadb106-server/files/patch-include_ssl__compat.h22
2 files changed, 23 insertions, 1 deletions
diff --git a/databases/mariadb106-server/Makefile b/databases/mariadb106-server/Makefile
index 47c837f25630..540d6cbadf0d 100644
--- a/databases/mariadb106-server/Makefile
+++ b/databases/mariadb106-server/Makefile
@@ -273,7 +273,7 @@ post-install:
${STAGEDIR}${ETCDIR}/logrotate.d \
${STAGEDIR}${DOCSDIR}/COPYING
${MKDIR} ${STAGEDIR}${MARIADB_LOGDIR}
- ${SED} '/%%/d;/^@comment /d;s/^/@comment /' ../${PORTNAME}${PKGNAMESUFFIX:S/-server/-client/}/pkg-plist \
+ ${SED} '/%%/d;/^@comment /d;s/^/@comment /' ${PORTSDIR}/${CATEGORIES:[1]}/${PORTNAME}${PKGNAMESUFFIX:S/-server/-client/}/pkg-plist \
>> ${TMPPLIST}
post-install-MROONGA-on:
diff --git a/databases/mariadb106-server/files/patch-include_ssl__compat.h b/databases/mariadb106-server/files/patch-include_ssl__compat.h
new file mode 100644
index 000000000000..132f629cf2eb
--- /dev/null
+++ b/databases/mariadb106-server/files/patch-include_ssl__compat.h
@@ -0,0 +1,22 @@
+--- include/ssl_compat.h.orig 2022-02-10 20:17:08 UTC
++++ include/ssl_compat.h
+@@ -19,7 +19,8 @@
+ /* OpenSSL version specific definitions */
+ #if defined(OPENSSL_VERSION_NUMBER)
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
++#if OPENSSL_VERSION_NUMBER >= 0x10100000L && \
++ !(defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x30500000)
+ #define HAVE_OPENSSL11 1
+ #define SSL_LIBRARY OpenSSL_version(OPENSSL_VERSION)
+ #define ERR_remove_state(X) ERR_clear_error()
+@@ -73,7 +74,8 @@
+ #define EVP_MD_CTX_SIZE sizeof(EVP_MD_CTX)
+ #endif
+
+-#ifndef DH_set0_pqg
++#if !defined(DH_set0_pqg) && \
++ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x30500000)
+ #define DH_set0_pqg(D,P,Q,G) ((D)->p= (P), (D)->g= (G))
+ #endif
+