aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-21 21:39:43 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-22 14:45:02 +0000
commit4a41cd7501fccf18ca3028221307b9f75c8d5328 (patch)
tree1c1c742444bcfcafa5f379149bec69de648d9d11
parent946eeef0411c1b01e998eaafba0017619595edd3 (diff)
downloadports-4a41cd7501fccf18ca3028221307b9f75c8d5328.tar.gz
ports-4a41cd7501fccf18ca3028221307b9f75c8d5328.zip
graphics/gauche-gl: Optionize INFO
- Pet portclippy
-rw-r--r--graphics/gauche-gl/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/graphics/gauche-gl/Makefile b/graphics/gauche-gl/Makefile
index 393cf608100d..fd1c68450cda 100644
--- a/graphics/gauche-gl/Makefile
+++ b/graphics/gauche-gl/Makefile
@@ -16,25 +16,30 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gosh:lang/gauche
RUN_DEPENDS= gosh:lang/gauche
-USES= gl localbase makeinfo tar:tgz xorg
+USES= gl localbase tar:tgz xorg
USE_CSTD= gnu99
-USE_XORG= ice sm x11 xext xmu xi
USE_GL= gl glu glut
+USE_XORG= ice sm x11 xext xmu xi
+
GNU_CONFIGURE= yes
+
MAKE_JOBS_UNSAFE= yes
-GAUCHE_ABI= 0.98
DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/gauche/${PORTNAME}
PLIST_SUB= TARGET="${CONFIGURE_TARGET}" ABI_VER=${GAUCHE_ABI}
-INFO= gauche-gl-refe gauche-gl-refj
+OPTIONS_DEFINE= DOCS EXAMPLES INFO
+OPTIONS_DEFAULT= INFO
+
+INFO_USES= makeinfo
+INFO_INFO= gauche-gl-refe gauche-gl-refj
-OPTIONS_DEFINE= DOCS EXAMPLES
+GAUCHE_ABI= 0.98
post-patch:
-.for i in configure src/gauche-gl.c src/gauche-gl.h src/glut-lib.stub
+.for i in configure src/gauche-gl.h src/glut-lib.stub
@${REINPLACE_CMD} -e '/glut.h/s|GLUT|GL|' ${WRKSRC}/${i}
.endfor
@@ -43,10 +48,6 @@ do-install:
@(cd ${WRKSRC}/${i} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
.endfor
-.for i in ${INFO}
- ${GZCAT} ${WRKSRC}/doc/${i}.info.gz \
- > ${STAGEDIR}${PREFIX}/${INFO_PATH}/${i}.info
-.endfor
@(cd ${STAGEDIR}${PREFIX}/lib/gauche-${GAUCHE_ABI}/site/${CONFIGURE_TARGET} && \
${CHMOD} u+w libgauche-*.so && ${STRIP_CMD} libgauche-*.so && \
${CHMOD} u-w libgauche-*.so)