aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-13 12:33:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-13 12:33:03 +0000
commit4ae0fc34d1d952124f6a5c8d5caa116d375ce396 (patch)
tree8e803133bdaf13639d37952b87f942c53ab47986
parent998d75e98efc87fa5fa00c919ad64b4d667c7270 (diff)
downloadports-4ae0fc34d1d952124f6a5c8d5caa116d375ce396.tar.gz
ports-4ae0fc34d1d952124f6a5c8d5caa116d375ce396.zip
- Fix permissions/ownership
PR: ports/105144 Submitted by: Ulrich Spoerlein <uspoerlein@gmail.com> Approved by: maintainer
Notes
Notes: svn path=/head/; revision=177173
-rw-r--r--sysutils/heartbeat/Makefile5
-rw-r--r--sysutils/heartbeat/files/patch-ldirectord-init.d-ldirectord11
-rw-r--r--sysutils/heartbeat/files/pkg-install.in10
-rw-r--r--sysutils/heartbeat2/Makefile5
-rw-r--r--sysutils/heartbeat2/files/patch-ldirectord-init.d-ldirectord11
-rw-r--r--sysutils/heartbeat2/files/pkg-install.in10
6 files changed, 46 insertions, 6 deletions
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index be93b8c7c087..f8628fcc7bdb 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= heartbeat
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://linux-ha.org/download/
@@ -72,8 +73,8 @@ BATCH=no
post-deinstall:
@BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} DEINSTALL
-post-install:
- @BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+pre-install:
+ @BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
# some subdirs treat man as documentation, therefor we have to install
# those man pages manually if NOPORTDOCS is defined
diff --git a/sysutils/heartbeat/files/patch-ldirectord-init.d-ldirectord b/sysutils/heartbeat/files/patch-ldirectord-init.d-ldirectord
new file mode 100644
index 000000000000..fa699c652b52
--- /dev/null
+++ b/sysutils/heartbeat/files/patch-ldirectord-init.d-ldirectord
@@ -0,0 +1,11 @@
+--- ldirectord/init.d/ldirectord.orig
++++ ldirectord/init.d/ldirectord
+@@ -22,7 +22,7 @@
+ then
+ . /etc/rc.d/init.d/functions
+ else
+- function action {
++ action() {
+ echo -n "$1... "
+ shift
+ $@
diff --git a/sysutils/heartbeat/files/pkg-install.in b/sysutils/heartbeat/files/pkg-install.in
index add49ae3f155..a125513bfc8e 100644
--- a/sysutils/heartbeat/files/pkg-install.in
+++ b/sysutils/heartbeat/files/pkg-install.in
@@ -85,7 +85,7 @@ delete_account() {
case $2 in
-POST-INSTALL)
+PRE-INSTALL)
echo ""
user=hacluster
group=haclient
@@ -96,6 +96,14 @@ POST-INSTALL)
echo "Adding empty dirs and pid file."
test -d /var/lib/heartbeat/ckpt || \
install -d -m 755 /var/lib/heartbeat/ckpt
+ test -d /var/lib/heartbeat/ccm || \
+ install -d -m 750 -o ${user} -g ${group} /var/lib/heartbeat/ccm
+ test -d /var/lib/heartbeat/cores/root || \
+ install -d -m 700 /var/lib/heartbeat/cores/root
+ test -d /var/lib/heartbeat/cores/nobody || \
+ install -d -m 700 -o nobody /var/lib/heartbeat/cores/nobody
+ test -d /var/lib/heartbeat/cores/hacluster || \
+ install -d -m 700 -o ${user} /var/lib/heartbeat/cores/hacluster
test -d /var/lock/subsys || \
install -d -m 755 /var/lock/subsys
test -f /var/run/heartbeat.pid || \
diff --git a/sysutils/heartbeat2/Makefile b/sysutils/heartbeat2/Makefile
index be93b8c7c087..f8628fcc7bdb 100644
--- a/sysutils/heartbeat2/Makefile
+++ b/sysutils/heartbeat2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= heartbeat
PORTVERSION= 1.2.5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://linux-ha.org/download/
@@ -72,8 +73,8 @@ BATCH=no
post-deinstall:
@BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} DEINSTALL
-post-install:
- @BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+pre-install:
+ @BATCH=${BATCH} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
# some subdirs treat man as documentation, therefor we have to install
# those man pages manually if NOPORTDOCS is defined
diff --git a/sysutils/heartbeat2/files/patch-ldirectord-init.d-ldirectord b/sysutils/heartbeat2/files/patch-ldirectord-init.d-ldirectord
new file mode 100644
index 000000000000..fa699c652b52
--- /dev/null
+++ b/sysutils/heartbeat2/files/patch-ldirectord-init.d-ldirectord
@@ -0,0 +1,11 @@
+--- ldirectord/init.d/ldirectord.orig
++++ ldirectord/init.d/ldirectord
+@@ -22,7 +22,7 @@
+ then
+ . /etc/rc.d/init.d/functions
+ else
+- function action {
++ action() {
+ echo -n "$1... "
+ shift
+ $@
diff --git a/sysutils/heartbeat2/files/pkg-install.in b/sysutils/heartbeat2/files/pkg-install.in
index add49ae3f155..a125513bfc8e 100644
--- a/sysutils/heartbeat2/files/pkg-install.in
+++ b/sysutils/heartbeat2/files/pkg-install.in
@@ -85,7 +85,7 @@ delete_account() {
case $2 in
-POST-INSTALL)
+PRE-INSTALL)
echo ""
user=hacluster
group=haclient
@@ -96,6 +96,14 @@ POST-INSTALL)
echo "Adding empty dirs and pid file."
test -d /var/lib/heartbeat/ckpt || \
install -d -m 755 /var/lib/heartbeat/ckpt
+ test -d /var/lib/heartbeat/ccm || \
+ install -d -m 750 -o ${user} -g ${group} /var/lib/heartbeat/ccm
+ test -d /var/lib/heartbeat/cores/root || \
+ install -d -m 700 /var/lib/heartbeat/cores/root
+ test -d /var/lib/heartbeat/cores/nobody || \
+ install -d -m 700 -o nobody /var/lib/heartbeat/cores/nobody
+ test -d /var/lib/heartbeat/cores/hacluster || \
+ install -d -m 700 -o ${user} /var/lib/heartbeat/cores/hacluster
test -d /var/lock/subsys || \
install -d -m 755 /var/lock/subsys
test -f /var/run/heartbeat.pid || \