aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 23:40:26 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 23:52:29 +0000
commit4b1a54d7fd812bca88580618d4694288631ecf85 (patch)
treea1a969c85042ca805c47522e557921faff46d30c
parent8967ed2438a73449c1688c27f177f17b1776460f (diff)
downloadports-4b1a54d7fd812bca88580618d4694288631ecf85.tar.gz
ports-4b1a54d7fd812bca88580618d4694288631ecf85.zip
www/rubygem-passenger: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
-rw-r--r--www/rubygem-passenger/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/rubygem-passenger/Makefile b/www/rubygem-passenger/Makefile
index dbe1273fd9f0..e60bd3ae64e0 100644
--- a/www/rubygem-passenger/Makefile
+++ b/www/rubygem-passenger/Makefile
@@ -11,6 +11,9 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= rake:devel/rubygem-rake
+LIB_DEPENDS+= libuv.so:devel/libuv \
+ libcurl.so:ftp/curl \
+ libapr-1.so:devel/apr1
CPE_VENDOR= phusion
CPE_PRODUCT= passenger
@@ -35,12 +38,9 @@ USES+= apache
RAKE_BIN= ${LOCALBASE}/bin/rake
USES+= compiler:c++11-lang cpe gem libtool python:env shebangfix ssl
+USE_CXXSTD= c++14
SHEBANG_FILES= src/cxx_supportlib/vendor-copy/libuv/gyp_uv.py
-LIB_DEPENDS+= libuv.so:devel/libuv \
- libcurl.so:ftp/curl \
- libapr-1.so:devel/apr1
-
BUILD_DEPENDS+= rubygem-rack>=0:www/rubygem-rack
RUN_DEPENDS:= ${BUILD_DEPENDS} \
rubygem-etc>=0:devel/rubygem-etc
@@ -77,11 +77,11 @@ pre-patch-DEBUG-off:
post-build:
.if ${FLAVOR} == apache
- (CC=${CC} CXX=${CXX} ${WRKSRC}/bin/passenger-install-apache2-module --auto)
+ (CC=${CC} CXX=${CXX} EXTRA_CXXFLAGS="${CXXFLAGS}" ${WRKSRC}/bin/passenger-install-apache2-module --auto)
.endif
.if ${FLAVOR} == nginx
- (cd ${WRKSRC} && CC=${CC} CXX=${CXX} ${RAKE_BIN} nginx)
+ (cd ${WRKSRC} && CC=${CC} CXX=${CXX} EXTRA_CXXFLAGS="${CXXFLAGS}" ${RAKE_BIN} nginx)
.endif
${FIND} ${WRKSRC} -name '*.o' -o -name '*.bak' -o -name '*.orig' | ${XARGS} ${RM}