aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2023-04-20 09:44:49 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2023-04-20 10:00:28 +0000
commit4baf754027807e1ad7966055d40a4c4eb75a5717 (patch)
tree06f4d0dbf7bf1e48a91e7c9afdb5a1061f44a590
parentf80db8d420bfda00166ab82cd1405f0a13ed06fb (diff)
downloadports-4baf754027807e1ad7966055d40a4c4eb75a5717.tar.gz
ports-4baf754027807e1ad7966055d40a4c4eb75a5717.zip
net-p2p/amule: Adopt/Fix segmentation fault
- Add -DCRYPTOPP_DISABLE_ASM to CXXFLAGS on i386 and amd64, as cryptopp-8.7.0 build with this option by default on i386 and amd64. (5a19c08: security/cryptopp: Update to 8.7.0) While I'm here: - Makefile cleanup: license file, formatting and remove conflicts install on expired net-p2p/amule-devel port. PR: 266866 Reported by: Francesco <francesco@magno.cc> MFH: 2023Q2
-rw-r--r--net-p2p/amule/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index c9f2896e8e56..2689353f4092 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -1,16 +1,16 @@
PORTNAME= amule
PORTVERSION= 2.3.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-p2p
MASTER_SITES= SF/${PORTNAME}/aMule/${PORTVERSION}
DISTNAME= aMule-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= eduardo@FreeBSD.org
COMMENT= All-platform eMule p2p client
WWW= https://www.amule.org/
LICENSE= GPLv2+
-LICENSE_FILE_GPLv2+ = ${WRKSRC}/docs/COPYING
+LICENSE_FILE= ${WRKSRC}/docs/COPYING
LIB_DEPENDS= libcryptopp.so:security/cryptopp
@@ -29,10 +29,9 @@ LDFLAGS+= -lpthread
SHEBANG_FILES= src/utils/scripts/*.pl src/utils/xas/*.pl src/libs/ec/*.pl
-CONFLICTS_INSTALL= amule-devel
-
OPTIONS_DEFINE= ALC ALCC AMULECMD AMULEDAEMON AMULEGUI BOOST CAS DEBUG \
- DOCS ED2K FILEVIEW MMAP MONOLITHIC NLS UPNP WEBSERVER WXCAS XAS
+ DOCS ED2K FILEVIEW MMAP MONOLITHIC NLS UPNP WEBSERVER \
+ WXCAS XAS
ALC_DESC= Compile aMule Link Creator for GUI
ALCC_DESC= Compile aMule Link Creator for console
AMULECMD_DESC= Compile aMule command line client
@@ -45,9 +44,8 @@ MMAP_DESC= Use mapped memory
MONOLITHIC_DESC= Compile monolithic aMule
WXCAS_DESC= Compile aMule Statistics for GUI
XAS_DESC= Install XChat2 plugin
-OPTIONS_DEFAULT=ALC ALCC AMULECMD AMULEDAEMON AMULEGUI CAS ED2K \
- FILEVIEW MONOLITHIC WEBSERVER WXCAS XAS
-
+OPTIONS_DEFAULT= ALC ALCC AMULECMD AMULEDAEMON AMULEGUI CAS ED2K \
+ FILEVIEW MONOLITHIC WEBSERVER WXCAS XAS
OPTIONS_SUB= yes
DEBUG_CONFIGURE_OFF= --disable-debug
@@ -96,6 +94,12 @@ XAS_USE= PERL5+=run
.include <bsd.port.options.mk>
+# Fix segmentation fault, PR 266866
+# see also 5a19c08: security/cryptopp: Update to 8.7.0
+.if ${ARCH} == i386 || ${ARCH} == amd64
+CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM
+.endif
+
.if ${PORT_OPTIONS:MAMULEGUI} || ${PORT_OPTIONS:MMONOLITHIC}
PLIST_SUB+= AMULESKIN=""
.else