aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2017-08-15 20:42:40 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2017-08-15 20:42:40 +0000
commit4bc25af896739800bbf95b78d4315948778306da (patch)
treef5b993b56d5b75cebf7dee3c902fab787fc61893
parent833c001e9a9c2e219de6627744c1be310c4dd8d4 (diff)
downloadports-4bc25af896739800bbf95b78d4315948778306da.tar.gz
ports-4bc25af896739800bbf95b78d4315948778306da.zip
- Fix finding of mariadb headers [1]
- Fix build with custom mysql library PR: 221533 [1] Submitted by: vvd at unislabs.com [1]
Notes
Notes: svn path=/head/; revision=448008
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src-lookups-mysql.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index d9e6f0c7611e..c936a627234f 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -325,7 +325,7 @@ SEDLIST+= -e 's,XX_LMDB_LIBS_XX,${LMDB_LIBS:S/,/\\,/g},' \
-e 's,XX_LMDB_INCLUDES_XX,${LMDB_INCLUDES:S/,/\\,/g},'
.if ${PORT_OPTIONS:MMYSQL}
-SEDLIST+= -e 's,XX_MYSQL_LIBS_XX,-L${LOCALBASE:S/,/\\,/g}/lib/mysql -lmysqlclient,' \
+SEDLIST+= -e 's,XX_MYSQL_LIBS_XX,-L${LOCALBASE:S/,/\\,/g}/lib/mysql -l${_MYSQL_SHLIB:S/lib//},' \
-e 's,XX_MYSQL_INCLUDE_XX,-I${LOCALBASE:S/,/\\,/g}/include/mysql,' \
-e 's,^\# (LOOKUP_MYSQL=),\1,'
.else
diff --git a/mail/exim/files/patch-src-lookups-mysql.c b/mail/exim/files/patch-src-lookups-mysql.c
new file mode 100644
index 000000000000..db54d3526883
--- /dev/null
+++ b/mail/exim/files/patch-src-lookups-mysql.c
@@ -0,0 +1,10 @@
+--- src/lookups/mysql.c.orig 2017-03-05 00:21:35.000000000 +0300
++++ src/lookups/mysql.c 2017-08-15 01:12:26.508519000 +0300
+@@ -13,6 +13,7 @@
+ #include "lf_functions.h"
+
+ #include <mysql.h> /* The system header */
++#include <mysql_version.h>
+
+
+ /* Structure and anchor for caching connections. */