aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 14:50:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-03 15:38:52 +0000
commit4c2bb9fcd1b6d276d8fde1d27114290befe03dea (patch)
treed50aa592b8a750b34f75cdbc03011c41baf5e087
parentdb015e589372a8eb0c360cc207f95587948a0273 (diff)
downloadports-4c2bb9fcd1b6d276d8fde1d27114290befe03dea.tar.gz
ports-4c2bb9fcd1b6d276d8fde1d27114290befe03dea.zip
x11/xskyroot: Fix build with llvm15
- Pet portclippy - Reresh pathces - Use DISTNAME and EXTRACT_SUFX instead of DISTFILES
-rw-r--r--x11/xskyroot/Makefile21
-rw-r--r--x11/xskyroot/distinfo1
-rw-r--r--x11/xskyroot/files/patch-Imakefile6
-rw-r--r--x11/xskyroot/files/patch-astro.c4
-rw-r--r--x11/xskyroot/files/patch-xskyroot.c (renamed from x11/xskyroot/files/patch-xsyroot.c)4
5 files changed, 24 insertions, 12 deletions
diff --git a/x11/xskyroot/Makefile b/x11/xskyroot/Makefile
index 34666a758170..1fa6cbbf1b78 100644
--- a/x11/xskyroot/Makefile
+++ b/x11/xskyroot/Makefile
@@ -3,19 +3,30 @@ PORTVERSION= 920428
PORTREVISION= 2
CATEGORIES= x11
MASTER_SITES= ftp://ftp.sra.co.jp/pub/news/fj.sources/V10/
-DISTFILES= 1079.gz
+DISTNAME= 1079
+EXTRACT_SUFX= .gz
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Realtime sky drawer for X root window
+LICENSE= NONE
+
+USES= imake xorg
+USE_XORG= x11
+
EXTRACT_CMD= ${GZIP_CMD}
EXTRACT_BEFORE_ARGS= -dc
EXTRACT_AFTER_ARGS= | ${SED} -e "/^...bin.sh/,/exit 0/!d" | ${SH}
-DIST_SUBDIR= ${PORTNAME}
NO_WRKSUBDIR= yes
-USES= imake xorg
-USE_XORG= x11
+
PLIST_FILES= bin/xskyroot
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/xskyroot/distinfo b/x11/xskyroot/distinfo
index fa4c4cbea002..ae09a9ce27c1 100644
--- a/x11/xskyroot/distinfo
+++ b/x11/xskyroot/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1685803531
SHA256 (xskyroot/1079.gz) = 66e78ccd9c787ec9d21661be715702ae4a6d34e12b3c529dfca17ac382ffec92
SIZE (xskyroot/1079.gz) = 10285
diff --git a/x11/xskyroot/files/patch-Imakefile b/x11/xskyroot/files/patch-Imakefile
index 571af377cb00..3a02ed146aed 100644
--- a/x11/xskyroot/files/patch-Imakefile
+++ b/x11/xskyroot/files/patch-Imakefile
@@ -1,6 +1,6 @@
---- Imakefile.orig Sat Oct 14 07:16:08 2000
-+++ Imakefile Sat Oct 14 07:16:45 2000
-@@ -4,4 +4,4 @@
+--- Imakefile.orig 2023-06-03 14:41:54 UTC
++++ Imakefile
+@@ -4,4 +4,4 @@ SYS_LIBRARIES = -lX11 -lm
SRCS = xskyroot.c draw.c colorname.c astro.c
OBJS = xskyroot.o draw.o colorname.o astro.o
diff --git a/x11/xskyroot/files/patch-astro.c b/x11/xskyroot/files/patch-astro.c
index 16c3108c3ace..f154bccb87e8 100644
--- a/x11/xskyroot/files/patch-astro.c
+++ b/x11/xskyroot/files/patch-astro.c
@@ -1,5 +1,5 @@
---- astro.c.orig Mon May 31 09:06:03 1999
-+++ astro.c Mon May 31 09:06:18 1999
+--- astro.c.orig 2023-06-03 14:41:54 UTC
++++ astro.c
@@ -7,7 +7,7 @@
#include <math.h>
#include "mathlocal.h"
diff --git a/x11/xskyroot/files/patch-xsyroot.c b/x11/xskyroot/files/patch-xskyroot.c
index c2152bca70f1..479ad5455b9a 100644
--- a/x11/xskyroot/files/patch-xsyroot.c
+++ b/x11/xskyroot/files/patch-xskyroot.c
@@ -1,5 +1,5 @@
---- xskyroot.c- Thu May 29 08:56:15 1997
-+++ xskyroot.c Thu May 29 08:52:51 1997
+--- xskyroot.c.orig 2023-06-03 14:41:54 UTC
++++ xskyroot.c
@@ -1,4 +1,4 @@
-
+#include <stdlib.h>