aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2021-10-30 12:54:07 +0000
committerJuraj Lutter <otis@FreeBSD.org>2021-10-30 12:54:07 +0000
commit4c9b48d1b6bb64ee6b27e0ed5a98358266ce74da (patch)
treefa01772b827b5190ecc9caaa062ad57e42d7dd5d
parentad1215ab862fc649c4db8ec6225a943ac0960630 (diff)
downloadports-4c9b48d1b6bb64ee6b27e0ed5a98358266ce74da.tar.gz
ports-4c9b48d1b6bb64ee6b27e0ed5a98358266ce74da.zip
mail/postfix: Fix multiple build issues
- Add ssl to USES - Fix plist issues - Install sample files properly PR: 259530
-rw-r--r--mail/postfix/Makefile9
-rw-r--r--mail/postfix/pkg-plist8
2 files changed, 14 insertions, 3 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 90528b943dff..e05582fe6959 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -2,7 +2,7 @@
PORTNAME= postfix
DISTVERSION= 3.6.2
-PORTREVISION?= 2
+PORTREVISION?= 3
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://ftp.porcupine.org/mirrors/postfix-release/ \
@@ -36,7 +36,7 @@ sasl_CONFLICTS_INSTALL= postfix-[0-9]* postfix-base-[0-9]* \
COMMENT_ldap= (with OpenLDAP and Cyrus SASL support)
COMMENT_sasl= (with Cyrus SASL support)
-USES= cpe shebangfix
+USES= cpe shebangfix ssl
USE_RC_SUBR= postfix
USE_SUBMAKE= yes
@@ -290,7 +290,7 @@ REINPLACE= s!^PATH=.*!PATH=/bin:/sbin:/usr/bin:/usr/sbin:${PREFIX}/bin:${PREFIX}
)/etc/postfix!\1$$config_directory!g; \
s!/etc/postfix!${ETCDIR}!g; s!^(sample_directory =)!\1 \
${ETCDIR}!g; \
- s!($config_directory/(access|aliases|canonical|generic|header_checks|relocated|transport|virtual):f:root:-:644:)p1!\1o!;
+ s!($$config_directory/(access|aliases|canonical|generic|header_checks|relocated|transport|virtual):f:root:-:644:)p1!\1o!;
pre-patch:
.if ${PORT_OPTIONS:MSASL} && ! ${PORT_OPTIONS:MMYSQL} && exists(${LOCALBASE}/lib/libsasl2.a)
@@ -359,6 +359,9 @@ do-install:
${MV} ${STAGEDIR}${ETCDIR}/master.cf ${STAGEDIR}${ETCDIR}/master.cf.sample
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKDIR}/mailer.conf.postfix ${STAGEDIR}${DATADIR}
+.for SAMPLEFILE in access aliases canonical generic header_checks relocated transport virtual
+ ${MV} ${STAGEDIR}${ETCDIR}/${SAMPLEFILE} ${STAGEDIR}${ETCDIR}/${SAMPLEFILE}.sample
+.endfor
# == chop dynamicmaps.cf entries into dedicated .cf files
# for future sub-packages support
diff --git a/mail/postfix/pkg-plist b/mail/postfix/pkg-plist
index 09e304898f33..a3cc7b594290 100644
--- a/mail/postfix/pkg-plist
+++ b/mail/postfix/pkg-plist
@@ -12,6 +12,14 @@ bin/rmail
%%PFETC%%/main.cf.default
@sample %%PFETC%%/main.cf.sample
@sample %%PFETC%%/master.cf.sample
+@sample %%PFETC%%/access.sample
+@sample %%PFETC%%/aliases.sample
+@sample %%PFETC%%/canonical.sample
+@sample %%PFETC%%/generic.sample
+@sample %%PFETC%%/header_checks.sample
+@sample %%PFETC%%/relocated.sample
+@sample %%PFETC%%/transport.sample
+@sample %%PFETC%%/virtual.sample
lib/postfix/libpostfix-dns.so
lib/postfix/libpostfix-global.so
lib/postfix/libpostfix-master.so