aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2022-09-29 22:48:41 +0000
committerBrooks Davis <brooks@FreeBSD.org>2022-09-29 22:48:41 +0000
commit4ca5c8c042c7e7123b63e31936d5f1edc5d42969 (patch)
treec315f1030a8ebdff36d72182571ad9f842c68c13
parentbf050595e31dcb6c8cb7292ac5ad875b5839cc02 (diff)
downloadports-4ca5c8c042c7e7123b63e31936d5f1edc5d42969.tar.gz
ports-4ca5c8c042c7e7123b63e31936d5f1edc5d42969.zip
devel/llvm-devel: rename ignorelist dir variable (NFC)
A few years ago sanitizer black lists were renamed to ignore lists. The directory variable's value didn't change at the time so I didn't think to update it. Do so now so it's less oddly named.
-rw-r--r--devel/llvm-devel/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/llvm-devel/Makefile b/devel/llvm-devel/Makefile
index 624c4fb862aa..a258d186172d 100644
--- a/devel/llvm-devel/Makefile
+++ b/devel/llvm-devel/Makefile
@@ -126,7 +126,7 @@ CLANG_USE= PERL5=run
COMPILER_RT_DESC= Sanitizer libraries
COMPILER_RT_IMPLIES= CLANG
COMPILER_RT_PLIST_FILES=${_COMPILER_RT_LIBS} \
- ${COMPILER_RT_IGNORELISTS:S|^|${_CRTBLDIR}/|}
+ ${COMPILER_RT_IGNORELISTS:S|^|${_CRTILDIR}/|}
DOCS_PORTDOCS= llvm
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx-markdown-tables>=0:textproc/py-sphinx-markdown-tables@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}recommonmark>=0.0.20180530:textproc/py-recommonmark@${PY_FLAVOR}
@@ -322,7 +322,7 @@ COMPILER_RT_ARCHS= riscv64
.endif
_CRTBASEDIR= ${LLVM_DIR}/lib/clang/${LLVM_RELEASE}
-_CRTBLDIR= ${_CRTBASEDIR}/share
+_CRTILDIR= ${_CRTBASEDIR}/share
_CRTLIBDIR= ${_CRTBASEDIR}/lib
.include "Makefile.RUNTIMES"