aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-30 15:58:01 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-30 15:58:23 +0000
commit4cc1e57a823282ddd0626798e7e469cfb71f1f75 (patch)
tree779d2bfb4166d94d806b2e07ad103c4e30d20647
parent62f24fe764f55e3373215accef433cabc197bba4 (diff)
downloadports-4cc1e57a823282ddd0626798e7e469cfb71f1f75.tar.gz
ports-4cc1e57a823282ddd0626798e7e469cfb71f1f75.zip
audio/libremidi: New port: Modern C++ MIDI real-time & file I/O library
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libremidi/Makefile25
-rw-r--r--audio/libremidi/distinfo3
-rw-r--r--audio/libremidi/pkg-descr6
-rw-r--r--audio/libremidi/pkg-plist27
5 files changed, 62 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 5643ffad7b95..3457fc84242c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -392,6 +392,7 @@
SUBDIR += libopenshot-audio
SUBDIR += libopenspc
SUBDIR += libopusenc
+ SUBDIR += libremidi
SUBDIR += libsamplerate
SUBDIR += libshairport
SUBDIR += libshout
diff --git a/audio/libremidi/Makefile b/audio/libremidi/Makefile
new file mode 100644
index 000000000000..f9228d9da044
--- /dev/null
+++ b/audio/libremidi/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= libremidi
+DISTVERSION= g20230630
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Modern C++ MIDI real-time & file I/O library
+WWW= https://github.com/jcelerier/libremidi
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.ModernMidi
+
+LIB_DEPENDS= libasound.so:audio/alsa-lib \
+ libjack.so:audio/jack
+
+USES= cmake:testing
+
+USE_GITHUB= yes
+GH_ACCOUNT= jcelerier
+GH_TAGNAME= c4833ef
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+# This library can also be used as a header-only library
+
+.include <bsd.port.mk>
diff --git a/audio/libremidi/distinfo b/audio/libremidi/distinfo
new file mode 100644
index 000000000000..b35cb8fb231c
--- /dev/null
+++ b/audio/libremidi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1688140390
+SHA256 (jcelerier-libremidi-g20230630-c4833ef_GH0.tar.gz) = 89bd791321087e61d1cc575a3b2d2f88731a0e9335f0c1d93eab6dd41a11e319
+SIZE (jcelerier-libremidi-g20230630-c4833ef_GH0.tar.gz) = 15467125
diff --git a/audio/libremidi/pkg-descr b/audio/libremidi/pkg-descr
new file mode 100644
index 000000000000..76d338736852
--- /dev/null
+++ b/audio/libremidi/pkg-descr
@@ -0,0 +1,6 @@
+libremidi is a cross-platform C++17 library for real-time and MIDI file
+input and output.
+
+This is a fork based on two libraries:
+* RtMidi
+* ModernMIDI
diff --git a/audio/libremidi/pkg-plist b/audio/libremidi/pkg-plist
new file mode 100644
index 000000000000..2bc071958ee4
--- /dev/null
+++ b/audio/libremidi/pkg-plist
@@ -0,0 +1,27 @@
+include/libremidi/api.hpp
+include/libremidi/config.hpp
+include/libremidi/detail/alsa.hpp
+include/libremidi/detail/coreaudio.hpp
+include/libremidi/detail/dummy.hpp
+include/libremidi/detail/emscripten.hpp
+include/libremidi/detail/emscripten_api.hpp
+include/libremidi/detail/jack.hpp
+include/libremidi/detail/midi_api.hpp
+include/libremidi/detail/midi_queue.hpp
+include/libremidi/detail/raw_alsa.hpp
+include/libremidi/detail/raw_alsa_helpers.hpp
+include/libremidi/detail/semaphore.hpp
+include/libremidi/detail/winmm.hpp
+include/libremidi/detail/winuwp.hpp
+include/libremidi/libremidi.cpp
+include/libremidi/libremidi.hpp
+include/libremidi/message.hpp
+include/libremidi/reader.cpp
+include/libremidi/reader.hpp
+include/libremidi/writer.cpp
+include/libremidi/writer.hpp
+lib/cmake/libremidi/libremidi-config-version.cmake
+lib/cmake/libremidi/libremidi-config.cmake
+lib/cmake/libremidi/libremidi-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/libremidi/libremidi-targets.cmake
+lib/liblibremidi.so