aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-05 20:41:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-09-05 20:46:34 +0000
commit4cdf64230e4b9f8361a8ecd47054f7e8c8a4ea2c (patch)
treee1153c0eca2b3bcf1fca15053331898ef9d92674
parentda4321e06c5aff93bccbafe3fe6a2f330bdf77e6 (diff)
science/py-qcelemental: Fix BUILD_DEPENDS
from pyproject.toml: [build-system] requires = ["poetry-core"] build-backend = "poetry.core.masonry.api" Approved by: portmgr (blanket) With hat: python Reference: https://github.com/MolSSI/QCElemental/blob/v0.26.0/pyproject.toml#L1-L3
-rw-r--r--science/py-qcelemental/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/science/py-qcelemental/Makefile b/science/py-qcelemental/Makefile
index 7406cd9cd4eb..d8c008c55cdc 100644
--- a/science/py-qcelemental/Makefile
+++ b/science/py-qcelemental/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/MolSSI/QCElemental
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry>0:devel/py-poetry@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=0:devel/py-poetry-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pint>=0.10.0:devel/py-pint@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic>=1.8.2:devel/py-pydantic@${PY_FLAVOR}