aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-11-04 08:45:33 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-11-04 08:46:04 +0000
commit4d132b6070d927f136e56927d7218fb9190efe2d (patch)
tree66495a28deb51e6ad77aa92e3e0b2304de3c48d5
parent67e298afe734314fabc549aec65fa557f52d7b7d (diff)
downloadports-4d132b6070d927f136e56927d7218fb9190efe2d.tar.gz
ports-4d132b6070d927f136e56927d7218fb9190efe2d.zip
dns/zdns: New port: Fast CLI DNS lookup tool
-rw-r--r--dns/Makefile1
-rw-r--r--dns/zdns/Makefile19
-rw-r--r--dns/zdns/distinfo5
-rw-r--r--dns/zdns/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 5caf3d7098de..bfbea8877384 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -239,6 +239,7 @@
SUBDIR += wrapsrv
SUBDIR += yadifa
SUBDIR += yandex-ddns
+ SUBDIR += zdns
SUBDIR += zkt
SUBDIR += zonenotify
diff --git a/dns/zdns/Makefile b/dns/zdns/Makefile
new file mode 100644
index 000000000000..d9fa6e68085c
--- /dev/null
+++ b/dns/zdns/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= zdns
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0
+CATEGORIES= dns
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Fast CLI DNS lookup tool
+WWW= https://github.com/zmap/zdns
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/zmap/zdns
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/dns/zdns/distinfo b/dns/zdns/distinfo
new file mode 100644
index 000000000000..eeeec0035922
--- /dev/null
+++ b/dns/zdns/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1699087114
+SHA256 (go/dns_zdns/zdns-v1.0.0/v1.0.0.mod) = 22fd94eb06abb7cd2592ac62d82bef179e2622ec1306a10ac7e6ee5ae118f0ec
+SIZE (go/dns_zdns/zdns-v1.0.0/v1.0.0.mod) = 1269
+SHA256 (go/dns_zdns/zdns-v1.0.0/v1.0.0.zip) = 1e841d7ffed452d15411f987721c94a5cf604c22f47e69941218d9f3bfd5945c
+SIZE (go/dns_zdns/zdns-v1.0.0/v1.0.0.zip) = 115777
diff --git a/dns/zdns/pkg-descr b/dns/zdns/pkg-descr
new file mode 100644
index 000000000000..af1f1a10a9a6
--- /dev/null
+++ b/dns/zdns/pkg-descr
@@ -0,0 +1,3 @@
+ZDNS is a command-line utility that provides high-speed DNS lookups.
+ZDNS is written in Go and contains its own recursive resolution code and
+a cache optimized for performing lookups of a diverse set of names.