aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2023-09-28 13:43:10 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2023-10-03 07:56:21 +0000
commit4d94db2cfb7de05761b2df16c1e619cd31cabd83 (patch)
tree126f4cb8232149fa0ade0fdfc58411f136df818b
parentf41c68eae612fcc3dbea7eac70eed1e34f64807f (diff)
net-mgmt/icingaweb2: fix problems running the application
Icingaweb failed with stack traces when being accessed due to missing php module dependencies: mime_content_type requires fileinfo. Cron\filter_var requires filter. Also, icingaweb fails at access, missing Locale class, if built without the NLS option. Remove the NLS options, since it seems broken. PR: 271662
-rw-r--r--net-mgmt/icingaweb2/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net-mgmt/icingaweb2/Makefile b/net-mgmt/icingaweb2/Makefile
index 6b44d47388c0..488145283738 100644
--- a/net-mgmt/icingaweb2/Makefile
+++ b/net-mgmt/icingaweb2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= icingaweb2
DISTVERSIONPREFIX= v
DISTVERSION= 2.11.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt www
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}
@@ -16,8 +16,8 @@ RUN_DEPENDS= icinga-php-library${PHP_PKGNAMESUFFIX}>=0.10.0:net-mgmt/icinga-php-
icinga-php-thirdparty${PHP_PKGNAMESUFFIX}>=0.11.0:net-mgmt/icinga-php-thirdparty@${PHP_FLAVOR} \
icingaweb2-module-incubator${PHP_PKGNAMESUFFIX}>=0.18.0:net-mgmt/icingaweb2-module-incubator@${PHP_FLAVOR}
-USES= php:build,web,flavors shebangfix
-USE_PHP= bcmath bitset ctype curl dom gd gettext iconv ldap \
+USES= php:build,web,flavors shebangfix gettext
+USE_PHP= bcmath bitset ctype curl dom fileinfo filter gd gettext iconv intl ldap \
mbstring mcrypt memcache memcached opcache pdo \
pdo_sqlite posix session simplexml soap sockets sqlite3 xml \
zlib
@@ -40,14 +40,12 @@ SUB_LIST= ETCDIR=${ETCDIR} \
PLIST_SUB= WWWGRP=${WWWGRP} \
WWWOWN=${WWWOWN}
-OPTIONS_DEFINE= EXAMPLES LDAP MYSQL NLS PDF PGSQL SQLITE
+OPTIONS_DEFINE= EXAMPLES LDAP MYSQL PDF PGSQL SQLITE
OPTIONS_DEFAULT= LDAP MYSQL PGSQL SQLITE
PDF_DESC= Export graphs as PDF
PDF_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/imagick.so:graphics/pecl-imagick@${PHP_FLAVOR}
-NLS_USES= gettext
-NLS_USE= PHP=intl
PGSQL_USE= PHP=pdo_pgsql,pgsql
MYSQL_USE= PHP=mysqli,pdo_mysql
SQLITE_USE= PHP=pdo_sqlite,sqlite3