aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2024-02-23 06:14:36 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2024-02-23 13:18:03 +0000
commit4db00f8bcb92624026ddb7fbbb37380b7412683e (patch)
tree661db74164a83af17e62f9e7e00a5a2f96eb5ccb
parent2bfafad11c42a8265f02fdfb809ea6618e79022c (diff)
downloadports-4db00f8bcb92624026ddb7fbbb37380b7412683e.tar.gz
ports-4db00f8bcb92624026ddb7fbbb37380b7412683e.zip
www/gitlab-ce: fix regression from 393f9a3b150a2b125e035f67ff6bff5e694cccac
-rw-r--r--www/Makefile1
-rw-r--r--www/gitlab-ce/Makefile2
-rw-r--r--www/rubygem-cssbundling-rails13-rails70/Makefile20
-rw-r--r--www/rubygem-cssbundling-rails13-rails70/distinfo3
-rw-r--r--www/rubygem-cssbundling-rails13-rails70/pkg-descr12
5 files changed, 38 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index c73871845fff..51af194f4639 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1972,6 +1972,7 @@
SUBDIR += rubygem-crass
SUBDIR += rubygem-cssbundling-rails
SUBDIR += rubygem-cssbundling-rails-rails70
+ SUBDIR += rubygem-cssbundling-rails13-rails70
SUBDIR += rubygem-cuba
SUBDIR += rubygem-d3_rails
SUBDIR += rubygem-davclient
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index caeb3af796b1..2065781ce458 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gitlab-ce
PORTVERSION= 16.9.0
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= www devel
@@ -192,6 +193,7 @@ MY_DEPENDS= git>=2.41.0:devel/git \
rubygem-gitlab_chronic_duration>=0.12<1:devel/rubygem-gitlab_chronic_duration \
rubygem-rack-proxy>=0.7.7<0.8.0:www/rubygem-rack-proxy \
rubygem-sassc-rails-rails70>=2.1.0<2.2.0:textproc/rubygem-sassc-rails-rails70 \
+ rubygem-cssbundling-rails13-rails70>=1.3.3<1.3.4:www/rubygem-cssbundling-rails13-rails70 \
rubygem-autoprefixer-rails1025>=10.2.5.1<10.2.6:textproc/rubygem-autoprefixer-rails1025 \
rubygem-terser>=1.0.2<1.0.3:textproc/rubygem-terser \
rubygem-addressable>=2.8<3:www/rubygem-addressable \
diff --git a/www/rubygem-cssbundling-rails13-rails70/Makefile b/www/rubygem-cssbundling-rails13-rails70/Makefile
new file mode 100644
index 000000000000..fff07b5e98f3
--- /dev/null
+++ b/www/rubygem-cssbundling-rails13-rails70/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= cssbundling-rails
+PORTVERSION= 1.3.3
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 13-rails70
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Bundle and process CSS with Tailwind, Bootstrap, PostCSS, Sass in Rails via Node.js
+WWW= https://github.com/rails/cssbundling-rails
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-railties70>=6.0.0:www/rubygem-railties70
+
+USES= gem
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-cssbundling-rails13-rails70/distinfo b/www/rubygem-cssbundling-rails13-rails70/distinfo
new file mode 100644
index 000000000000..34df7d30aeb8
--- /dev/null
+++ b/www/rubygem-cssbundling-rails13-rails70/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708666194
+SHA256 (rubygem/cssbundling-rails-1.3.3.gem) = 4aa13311e52a40bc0eb32ca651f44db8df03df273553cf9aeb022570607e1855
+SIZE (rubygem/cssbundling-rails-1.3.3.gem) = 11264
diff --git a/www/rubygem-cssbundling-rails13-rails70/pkg-descr b/www/rubygem-cssbundling-rails13-rails70/pkg-descr
new file mode 100644
index 000000000000..3bf0ef49a085
--- /dev/null
+++ b/www/rubygem-cssbundling-rails13-rails70/pkg-descr
@@ -0,0 +1,12 @@
+Use Tailwind CSS, Bootstrap, Bulma, PostCSS, or Dart Sass to bundle and process
+your CSS, then deliver it via the asset pipeline in Rails. This gem provides
+installers to get you going with the bundler of your choice in a new Rails
+application, and a convention to use app/assets/builds to hold your bundled
+output as artifacts that are not checked into source control (the installer adds
+this directory to .gitignore by default).
+
+You develop using this approach by running the bundler in watch mode in a
+terminal with yarn build:css --watch (and your Rails server in another, if
+you're not using something like puma-dev). You can also use ./bin/dev, which
+will start both the Rails server and the CSS build watcher (along with a JS
+build watcher, if you're also using jsbundling-rails).