aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2023-10-12 13:46:11 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2023-10-12 13:48:29 +0000
commit4dee77e291a24e0f77af08d789ac0080bd981b6a (patch)
tree7dd8b3dfca851e29b13b5ecaec84092eeb26f9ef
parent4e6d5662a21589d6406683aaffb1f28e7b9283e3 (diff)
downloadports-4dee77e291a24e0f77af08d789ac0080bd981b6a.tar.gz
ports-4dee77e291a24e0f77af08d789ac0080bd981b6a.zip
ftp/gftp: Update to 2.9.1b
PR: 272931
-rw-r--r--ftp/gftp/Makefile22
-rw-r--r--ftp/gftp/distinfo6
-rw-r--r--ftp/gftp/files/patch-lib-misc.c6
-rw-r--r--ftp/gftp/files/patch-lib-pty.c112
-rw-r--r--ftp/gftp/pkg-plist5
5 files changed, 38 insertions, 113 deletions
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index 41e45a1a1543..4f4bcf46efef 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -1,6 +1,5 @@
PORTNAME= gftp
-PORTVERSION= 2.7.0b
-PORTREVISION= 1
+PORTVERSION= 2.9.1b
CATEGORIES= ftp
MAINTAINER= oliver@FreeBSD.org
@@ -9,10 +8,15 @@ WWW= http://gftp.seul.org/
LICENSE= GPLv2
-USES= autoreconf gnome gmake libtool pathfix pkgconfig ssl tar:bzip2
+LIB_DEPENDS= libharfbuzz.so:print/harfbuzz \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= autoreconf desktop-file-utils gettext-tools gnome gmake pathfix \
+ pkgconfig ssl tar:bzip2
USE_GITHUB= yes
GH_ACCOUNT= masneyb
-USE_GNOME= glib20 gtk20
+USE_GNOME= cairo gdkpixbuf2 glib20 gtk20
GNU_CONFIGURE= yes
@@ -21,11 +25,15 @@ CFLAGS+= -D_WANT_SEMUN
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_USES= gettext
-NLS_USE= GNOME=intltool
+NLS_USES= gettext iconv
NLS_CONFIGURE_OFF= --disable-nls
+NLS_CONFIGURE_ENABLE= nls
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LIBS= -L${LOCALBASE}/lib -lintl
post-patch:
- @${TOUCH} ${WRKSRC}/config.rpath
+ @${MKDIR} ${WRKSRC}/autoconf
+ @${MKDIR} ${WRKSRC}/autoconf-m4
+ @${TOUCH} ${WRKSRC}/autoconf/config.rpath
.include <bsd.port.mk>
diff --git a/ftp/gftp/distinfo b/ftp/gftp/distinfo
index 48716137aad0..b7c590085e65 100644
--- a/ftp/gftp/distinfo
+++ b/ftp/gftp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1631708866
-SHA256 (masneyb-gftp-2.7.0b_GH0.tar.gz) = 164651e19c840e5df148e905fbfcf4d24c65204a2df078dc98ad6c95a421e7f4
-SIZE (masneyb-gftp-2.7.0b_GH0.tar.gz) = 1618157
+TIMESTAMP = 1691171339
+SHA256 (masneyb-gftp-2.9.1b_GH0.tar.gz) = fb134d5479a6b81251b9d37be7264fb8be6edb07bce98569e0e0ba9570587fd6
+SIZE (masneyb-gftp-2.9.1b_GH0.tar.gz) = 1556915
diff --git a/ftp/gftp/files/patch-lib-misc.c b/ftp/gftp/files/patch-lib-misc.c
index 9daf864e58ab..e8d2d5347378 100644
--- a/ftp/gftp/files/patch-lib-misc.c
+++ b/ftp/gftp/files/patch-lib-misc.c
@@ -6,11 +6,9 @@ its only argument is NULL, then this returned string was unreferenced.
lib/misc.c | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
-diff --git a/lib/misc.c b/lib/misc.c
-index 16c019b..2791466 100644
---- lib/misc.c.orig
+--- lib/misc.c.orig 2022-02-15 06:31:19 UTC
+++ lib/misc.c
-@@ -143,6 +143,8 @@ gftp_expand_path (gftp_request * request, const char *src)
+@@ -145,6 +145,8 @@ char * gftp_expand_path (gftp_request * request, const
tempchar;
struct passwd *pw;
diff --git a/ftp/gftp/files/patch-lib-pty.c b/ftp/gftp/files/patch-lib-pty.c
index 25f7c385ed39..9b0e8224fcc7 100644
--- a/ftp/gftp/files/patch-lib-pty.c
+++ b/ftp/gftp/files/patch-lib-pty.c
@@ -1,103 +1,25 @@
---- lib/pty.c.orig 2007-03-13 02:56:43.000000000 +0100
-+++ lib/pty.c 2010-01-17 17:34:25.000000000 +0100
-@@ -59,6 +59,50 @@
- return (new_fds);
- }
-
-+#elif HAVE_OPENPTY
-+
-+#ifdef HAVE_PTY_H
-+#include <pty.h>
-+#include <utmp.h> /* for login_tty */
-+#elif HAVE_LIBUTIL_H
-+#include <libutil.h>
+--- lib/pty.c.orig 2022-02-15 06:31:19 UTC
++++ lib/pty.c
+@@ -91,7 +91,9 @@ _gftp_ptys_open (int fdm, int fds, char *pts_name)
+ #include <utmp.h> /* for login_tty */
+ #elif HAVE_LIBUTIL_H
+ #include <libutil.h>
+-#include <utmp.h> /* for login_tty */
+#else
+extern int openpty(int *amaster, int *aslave, char *name, struct termios *termp, struct winsize * winp);
+extern int login_tty(int fd);
-+#endif
-+
-+char *
-+gftp_get_pty_impl (void)
-+{
-+ return ("openpty");
-+}
-+
-+
-+static int
-+_gftp_ptym_open (char *pts_name, size_t len, int *fds)
-+{
-+ int fdm;
-+
-+ if (openpty (&fdm, fds, pts_name, NULL, NULL) < 0)
-+ return (GFTP_ERETRYABLE);
-+
-+ ioctl (*fds, TIOCSCTTY, NULL);
-+
-+ return (fdm);
-+}
-+
-+
-+static int
-+_gftp_ptys_open (int fdm, int fds, char *pts_name)
-+{
+ #endif
+
+ char *
+@@ -118,8 +120,10 @@ _gftp_ptys_open (int fdm, int fds, char *pts_name)
+ static int
+ _gftp_ptys_open (int fdm, int fds, char *pts_name)
+ {
+- if (login_tty (fds) < 0)
+ if (login_tty (fds) < 0) {
+ close(fds);
-+ return (GFTP_EFATAL);
+ return (GFTP_EFATAL);
+ }
-+
-+ return (fds);
-+}
-+
- #elif HAVE_GRANTPT
- #if !(defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__))
-@@ -131,49 +192,6 @@
- return (new_fds);
+ return (fds);
}
-
--#elif HAVE_OPENPTY
--
--#ifdef HAVE_PTY_H
--#include <pty.h>
--#include <utmp.h> /* for login_tty */
--#elif HAVE_LIBUTIL_H
--#include <libutil.h>
--#include <utmp.h> /* for login_tty */
--#else
--extern int openpty(int *amaster, int *aslave, char *name, struct termios *termp, struct winsize * winp);
--extern int login_tty(int fd);
--#endif
--
--char *
--gftp_get_pty_impl (void)
--{
-- return ("openpty");
--}
--
--
--static int
--_gftp_ptym_open (char *pts_name, size_t len, int *fds)
--{
-- int fdm;
--
-- if (openpty (&fdm, fds, pts_name, NULL, NULL) < 0)
-- return (GFTP_ERETRYABLE);
--
-- ioctl (*fds, TIOCSCTTY, NULL);
--
-- return (fdm);
--}
--
--
--static int
--_gftp_ptys_open (int fdm, int fds, char *pts_name)
--{
-- if (login_tty (fds) < 0)
-- return (GFTP_EFATAL);
--
-- return (fds);
--}
--
- #else
-
- /* Fall back to *BSD... */
diff --git a/ftp/gftp/pkg-plist b/ftp/gftp/pkg-plist
index 2c94155062b4..de969bf2a895 100644
--- a/ftp/gftp/pkg-plist
+++ b/ftp/gftp/pkg-plist
@@ -3,7 +3,6 @@ bin/gftp-gtk
bin/gftp-text
man/man1/gftp.1.gz
share/applications/gftp.desktop
-share/pixmaps/gftp.png
share/icons/hicolor/16x16/apps/gftp.png
share/icons/hicolor/22x22/apps/gftp.png
share/icons/hicolor/32x32/apps/gftp.png
@@ -38,15 +37,13 @@ share/icons/hicolor/scalable/apps/gftp.svg
%%NLS%%share/locale/bn/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/bn_IN/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/bs/LC_MESSAGES/gftp.mo
-%%NLS%%share/locale/ca@valencia/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/ca/LC_MESSAGES/gftp.mo
+%%NLS%%share/locale/ca@valencia/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/cs/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/da/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/de/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/dz/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/el/LC_MESSAGES/gftp.mo
-%%NLS%%share/locale/en_CA/LC_MESSAGES/gftp.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/eo/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/es/LC_MESSAGES/gftp.mo
%%NLS%%share/locale/eu/LC_MESSAGES/gftp.mo