aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-13 00:02:24 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-03-13 00:02:24 +0000
commit4e0db8a7406485b81659c9b26b0629756faecc15 (patch)
treef311f188f359d789cca6ee651935b209ea415590
parent0245cf92ba84717f51da9491591e3f57bc88852a (diff)
downloadports-4e0db8a7406485b81659c9b26b0629756faecc15.tar.gz
ports-4e0db8a7406485b81659c9b26b0629756faecc15.zip
astro/geographiclib: fix build without libomp
CMake Error at /usr/local/share/cmake/Modules/FindOpenMP.cmake:261 (try_compile): Failed to generate test project build system. Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindOpenMP.cmake:537 (_OPENMP_GET_FLAGS) examples/CMakeLists.txt:35 (find_package)
-rw-r--r--astro/geographiclib/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/astro/geographiclib/Makefile b/astro/geographiclib/Makefile
index 30bba17d135a..7a58ee99f264 100644
--- a/astro/geographiclib/Makefile
+++ b/astro/geographiclib/Makefile
@@ -15,7 +15,12 @@ WWW= https://geographiclib.sourceforge.io/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake compiler:c++14-lang localbase python:env
+USES= cmake localbase python:env
+.if !exists(/usr/include/omp.h)
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++14-lang
+.endif
USE_LDCONFIG= yes
USE_PYTHON= optsuffix
CMAKE_ARGS= -DGEOGRAPHICLIB_DATA:STRING=${DATADIR:Q} \