aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-29 23:53:33 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-30 00:52:07 +0000
commit4e8188fdccdfea82c790727d5de82d9914d43971 (patch)
tree26fe949cac65a95002d430b2f1b3819a782c9b5d
parent4e0c2ae319222145ab0b3f37c0ba52f596426d5a (diff)
downloadports-4e8188fdccdfea82c790727d5de82d9914d43971.tar.gz
ports-4e8188fdccdfea82c790727d5de82d9914d43971.zip
devel/ucommon: Fix build with llvm16
Sponsored by: The FreeBSD Foundation
-rw-r--r--devel/ucommon/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/ucommon/Makefile b/devel/ucommon/Makefile
index d3ef1b5e554b..b86b69db4292 100644
--- a/devel/ucommon/Makefile
+++ b/devel/ucommon/Makefile
@@ -17,7 +17,13 @@ CMAKE_ARGS= -DBUILD_TESTING:BOOL=ON \
USE_LDCONFIG= yes
TEST_TARGET= test
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+USE_CXXSTD= c++11
+.endif
+
post-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/ucommon-config.h ${STAGEDIR}${PREFIX}/include/ucommon
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>