aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2024-01-21 12:24:18 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2024-01-21 12:24:18 +0000
commit4eb5db88a806780718a046270a83faeb20356b45 (patch)
tree737a0f555d2e7d7f5db82201e9ef8d2b88cab977
parent8e1ef0a11e90da1a05376b4c4984dc8ebfd31b70 (diff)
downloadports-4eb5db88a806780718a046270a83faeb20356b45.tar.gz
ports-4eb5db88a806780718a046270a83faeb20356b45.zip
misc/ddate: Move manpages to share/man
-rw-r--r--misc/ddate/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/misc/ddate/Makefile b/misc/ddate/Makefile
index 8a92839d59b6..f4a27064b64a 100644
--- a/misc/ddate/Makefile
+++ b/misc/ddate/Makefile
@@ -2,6 +2,7 @@ PORTNAME= ddate
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.2-6
DISTVERSIONSUFFIX= -g899ca66
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= misc
@@ -14,25 +15,25 @@ LICENSE= GPLv2
USE_GITHUB= yes
GH_ACCOUNT= bo0ts
-OPTIONS_DEFINE= USFORMAT PRAISEBOB KILLBOB
+PLIST_FILES= bin/ddate \
+ share/man/man1/ddate.1.gz
-USFORMAT_DESC= US time format
-PRAISEBOB_DESC= SubGenius slogans
-KILLBOB_DESC= Countdown to X-Day
+OPTIONS_DEFINE= KILLBOB PRAISEBOB USFORMAT
+OPTIONS_DEFAULT= KILLBOB
-OPTIONS_DEFAULT=KILLBOB
+KILLBOB_DESC= Countdown to X-Day
+PRAISEBOB_DESC= SubGenius slogans
+USFORMAT_DESC= US time format
-USFORMAT_CFLAGS= -DUS_FORMAT=\"1\"
-PRAISEBOB_CFLAGS= -DPRAISE_BOB=\"13013\"
KILLBOB_CFLAGS= -DKILL_BOB=\"13013\"
-
-PLIST_FILES= bin/ddate man/man1/ddate.1.gz
+PRAISEBOB_CFLAGS= -DPRAISE_BOB=\"13013\"
+USFORMAT_CFLAGS= -DUS_FORMAT=\"1\"
do-build:
${CC} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/share/man/man1
.include <bsd.port.mk>