aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-13 23:37:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-13 23:37:52 +0000
commit4ec1f052f21c47fbb2b310d945c756fd022dc521 (patch)
tree90dc33e5581baf3f8c3d2e164249e7a55392b42d
parentd341ae03875db36d33256def78d6a41fac24b8b5 (diff)
audio/rtaudio: Add PULSEAUDIO option to enable use with PulseAudio
PR: 255853 Reported by: Duane <parakleta@darkreality.org>
-rw-r--r--audio/rtaudio/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/audio/rtaudio/Makefile b/audio/rtaudio/Makefile
index 290989da485c..83cb2e4ac011 100644
--- a/audio/rtaudio/Makefile
+++ b/audio/rtaudio/Makefile
@@ -1,6 +1,6 @@
PORTNAME= rtaudio
DISTVERSION= 5.1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@@ -9,11 +9,22 @@ COMMENT= C++ classes that provide a common API for realtime audio input/output
LICENSE= MIT
USES= autoreconf compiler:c++11-lang libtool pkgconfig
+USE_LDCONFIG= yes
+
USE_GITHUB= yes
GH_ACCOUNT= thestk
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static
-USE_LDCONFIG= yes
+
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= PULSEAUDIO
+OPTIONS_DEFAULT= PULSEAUDIO
+
+PULSEAUDIO_CONFIGURE_WITH= pulse
+PULSEAUDIO_USES= localbase:ldflags
+PULSEAUDIO_LDFLAGS= -lpulse # see https://github.com/thestk/rtaudio/issues/293
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+
.include <bsd.port.mk>