aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLady Serena Kitty <jlhawkwell@ladyserenakitty.com>2022-09-14 21:43:21 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-09-14 21:44:30 +0000
commit4ed2ec5dacb007572a4da5b85f8d928a6ab93ce9 (patch)
treea33ac69a316ec3b3ed9f8a03cb45243112f3df62
parentf20d15f9c9696b4b65af296b238882e0c46ae213 (diff)
downloadports-4ed2ec5dacb007572a4da5b85f8d928a6ab93ce9.tar.gz
ports-4ed2ec5dacb007572a4da5b85f8d928a6ab93ce9.zip
security/diffcode: New port
Differential Revision: https://reviews.freebsd.org/D36586
-rw-r--r--security/Makefile1
-rw-r--r--security/diffcode/Makefile20
-rw-r--r--security/diffcode/distinfo3
-rw-r--r--security/diffcode/pkg-descr3
-rw-r--r--security/diffcode/pkg-plist4
5 files changed, 31 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f2313d2c6fb5..e583d051705f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -120,6 +120,7 @@
SUBDIR += dehydrated
SUBDIR += denyhosts
SUBDIR += destroy
+ SUBDIR += diffcode
SUBDIR += digestpp
SUBDIR += dirbuster
SUBDIR += dirmngr
diff --git a/security/diffcode/Makefile b/security/diffcode/Makefile
new file mode 100644
index 000000000000..2ec298b7c3a2
--- /dev/null
+++ b/security/diffcode/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= diffcode
+DISTVERSION= 1.2
+CATEGORIES= security
+MASTER_SITES= https://gitlab.com/LadySerenaKitty
+
+MAINTAINER= jlhawkwell@ladyserenakitty.com
+COMMENT= Progrssive differential cipher
+WWW= https://gitlab.com/LadySerenaKitty/diffcode
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+
+USE_GITLAB= yes
+GL_ACCOUNT= LadySerenaKitty
+GL_PROJECT= ${PORTNAME}
+GL_COMMIT= 4ae08b53b657ad2aa6816123b49709d903e4593c
+
+.include <bsd.port.mk>
diff --git a/security/diffcode/distinfo b/security/diffcode/distinfo
new file mode 100644
index 000000000000..2ac3ff854f98
--- /dev/null
+++ b/security/diffcode/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1663188469
+SHA256 (LadySerenaKitty-diffcode-4ae08b53b657ad2aa6816123b49709d903e4593c_GL0.tar.gz) = 051d0ab36deb492509f477110ad491af9f034dbdcf7de771913f26ca0571d1cf
+SIZE (LadySerenaKitty-diffcode-4ae08b53b657ad2aa6816123b49709d903e4593c_GL0.tar.gz) = 2660
diff --git a/security/diffcode/pkg-descr b/security/diffcode/pkg-descr
new file mode 100644
index 000000000000..2e5657bd6724
--- /dev/null
+++ b/security/diffcode/pkg-descr
@@ -0,0 +1,3 @@
+diffcode is a project that can encode and decode using the progressive
+differential algorithm. During encoding, the difference between the binary
+values of each input character is calculated and that difference is output.
diff --git a/security/diffcode/pkg-plist b/security/diffcode/pkg-plist
new file mode 100644
index 000000000000..edf0a3aa99cd
--- /dev/null
+++ b/security/diffcode/pkg-plist
@@ -0,0 +1,4 @@
+bin/dediff
+bin/endiff
+include/diffcode.h
+lib/libdiffcode.so