aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-05-01 04:28:36 +0000
committerCy Schubert <cy@FreeBSD.org>2011-05-01 04:28:36 +0000
commit4f26baad22fb5156b9638f65c81fbc6c85fd61b8 (patch)
treee899e7f8c1346ce1749cde63d11ad716e55de3de
parent88c448ad2cf316066dfd5f136c2107e6dba55305 (diff)
downloadports-4f26baad22fb5156b9638f65c81fbc6c85fd61b8.tar.gz
ports-4f26baad22fb5156b9638f65c81fbc6c85fd61b8.zip
Add support for KOI8-U.
PR: ports/156031 Submitted by: Valentin Nechayev <netch@netch.kiev.ua>
Notes
Notes: svn path=/head/; revision=273389
-rw-r--r--sysutils/screen/Makefile3
-rw-r--r--sysutils/screen/files/patch-ansi.h11
-rw-r--r--sysutils/screen/files/patch-doc_screen.115
-rw-r--r--sysutils/screen/files/patch-doc_screen.texinfo13
-rw-r--r--sysutils/screen/files/patch-encoding.c19
-rw-r--r--sysutils/screen/files/uue-utf8encodings_a315
-rw-r--r--sysutils/screen/pkg-plist1
7 files changed, 76 insertions, 1 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index 90af8d572ea1..bdd9d5845ee6 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= screen
PORTVERSION= 4.0.3
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
http://komquats.com/distfiles/ \
@@ -74,6 +74,7 @@ EXTRA_PATCHES+= ${FILESDIR}/opt-showencoding
post-patch:
@${RM} ${WRKSRC}/doc/screen.info*
@${REINPLACE_CMD} -e 's|/dev/ptmx|/nonexistent|' ${WRKSRC}/configure
+ uudecode -o ${WRKSRC}/utf8encodings/a3 ${FILESDIR}/uue-utf8encodings_a3
post-install:
@${MKDIR} ${EXAMPLESDIR}
diff --git a/sysutils/screen/files/patch-ansi.h b/sysutils/screen/files/patch-ansi.h
new file mode 100644
index 000000000000..aa0168c3ea12
--- /dev/null
+++ b/sysutils/screen/files/patch-ansi.h
@@ -0,0 +1,11 @@
+diff -u -rNu ansi.h ansi.h
+--- ansi.h 2003-02-24 18:55:08.000000000 +0200
++++ ansi.h 2011-03-29 11:24:20.212563516 +0300
+@@ -127,6 +127,7 @@
+ #define BIG5 5
+ #define KOI8R 6
+ #define CP1251 7
++#define KOI8U 8
+ #define GBK 20
+
+ #define EUC EUC_JP
diff --git a/sysutils/screen/files/patch-doc_screen.1 b/sysutils/screen/files/patch-doc_screen.1
new file mode 100644
index 000000000000..5075a12e7c4e
--- /dev/null
+++ b/sysutils/screen/files/patch-doc_screen.1
@@ -0,0 +1,15 @@
+diff -u -rNu doc/screen.1 doc/screen.1
+--- doc/screen.1 2003-12-05 15:51:57.000000000 +0200
++++ doc/screen.1 2011-03-29 11:22:55.739089194 +0300
+@@ -1688,8 +1688,9 @@
+ There is also a way to select a terminal encoding depending on
+ the terminal type by using the \*QKJ\*U termcap entry.
+
+-Supported encodings are eucJP, SJIS, eucKR, eucCN, Big5, GBK, KOI8-R,
+-CP1251, UTF-8, ISO8859-2, ISO8859-3, ISO8859-4, ISO8859-5, ISO8859-6,
++Supported encodings are eucJP, SJIS, eucKR, eucCN, Big5, GBK,
++KOI8-R, KOI8-U, CP1251, UTF-8,
++ISO8859-2, ISO8859-3, ISO8859-4, ISO8859-5, ISO8859-6,
+ ISO8859-7, ISO8859-8, ISO8859-9, ISO8859-10, ISO8859-15, jis.
+
+ See also \*Qdefencoding\*U, which changes the default setting of a new
diff --git a/sysutils/screen/files/patch-doc_screen.texinfo b/sysutils/screen/files/patch-doc_screen.texinfo
new file mode 100644
index 000000000000..68eb8d6f596e
--- /dev/null
+++ b/sysutils/screen/files/patch-doc_screen.texinfo
@@ -0,0 +1,13 @@
+diff -u -rNu doc/screen.texinfo doc/screen.texinfo
+--- doc/screen.texinfo 2003-12-05 15:51:46.000000000 +0200
++++ doc/screen.texinfo 2011-03-29 11:22:30.536269863 +0300
+@@ -2726,7 +2726,8 @@
+
+ Supported encodings are
+ @code{eucJP}, @code{SJIS}, @code{eucKR},
+-@code{eucCN}, @code{Big5}, @code{GBK}, @code{KOI8-R}, @code{CP1251},
++@code{eucCN}, @code{Big5}, @code{GBK},
++@code{KOI8-R}, @code{KOI8-U}, @code{CP1251},
+ @code{UTF-8}, @code{ISO8859-2}, @code{ISO8859-3},
+ @code{ISO8859-4}, @code{ISO8859-5}, @code{ISO8859-6},
+ @code{ISO8859-7}, @code{ISO8859-8}, @code{ISO8859-9},
diff --git a/sysutils/screen/files/patch-encoding.c b/sysutils/screen/files/patch-encoding.c
new file mode 100644
index 000000000000..28866a9cbce2
--- /dev/null
+++ b/sysutils/screen/files/patch-encoding.c
@@ -0,0 +1,19 @@
+diff -u -rNu encoding.c encoding.c
+--- encoding.c 2006-10-23 15:58:14.000000000 +0300
++++ encoding.c 2011-03-29 11:23:56.454204244 +0300
+@@ -57,6 +57,7 @@
+
+ /* big5 font: ^X */
+ /* KOI8-R font: 96 ! */
++/* KOI8-U font: 96 # */
+ /* CP1251 font: 96 ? */
+
+ struct encoding encodings[] = {
+@@ -67,6 +68,7 @@
+ { "eucCN", "B\001BB01", 0, 1, 0, "\001" },
+ { "Big5", "B\030BB01", 0, 1, 0, "\030" },
+ { "KOI8-R", 0, 0x80|'!', 0, 1, 0 },
++ { "KOI8-U", 0, 0x80|'#', 0, 1, 0 },
+ { "CP1251", 0, 0x80|'?', 0, 1, 0 },
+ { "UTF-8", 0, -1, 0, 0, 0 },
+ { "ISO8859-2", 0, 0x80|'B', 0, 0, 0 },
diff --git a/sysutils/screen/files/uue-utf8encodings_a3 b/sysutils/screen/files/uue-utf8encodings_a3
new file mode 100644
index 000000000000..243c00ef0b4b
--- /dev/null
+++ b/sysutils/screen/files/uue-utf8encodings_a3
@@ -0,0 +1,15 @@
+begin 644 a3
+M4V-R965N23)55$8X`*,`@$M/23@M50```(`E``"!)0(`@B4,`(,E$`"$)10`
+MA248`(8E'`"')20`B"4L`(DE-`"*)3P`BR6``(PEA`"-)8@`CB6,`(\ED`"0
+M)9$`D262`)(EDP"3(R``E"6@`)4B&0"6(AH`ER)(`)@B9`"9(F4`F@"@`)LC
+M(0"<`+``G0"R`)X`MP"?`/<`H"50`*$E40"B)5(`HP11`*0$5`"E)50`I@16
+M`*<$5P"H)5<`J258`*HE60"K)5H`K"5;`*T$D0"N)5T`KR5>`+`E7P"Q)6``
+MLB5A`+,$`0"T!`,`M25C`+8$!@"W!`<`N"5F`+DE9P"Z)6@`NR5I`+PE:@"]
+M!)``OB5L`+\`J0#`!$X`P00P`,($,0##!$8`Q`0T`,4$-0#&!$0`QP0S`,@$
+M10#)!#@`R@0Y`,L$.@#,!#L`S00\`,X$/0#/!#X`T`0_`-$$3P#2!$``TP1!
+M`-0$0@#5!$,`U@0V`-<$,@#8!$P`V01+`-H$-P#;!$@`W`1-`-T$20#>!$<`
+MWP1*`.`$+@#A!!``X@01`.,$)@#D!!0`Y005`.8$)`#G!!,`Z`0E`.D$&`#J
+M!!D`ZP0:`.P$&P#M!!P`[@0=`.\$'@#P!!\`\00O`/($(`#S!"$`]`0B`/4$
+I(P#V!!8`]P02`/@$+`#Y!"L`^@07`/L$*`#\!"T`_00I`/X$)P#_!"H`
+`
+end
diff --git a/sysutils/screen/pkg-plist b/sysutils/screen/pkg-plist
index 4bf7b39f7bc4..9e815416458c 100644
--- a/sysutils/screen/pkg-plist
+++ b/sysutils/screen/pkg-plist
@@ -6,6 +6,7 @@ bin/screen
%%DATADIR%%/utf8encodings/18
%%DATADIR%%/utf8encodings/19
%%DATADIR%%/utf8encodings/a1
+%%DATADIR%%/utf8encodings/a3
%%DATADIR%%/utf8encodings/bf
%%DATADIR%%/utf8encodings/c2
%%DATADIR%%/utf8encodings/c3