aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-08-10 19:01:26 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-08-10 19:01:26 +0000
commit4f7fcd1bccb37848f412426a0b168f0845ac7d68 (patch)
treecba6a402318fe1d42315e86ca1845fef651cb9b0
parent1d76dde1a4d7ce082e2d8bd8d2f6e2f5f7615b7d (diff)
downloadports-4f7fcd1bccb37848f412426a0b168f0845ac7d68.tar.gz
ports-4f7fcd1bccb37848f412426a0b168f0845ac7d68.zip
Unbreak build of p5-[Pp]od*
PR: ports/70185 Submitted by: Yen-Ming Lee <leeym@FreeBSD.org>
Notes
Notes: svn path=/head/; revision=115863
-rw-r--r--textproc/p5-Pod-Constants/Makefile14
-rw-r--r--textproc/p5-Pod-Parser/Makefile21
-rw-r--r--textproc/p5-Pod-Parser/pkg-descr3
-rw-r--r--textproc/p5-Pod-Parser/pkg-plist6
-rw-r--r--textproc/p5-Pod-Stripper/Makefile15
-rw-r--r--textproc/p5-PodParser/Makefile21
-rw-r--r--textproc/p5-PodParser/pkg-descr3
-rw-r--r--textproc/p5-PodParser/pkg-plist6
-rw-r--r--textproc/p5-podlators/Makefile22
-rw-r--r--textproc/p5-podlators/pkg-descr3
-rw-r--r--textproc/p5-podlators/pkg-plist4
11 files changed, 62 insertions, 56 deletions
diff --git a/textproc/p5-Pod-Constants/Makefile b/textproc/p5-Pod-Constants/Makefile
index 131c67581f23..795683ef71c2 100644
--- a/textproc/p5-Pod-Constants/Makefile
+++ b/textproc/p5-Pod-Constants/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Pod-Constants
PORTVERSION= 0.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/S/SA/SAMV
@@ -16,15 +16,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Include constants from POD
+BUILD_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= Pod::Constants.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index e4fc220ae6be..17e68b754b8d 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PodParser
PORTVERSION= 1.28
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -23,16 +24,22 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
-CONFLICTS= perl-5.6.* perl-5.8.*
+.include <bsd.port.pre.mk>
-post-patch:
- @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
+PLIST_SUB= PL_FILES=""
-.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.elif ${PERL_LEVEL} < 500802
+.undef MAN1
+PLIST_SUB= PL_FILES="@comment "
+.endif
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${BUILD_DEPENDS}
+post-patch:
+.if ${PERL_LEVEL} >= 500600 && ${PERL_LEVEL} < 500802
+ @${PERL} -pi -e 'm,_FILES, && s,.,,sg' ${WRKSRC}/Makefile.PL
.endif
+ @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
.include <bsd.port.post.mk>
diff --git a/textproc/p5-Pod-Parser/pkg-descr b/textproc/p5-Pod-Parser/pkg-descr
index dbfd043fc772..52476fcb8f2b 100644
--- a/textproc/p5-Pod-Parser/pkg-descr
+++ b/textproc/p5-Pod-Parser/pkg-descr
@@ -10,6 +10,3 @@ Set of modules:
* Pod::Find - find POD documents in directory trees
WWW: http://search.cpan.org/dist/PodParser/
-
--- Sergey Skvortsov
-skv@FreeBSD.org
diff --git a/textproc/p5-Pod-Parser/pkg-plist b/textproc/p5-Pod-Parser/pkg-plist
index 1fce1057e5e8..767ad94ec02d 100644
--- a/textproc/p5-Pod-Parser/pkg-plist
+++ b/textproc/p5-Pod-Parser/pkg-plist
@@ -1,6 +1,6 @@
-bin/pod2usage
-bin/podchecker
-bin/podselect
+%%PL_FILES%%bin/pod2usage
+%%PL_FILES%%bin/podchecker
+%%PL_FILES%%bin/podselect
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Parser/.packlist
%%SITE_PERL%%/Pod/Checker.pm
%%SITE_PERL%%/Pod/Find.pm
diff --git a/textproc/p5-Pod-Stripper/Makefile b/textproc/p5-Pod-Stripper/Makefile
index d684b7c8e74a..cca5d55dc9ce 100644
--- a/textproc/p5-Pod-Stripper/Makefile
+++ b/textproc/p5-Pod-Stripper/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Pod-Stripper
PORTVERSION= 0.22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -16,6 +16,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Strip all pod, and output what's left
+BUILD_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
CONFIGURE_ARGS= INSTALLDIRS="site"
@@ -25,12 +28,4 @@ MAN3= Pod::Stripper.3
post-patch:
@${FIND} ${WRKSRC} -type f|${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//;'
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/p5-PodParser/Makefile b/textproc/p5-PodParser/Makefile
index e4fc220ae6be..17e68b754b8d 100644
--- a/textproc/p5-PodParser/Makefile
+++ b/textproc/p5-PodParser/Makefile
@@ -7,6 +7,7 @@
PORTNAME= PodParser
PORTVERSION= 1.28
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -23,16 +24,22 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
Pod::ParseUtils.3 Pod::Parser.3 Pod::PlainText.3 Pod::Select.3 \
Pod::Usage.3
-CONFLICTS= perl-5.6.* perl-5.8.*
+.include <bsd.port.pre.mk>
-post-patch:
- @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
+PLIST_SUB= PL_FILES=""
-.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.elif ${PERL_LEVEL} < 500802
+.undef MAN1
+PLIST_SUB= PL_FILES="@comment "
+.endif
-.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${BUILD_DEPENDS}
+post-patch:
+.if ${PERL_LEVEL} >= 500600 && ${PERL_LEVEL} < 500802
+ @${PERL} -pi -e 'm,_FILES, && s,.,,sg' ${WRKSRC}/Makefile.PL
.endif
+ @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
.include <bsd.port.post.mk>
diff --git a/textproc/p5-PodParser/pkg-descr b/textproc/p5-PodParser/pkg-descr
index dbfd043fc772..52476fcb8f2b 100644
--- a/textproc/p5-PodParser/pkg-descr
+++ b/textproc/p5-PodParser/pkg-descr
@@ -10,6 +10,3 @@ Set of modules:
* Pod::Find - find POD documents in directory trees
WWW: http://search.cpan.org/dist/PodParser/
-
--- Sergey Skvortsov
-skv@FreeBSD.org
diff --git a/textproc/p5-PodParser/pkg-plist b/textproc/p5-PodParser/pkg-plist
index 1fce1057e5e8..767ad94ec02d 100644
--- a/textproc/p5-PodParser/pkg-plist
+++ b/textproc/p5-PodParser/pkg-plist
@@ -1,6 +1,6 @@
-bin/pod2usage
-bin/podchecker
-bin/podselect
+%%PL_FILES%%bin/pod2usage
+%%PL_FILES%%bin/podchecker
+%%PL_FILES%%bin/podselect
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Parser/.packlist
%%SITE_PERL%%/Pod/Checker.pm
%%SITE_PERL%%/Pod/Find.pm
diff --git a/textproc/p5-podlators/Makefile b/textproc/p5-podlators/Makefile
index 11758ac3cfe6..4998b276f429 100644
--- a/textproc/p5-podlators/Makefile
+++ b/textproc/p5-podlators/Makefile
@@ -7,7 +7,7 @@
PORTNAME= podlators
PORTVERSION= 1.27
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Pod
@@ -16,6 +16,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Modules to convert and parse POD (Plain Old Documentation)
+RUN_DEPENDS= ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
PERL_CONFIGURE= yes
CONFIGURE_ARGS= INSTALLDIRS=site
@@ -23,14 +26,21 @@ MAN1= pod2man.1 pod2text.1
MAN3= Pod::Man.3 Pod::ParseLink.3 Pod::Text.3 Pod::Text::Color.3 \
Pod::Text::Overstrike.3 Pod::Text::Termcap.3
-CONFLICTS= perl-5.6.* perl-5.8.*
-
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500601
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
- ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-PodParser \
+PLIST_SUB= PL_FILES=""
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
+.elif ${PERL_LEVEL} < 500802
+.undef MAN1
+PLIST_SUB= PL_FILES="@comment "
+.endif
+
+post-patch:
+.if ${PERL_LEVEL} >= 500600 && ${PERL_LEVEL} < 500802
+ @${PERL} -pi -e 'm,pod2man|pod2text, && s,.,,sg' ${WRKSRC}/Makefile.PL
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/p5-podlators/pkg-descr b/textproc/p5-podlators/pkg-descr
index a75072cc0faf..bbaadb8cd590 100644
--- a/textproc/p5-podlators/pkg-descr
+++ b/textproc/p5-podlators/pkg-descr
@@ -7,6 +7,3 @@ Set of modules:
* Pod::Text::Overstrike - convert POD data to formatted overstrike text
WWW: http://search.cpan.org/dist/podlators/
-
--- Sergey Skvortsov
-skv@FreeBSD.org
diff --git a/textproc/p5-podlators/pkg-plist b/textproc/p5-podlators/pkg-plist
index 8e6d9f6acc6a..63a817c1e6f9 100644
--- a/textproc/p5-podlators/pkg-plist
+++ b/textproc/p5-podlators/pkg-plist
@@ -1,5 +1,5 @@
-bin/pod2man
-bin/pod2text
+%%PL_FILES%%bin/pod2man
+%%PL_FILES%%bin/pod2text
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/.packlist
%%SITE_PERL%%/Pod/Man.pm
%%SITE_PERL%%/Pod/ParseLink.pm